Results 1 to 10 of 10

Thread: hd7870 black screen

  1. #1
    Member
    Join Date
    Aug 2003
    Location
    UK
    Posts
    109
    Thanks
    6
    Thanked
    2 times in 2 posts
    • hatsumi's system
      • Motherboard:
      • Gigabyte Z77X-D3H
      • CPU:
      • i5 3570K
      • Memory:
      • 8Gb DD3 Corsair Dominator 1600
      • Storage:
      • 5 HD total around 2.5TB
      • Graphics card(s):
      • Sapphire HD7870 Ghz OC 2GB
      • PSU:
      • Aerocool 750W
      • Case:
      • Cooler Master HAF932 Adv
      • Operating System:
      • Win8 Pro 64
      • Monitor(s):
      • Belinea 20.1"
      • Internet:
      • VM 100MB

    hd7870 black screen

    I've just got one of these and have fitted it and installed cat 12.8 drivers after removing nvidia. I tried guild wars2 and Diablo 3. Both caused a black screen and sound loops within 5 mins of playing.

    I think I've sort of solved the issue by disabling the 5 entries for AMD hdmi sound that were added on driver install. I didn't have a lot of testing time, but managed to get gw2 in game and fast travel to lions arch. I also managed about 15 minutes in hitman sniper challenge.

    Is there a better or proper fix? I'll be testing more after work tonight. I don't want to have the hassle of rma.
    Les - SteeliXS
    Gaming |i5 3570K (stock at mo)|2x4096 MB Corsair DDR3 1600|Gigabyte Z77X-D3H|Sapphire HD7870 OC Ghz 2Gb|WIN8 Pro 64bit|CM HAF 932 Adv
    media |LG 42LS575T Television as extender replacing PC with Samsung BD-E5500 blu ray|

  2. #2
    Member
    Join Date
    Aug 2003
    Location
    UK
    Posts
    109
    Thanks
    6
    Thanked
    2 times in 2 posts
    • hatsumi's system
      • Motherboard:
      • Gigabyte Z77X-D3H
      • CPU:
      • i5 3570K
      • Memory:
      • 8Gb DD3 Corsair Dominator 1600
      • Storage:
      • 5 HD total around 2.5TB
      • Graphics card(s):
      • Sapphire HD7870 Ghz OC 2GB
      • PSU:
      • Aerocool 750W
      • Case:
      • Cooler Master HAF932 Adv
      • Operating System:
      • Win8 Pro 64
      • Monitor(s):
      • Belinea 20.1"
      • Internet:
      • VM 100MB

    Re: hd7870 black screen

    Well don't I feel silly. Played a bit of GTA4 then moved onto CS:GO. hard lock with a Black screen and funky sound after 10 minutes. Really feel like going back to an nvidia card :/
    Last edited by hatsumi; 17-09-2012 at 10:22 PM.
    Les - SteeliXS
    Gaming |i5 3570K (stock at mo)|2x4096 MB Corsair DDR3 1600|Gigabyte Z77X-D3H|Sapphire HD7870 OC Ghz 2Gb|WIN8 Pro 64bit|CM HAF 932 Adv
    media |LG 42LS575T Television as extender replacing PC with Samsung BD-E5500 blu ray|

  3. #3
    Senior Member
    Join Date
    Jun 2012
    Posts
    2,305
    Thanks
    83
    Thanked
    147 times in 141 posts

    Re: hd7870 black screen

    Are you sure you fully removed the old drivers? Isn't there some tool you have to run?

    http://www.overclock.net/t/1150443/h...ia-gpu-drivers

  4. #4
    Member
    Join Date
    Aug 2003
    Location
    UK
    Posts
    109
    Thanks
    6
    Thanked
    2 times in 2 posts
    • hatsumi's system
      • Motherboard:
      • Gigabyte Z77X-D3H
      • CPU:
      • i5 3570K
      • Memory:
      • 8Gb DD3 Corsair Dominator 1600
      • Storage:
      • 5 HD total around 2.5TB
      • Graphics card(s):
      • Sapphire HD7870 Ghz OC 2GB
      • PSU:
      • Aerocool 750W
      • Case:
      • Cooler Master HAF932 Adv
      • Operating System:
      • Win8 Pro 64
      • Monitor(s):
      • Belinea 20.1"
      • Internet:
      • VM 100MB

    Re: hd7870 black screen

    I've literally just rebooted after running driver sweeper. Time to see if it still crashes or stabilises now.
    Les - SteeliXS
    Gaming |i5 3570K (stock at mo)|2x4096 MB Corsair DDR3 1600|Gigabyte Z77X-D3H|Sapphire HD7870 OC Ghz 2Gb|WIN8 Pro 64bit|CM HAF 932 Adv
    media |LG 42LS575T Television as extender replacing PC with Samsung BD-E5500 blu ray|

  5. #5
    Member
    Join Date
    Aug 2003
    Location
    UK
    Posts
    109
    Thanks
    6
    Thanked
    2 times in 2 posts
    • hatsumi's system
      • Motherboard:
      • Gigabyte Z77X-D3H
      • CPU:
      • i5 3570K
      • Memory:
      • 8Gb DD3 Corsair Dominator 1600
      • Storage:
      • 5 HD total around 2.5TB
      • Graphics card(s):
      • Sapphire HD7870 Ghz OC 2GB
      • PSU:
      • Aerocool 750W
      • Case:
      • Cooler Master HAF932 Adv
      • Operating System:
      • Win8 Pro 64
      • Monitor(s):
      • Belinea 20.1"
      • Internet:
      • VM 100MB

    Re: hd7870 black screen

    POS black screened during the intro sequence of Dead Island.
    Les - SteeliXS
    Gaming |i5 3570K (stock at mo)|2x4096 MB Corsair DDR3 1600|Gigabyte Z77X-D3H|Sapphire HD7870 OC Ghz 2Gb|WIN8 Pro 64bit|CM HAF 932 Adv
    media |LG 42LS575T Television as extender replacing PC with Samsung BD-E5500 blu ray|

  6. #6
    Member
    Join Date
    Aug 2003
    Location
    UK
    Posts
    109
    Thanks
    6
    Thanked
    2 times in 2 posts
    • hatsumi's system
      • Motherboard:
      • Gigabyte Z77X-D3H
      • CPU:
      • i5 3570K
      • Memory:
      • 8Gb DD3 Corsair Dominator 1600
      • Storage:
      • 5 HD total around 2.5TB
      • Graphics card(s):
      • Sapphire HD7870 Ghz OC 2GB
      • PSU:
      • Aerocool 750W
      • Case:
      • Cooler Master HAF932 Adv
      • Operating System:
      • Win8 Pro 64
      • Monitor(s):
      • Belinea 20.1"
      • Internet:
      • VM 100MB

    Re: hd7870 black screen

    Seems to be stabilised using an amended CCC profile (basically upping voltage in 2d to same as 3d in /ATI/ACE/Profiles.xml) and MSI afterburner to manually switch between 2d mode with lower clocks and fan speed (525/625/33) and 3d mode with higher clocks (card defaults) and fan speed (1050/1250/50). Also disabled ULPS in registry (won't auto switch).

    At 100% GPU use, temp topped out at 53c at 50% fan speed. played Dead Island without issue and Batman Arkham City without issue.

    I have to use both programs together to get this working, otherwise it seems the card drops to 300/150 gpu/ram which I think is part of the problem as it kept dropping to these every 5 seconds even under 100% load, although I can't be certain seeing as also I upped the voltage in 2d so even if core speed drops the voltage doesn't. This I believe is what was causing the crashing. This doesn't happen using the above combo for some reason, as I tried both CCC and AB on their own and couldn't replicate the stability.

    Now if only it all just worked out of the box...

    (Monitored everything with gpu-z)
    Les - SteeliXS
    Gaming |i5 3570K (stock at mo)|2x4096 MB Corsair DDR3 1600|Gigabyte Z77X-D3H|Sapphire HD7870 OC Ghz 2Gb|WIN8 Pro 64bit|CM HAF 932 Adv
    media |LG 42LS575T Television as extender replacing PC with Samsung BD-E5500 blu ray|

  7. #7
    Registered+
    Join Date
    Sep 2012
    Posts
    70
    Thanks
    0
    Thanked
    1 time in 1 post
    • Oswald's system
      • Motherboard:
      • ASUS M4A77TD PRO
      • CPU:
      • AMD PHENOM II X4 955 @3.6
      • Memory:
      • 8GB KINGSTON 1600
      • Storage:
      • OCZ AGILITY & WD CAVIAR BLUE
      • Graphics card(s):
      • SAPPHIRE 7870 OC
      • PSU:
      • ANTEC EARTHWATTS 500
      • Case:
      • ANTEC SONATA III
      • Operating System:
      • WIN 7 ULTIMATE 64BIT
      • Monitor(s):
      • PHILLIPS 37" LCD
      • Internet:
      • TELENET CABLE

    Re: hd7870 black screen

    I read about this problem AFTER I ordered my 7870 and was afraid of getting the same issue. But it turns out my card is working fine.
    But since yesterday there is a 12.9 version of the drivers online. Maybe you can try those to see if there is any improvement?

  8. #8
    Member
    Join Date
    Aug 2003
    Location
    UK
    Posts
    109
    Thanks
    6
    Thanked
    2 times in 2 posts
    • hatsumi's system
      • Motherboard:
      • Gigabyte Z77X-D3H
      • CPU:
      • i5 3570K
      • Memory:
      • 8Gb DD3 Corsair Dominator 1600
      • Storage:
      • 5 HD total around 2.5TB
      • Graphics card(s):
      • Sapphire HD7870 Ghz OC 2GB
      • PSU:
      • Aerocool 750W
      • Case:
      • Cooler Master HAF932 Adv
      • Operating System:
      • Win8 Pro 64
      • Monitor(s):
      • Belinea 20.1"
      • Internet:
      • VM 100MB

    Re: hd7870 black screen

    Quote Originally Posted by hatsumi View Post
    Seems to be stabilised using an amended CCC profile (basically upping voltage in 2d to same as 3d in /ATI/ACE/Profiles.xml) and MSI afterburner to manually switch between 2d mode with lower clocks and fan speed (525/625/33) and 3d mode with higher clocks (card defaults) and fan speed (1050/1250/50). Also disabled ULPS in registry (won't auto switch).

    At 100% GPU use, temp topped out at 53c at 50% fan speed. played Dead Island without issue and Batman Arkham City without issue.

    I have to use both programs together to get this working, otherwise it seems the card drops to 300/150 gpu/ram which I think is part of the problem as it kept dropping to these every 5 seconds even under 100% load, although I can't be certain seeing as also I upped the voltage in 2d so even if core speed drops the voltage doesn't. This I believe is what was causing the crashing. This doesn't happen using the above combo for some reason, as I tried both CCC and AB on their own and couldn't replicate the stability.

    Now if only it all just worked out of the box...

    (Monitored everything with gpu-z)
    I can't be arsed on any more, black screen and constant hard locks trying to play xcom and dishonored. I've reinstalled mt GTX460 and I'm taking the 7870 back to the store tomorrow.

    I'm put right off AMD Hardware now, and I never used to really care as long as there was a good priceerformance.
    Les - SteeliXS
    Gaming |i5 3570K (stock at mo)|2x4096 MB Corsair DDR3 1600|Gigabyte Z77X-D3H|Sapphire HD7870 OC Ghz 2Gb|WIN8 Pro 64bit|CM HAF 932 Adv
    media |LG 42LS575T Television as extender replacing PC with Samsung BD-E5500 blu ray|

  9. #9
    Member
    Join Date
    Aug 2003
    Location
    UK
    Posts
    109
    Thanks
    6
    Thanked
    2 times in 2 posts
    • hatsumi's system
      • Motherboard:
      • Gigabyte Z77X-D3H
      • CPU:
      • i5 3570K
      • Memory:
      • 8Gb DD3 Corsair Dominator 1600
      • Storage:
      • 5 HD total around 2.5TB
      • Graphics card(s):
      • Sapphire HD7870 Ghz OC 2GB
      • PSU:
      • Aerocool 750W
      • Case:
      • Cooler Master HAF932 Adv
      • Operating System:
      • Win8 Pro 64
      • Monitor(s):
      • Belinea 20.1"
      • Internet:
      • VM 100MB

    Re: hd7870 black screen

    Card swapped, replacement works fine. All it has is those micro stutters as it switches between 2d and and 3d clocks depending on GPU load. That at least is easy solved!
    Les - SteeliXS
    Gaming |i5 3570K (stock at mo)|2x4096 MB Corsair DDR3 1600|Gigabyte Z77X-D3H|Sapphire HD7870 OC Ghz 2Gb|WIN8 Pro 64bit|CM HAF 932 Adv
    media |LG 42LS575T Television as extender replacing PC with Samsung BD-E5500 blu ray|

  10. #10
    Member
    Join Date
    Aug 2003
    Location
    UK
    Posts
    109
    Thanks
    6
    Thanked
    2 times in 2 posts
    • hatsumi's system
      • Motherboard:
      • Gigabyte Z77X-D3H
      • CPU:
      • i5 3570K
      • Memory:
      • 8Gb DD3 Corsair Dominator 1600
      • Storage:
      • 5 HD total around 2.5TB
      • Graphics card(s):
      • Sapphire HD7870 Ghz OC 2GB
      • PSU:
      • Aerocool 750W
      • Case:
      • Cooler Master HAF932 Adv
      • Operating System:
      • Win8 Pro 64
      • Monitor(s):
      • Belinea 20.1"
      • Internet:
      • VM 100MB

    Re: hd7870 black screen

    And that didn't last long. Now have to send my replacement to Czech republic to be replaced. Apparently a lot of AMD partners were using defective ceramic capacitors on the gpu.
    Les - SteeliXS
    Gaming |i5 3570K (stock at mo)|2x4096 MB Corsair DDR3 1600|Gigabyte Z77X-D3H|Sapphire HD7870 OC Ghz 2Gb|WIN8 Pro 64bit|CM HAF 932 Adv
    media |LG 42LS575T Television as extender replacing PC with Samsung BD-E5500 blu ray|

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •