Page 1 of 2 12 LastLast
Results 1 to 16 of 30

Thread: Can't play, riddick escape from butcher bay

  1. #1
    Banned Smokey21's Avatar
    Join Date
    May 2005
    Location
    Stafford, Midlands
    Posts
    1,752
    Thanks
    0
    Thanked
    0 times in 0 posts

    Can't play, riddick escape from butcher bay

    I get an Open GL error or some crap when i try to open the game.

    I try to install the patch, and it tells me some crap like a file was found or somet **** like that and it doesn't install.

    So what is going on? Suppose this is the norm for Nvidia drivers.

  2. #2
    Member
    Join Date
    Feb 2005
    Location
    Staffs, UK
    Posts
    172
    Thanks
    0
    Thanked
    0 times in 0 posts
    Can you tell me where in the world you are located?

    I had the same problem with the patch not finding an original file, and it turned out that there are 2 seperate patches......a US only one, and a EU one.......so it depends where you are as to which one you need.

  3. #3
    Banned Smokey21's Avatar
    Join Date
    May 2005
    Location
    Stafford, Midlands
    Posts
    1,752
    Thanks
    0
    Thanked
    0 times in 0 posts
    Like i said, i tryed installing a patch and it didn't work. I tryed the English one and the E.U one.

    I found a fix for it a .dll file and it works, but i still get an error when i open the game, and when i load a game, it just sits there on the loading screen and does nothing.

    Ive also re-installed it, and chanfed drivers from 77.72 to 77.76.

    Guess this is the wonderful world of Nvidia.

    Please ATI bring the R520 ASAP.

  4. #4
    Banned Smokey21's Avatar
    Join Date
    May 2005
    Location
    Stafford, Midlands
    Posts
    1,752
    Thanks
    0
    Thanked
    0 times in 0 posts
    Oh lol i also get this nice error when trying to install Battlefront:
    http://img263.imageshack.us/my.php?i...titled8oz1.jpg

    *roles sleeves up to throw 7800GTX in the bin*

  5. #5
    hi unreal's Avatar
    Join Date
    Jan 2005
    Location
    East London & Birmingham City Uni
    Posts
    3,657
    Thanks
    14
    Thanked
    37 times in 30 posts
    • unreal's system
      • Motherboard:
      • Intel iMac 20" & Macbook
      • CPU:
      • Intel Core 2 Duo T7200 2.0Ghz
      • Memory:
      • 4gb DDR667
      • Storage:
      • 1TB 7200 Int + 1.5Tb Ext
      • Graphics card(s):
      • ATi Radeon 2400XT
      • PSU:
      • 95W or something?
      • Case:
      • Intel iMac 20" Aluminium
      • Operating System:
      • OSX Snow Leopard (Win 7 x64 on Macbook Bootcamp)
      • Monitor(s):
      • 20" @ 1680x1050 & 27" 1080p HDTV
      • Internet:
      • O2 10mb
    Quote Originally Posted by Smokey21
    Oh lol i also get this nice error when trying to install Battlefront:
    http://img263.imageshack.us/my.php?i...titled8oz1.jpg

    *roles sleeves up to throw 7800GTX in the bin*
    An install error has nothing to do with a graphics card...

    You have probably got a dodgy disc - if its pirated it obviously has a chance of being a ghey disc, or if its a retail copy then the disc can be damaged, or there could be a problem with your optical drive.

    As for your Riddick problem, I remember my nVidia mate had that - I can't quite remember how he sorted it out though.

  6. #6
    Slightly Trigger Happy
    Join Date
    Jun 2005
    Location
    In front of a computer
    Posts
    366
    Thanks
    0
    Thanked
    0 times in 0 posts
    Quote Originally Posted by Smokey21
    *roles sleeves up to throw 7800GTX in the bin*
    can i have it then
    your computer is similar to a fridge in that if it cannot keep a beer cold then it sucks

  7. #7
    Member
    Join Date
    Feb 2005
    Location
    Staffs, UK
    Posts
    172
    Thanks
    0
    Thanked
    0 times in 0 posts
    *sits in the bin waiting for 7800GTX to fall into lap*

    I had the patch problem only when I was trying to patch my UK game with the US patch.....which wasn't made clear at pointof download.

    Once i reinstalled Riddick and got the correct patch (which was actually released a couple of weeks after the US one) it went in fine.

    Can't really see this being an nVidia problem directly......although with it being the new 7800 core, I imagine a few problems will surface (as the did with FarCry when the 6800 series was released).

  8. #8
    Banned Smokey21's Avatar
    Join Date
    May 2005
    Location
    Stafford, Midlands
    Posts
    1,752
    Thanks
    0
    Thanked
    0 times in 0 posts
    Tryed Riddick again, same crap. Error on startup, then it sits on a load screen.

  9. #9
    Going Retro!!! Ferral's Avatar
    Join Date
    Jul 2003
    Location
    North East
    Posts
    7,427
    Thanks
    373
    Thanked
    1,053 times in 667 posts
    • Ferral's system
      • Motherboard:
      • ASUS Z97-P
      • CPU:
      • Intel i7 4790K Haswell
      • Memory:
      • 8Gb Corsair XMS3 DDR3 1600 Mhz
      • Storage:
      • 120Gb Kingston SSD & 1.5 Tb Western Digital
      • Graphics card(s):
      • Sapphire Radeon R9 380 Nitro 4Gb
      • PSU:
      • Antec Truepower 750 Watt Modular
      • Case:
      • Zalman HD501 HTPC case
      • Operating System:
      • Windows 10 64 bit
      • Monitor(s):
      • 21" ASUS 1080P Widescreen LCD
      • Internet:
      • 20MB Sky Fibre
    Try changing you're desktop colour depth and resolution, that can sometimes stop games from starting up. Silent Hunter 3, Splinter Cell and Second Sight spring straight to mind on that one !

  10. #10
    Registered+
    Join Date
    Jan 2005
    Location
    Just round the corner
    Posts
    31
    Thanks
    0
    Thanked
    0 times in 0 posts
    Quote Originally Posted by Smokey21
    Tryed Riddick again, same crap. Error on startup, then it sits on a load screen.
    Have you tried using Rivatuner to alter the OpenGL version, old chap? It needs to be set for v1.3 or else Riddick won't run. I had the same problem myself. It was quite a while ago so I'm trying to remember the precise Rivatuner tabs to click on.

  11. #11
    Banned Smokey21's Avatar
    Join Date
    May 2005
    Location
    Stafford, Midlands
    Posts
    1,752
    Thanks
    0
    Thanked
    0 times in 0 posts
    Ok, cheers, but i have sorted the Open GL with a fix, but the last 2 times ive tryed to play it, it just stays stuck on the loading screen.

    I also cannot patch the game, it tells me some crap about a file is find or some bollocks and ive tryed the English and EU patch.

  12. #12
    Registered User
    Join Date
    Aug 2005
    Posts
    3
    Thanks
    0
    Thanked
    0 times in 0 posts
    hi smokey21, im having the exact same problem as you.

    initially was the opengl thing, then i tried to patch it to v1.1 but gives error about a file not the same so no update was done... i tried with the US version... will try EU version asap...

    used rivatuner to set it as openGL 1.5, then i get into the game and it loads forever when i start i new game... stuck at the loading screen...

    anyone successfully solve this problem?

  13. #13
    Going Retro!!! Ferral's Avatar
    Join Date
    Jul 2003
    Location
    North East
    Posts
    7,427
    Thanks
    373
    Thanked
    1,053 times in 667 posts
    • Ferral's system
      • Motherboard:
      • ASUS Z97-P
      • CPU:
      • Intel i7 4790K Haswell
      • Memory:
      • 8Gb Corsair XMS3 DDR3 1600 Mhz
      • Storage:
      • 120Gb Kingston SSD & 1.5 Tb Western Digital
      • Graphics card(s):
      • Sapphire Radeon R9 380 Nitro 4Gb
      • PSU:
      • Antec Truepower 750 Watt Modular
      • Case:
      • Zalman HD501 HTPC case
      • Operating System:
      • Windows 10 64 bit
      • Monitor(s):
      • 21" ASUS 1080P Widescreen LCD
      • Internet:
      • 20MB Sky Fibre
    Bit of a weird problem this one, I never had any problem at all with it.

    Are you overclocking ? If so, try running at stock and see if you get the error. Also make sure you have WHQL official drivers for the vga card and get you're latest motherboard drivers installed.

  14. #14
    Vive le pants! directhex's Avatar
    Join Date
    Jul 2003
    Location
    /dev/urandom
    Posts
    17,047
    Thanks
    223
    Thanked
    1,018 times in 671 posts
    • directhex's system
      • Motherboard:
      • MSI X99A Gaming 7
      • CPU:
      • Intel Core i7 5280k
      • Memory:
      • 32GiB ADATA DDR4
      • Storage:
      • Corsair Neutron XT 960GB
      • Graphics card(s):
      • MSI GTX 980 Gaming 4G Twin Frozr 5
      • PSU:
      • Corsair AX860i
      • Case:
      • NZXT H440
      • Operating System:
      • Ubuntu 17.10, Windows 10
      • Monitor(s):
      • Dell U2713HM
      • Internet:
      • FIOS
    Quote Originally Posted by Smokey21
    Oh lol i also get this nice error when trying to install Battlefront:
    http://img263.imageshack.us/my.php?i...titled8oz1.jpg

    *roles sleeves up to throw 7800GTX in the bin*
    yes, a CRC error is caused by a dodgy graphics card...

    or by a dodgy CD, of course. ring the publisher to ask for replacement media.

  15. #15
    Registered User
    Join Date
    Aug 2005
    Posts
    3
    Thanks
    0
    Thanked
    0 times in 0 posts
    Quote Originally Posted by Ferral
    Bit of a weird problem this one, I never had any problem at all with it.

    Are you overclocking ? If so, try running at stock and see if you get the error. Also make sure you have WHQL official drivers for the vga card and get you're latest motherboard drivers installed.
    nope, im not overclocking it, and i have the WHQL drivers and the latest mobo bios n drivers... still ain't working... give up trying

    now playing other games

  16. #16
    Registered User
    Join Date
    Aug 2005
    Posts
    3
    Thanks
    0
    Thanked
    0 times in 0 posts
    problem solved! just run the 1.1 patch from the installed directory and everything runs smoothly with 77.77 drivers!


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Chronicles of Riddick PC
    By Ferral in forum Reader Reviews
    Replies: 32
    Last Post: 15-06-2005, 11:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •