Page 2 of 2 FirstFirst 12
Results 17 to 31 of 31

Thread: Shuttle ST20G5 Windows 7 SATA driver working

  1. #17
    hfm
    hfm is offline
    Registered User
    Join Date
    Feb 2010
    Posts
    6
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Quote Originally Posted by jihmbo View Post
    I've solved the problem!!! All I needed to do was update the bios! As simple as that, problem solved immediatly. So anybody trying to install Windows 7 on a shuttle st20g5 should do a bios update first
    I wish this would have worked for me, alas i've installed ubuntu and turned it into a bacula and media server with two 1TB in raid1. So I guess it's probably better off it didn't work.

    I'm glad you got your issue sorted out. It seems so hit and miss.

  2. #18
    Registered User
    Join Date
    Oct 2009
    Posts
    11
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Doh, should have suggested that too.

    Glad you have it working. Any future visitor should be able to overcome most problems now. I had problems with zip file corruption on my download site but it is fixed now. Just a reminder of the link
    http://www.paulmcgrath.net/request.php?5

  3. #19
    Senior Member
    Join Date
    Nov 2006
    Location
    London
    Posts
    433
    Thanks
    17
    Thanked
    0 times in 0 posts
    • timtim86's system
      • Motherboard:
      • Shuttle
      • CPU:
      • Athlon X2 5000+
      • Memory:
      • 6GB OCZ Gold 6400
      • Storage:
      • 2 x 250GB Seagates, 1 x 750GB Samsung
      • Graphics card(s):
      • 8800GS 384MB
      • PSU:
      • Shuttle 400W
      • Case:
      • Shuttle SN27P2
      • Operating System:
      • Windows 7 Pro
      • Monitor(s):
      • Dell 2007WFP

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Thank you for this! Just got my old ST20G5 running with Windows 7 Pro. Vista was incredibly rubbish in comparison!

    Thanks

  4. #20
    Registered User
    Join Date
    Aug 2005
    Posts
    7
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Hi,

    Does anyone still have those drivers for the ST20G5?

    paulmcgrath dot net seems to be down.

    Alan

  5. #21
    Registered User
    Join Date
    Oct 2009
    Posts
    11
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Quote Originally Posted by firehorse View Post
    Hi,

    Does anyone still have those drivers for the ST20G5?

    paulmcgrath dot net seems to be down.

    Alan
    Hi, sorry I'm in the middle of moving domain registrars so it'll be up/down over the next week. It is up at the moment.
    Paul

  6. #22
    hfm
    hfm is offline
    Registered User
    Join Date
    Feb 2010
    Posts
    6
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Quote Originally Posted by firehorse View Post
    Hi,

    Does anyone still have those drivers for the ST20G5?

    paulmcgrath dot net seems to be down.

    Alan
    It's

  7. #23
    Registered User
    Join Date
    Aug 2005
    Posts
    7
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Hi Paul,
    Quote Originally Posted by csjjpm View Post
    Hi, sorry I'm in the middle of moving domain registrars so it'll be up/down over the next week. It is up at the moment.
    Paul
    Got it. Thanks :-)

    Alan

  8. #24
    Registered User
    Join Date
    Oct 2009
    Posts
    11
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    The Realtek audio driver has been hit and miss for me. Sometimes the latest release works and then the next version doesn't so I have to roll back.

  9. #25
    Registered User
    Join Date
    Aug 2005
    Posts
    7
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Hi Paul,

    Quote Originally Posted by csjjpm View Post
    The Realtek audio driver has been hit and miss for me. Sometimes the latest release works and then the next version doesn't so I have to roll back.
    Thanks for keeping everyone informed of your progress. I would be interested in which version of the Realtek audio driver you have found which works.

    The latest version of bios on the shuttle website is FT20S01E, I assume that is the one you are using.

    Many thanks
    Alan

  10. #26
    Registered User
    Join Date
    Oct 2009
    Posts
    11
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Thank you to everyone who mails me to thank me for hosting the file.

    My webserver is a VM on my Mac in work so I often have to reboot. It should never be offline for more than a couple of hours (worse case maybe overnight GMT). So please persist if you want to get the driver from my site.

    It is a pity you can't upload attachments to this site otherwise I would have.

    BW
    Paul

  11. #27
    hfm
    hfm is offline
    Registered User
    Join Date
    Feb 2010
    Posts
    6
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    I can confirm this is working on the ST20G5 with Windows 8 Consumer Preview 64 bit!

    I think the reason I was having so many problems before with Win7 was because of my SATA DVD Drive.

    Seems to be working fine right now with no DVD or Floppy installed, created a bootable USB to install Win8 Consumer 64bit and used the driver you have. Thanks!

  12. #28
    Registered User
    Join Date
    Oct 2009
    Posts
    11
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    That is brilliant. They didn't have a working sata driver in the original Win7 installation DVD so it is nice to see that they've included it in Win8.

    Thanks for letting us know and keep up the good work.

    I haven't tried it myself but I will give it a go.

    Quote Originally Posted by hfm View Post
    I can confirm this is working on the ST20G5 with Windows 8 Consumer Preview 64 bit!

    I think the reason I was having so many problems before with Win7 was because of my SATA DVD Drive.

    Seems to be working fine right now with no DVD or Floppy installed, created a bootable USB to install Win8 Consumer 64bit and used the driver you have. Thanks!

  13. #29
    Registered User
    Join Date
    Nov 2012
    Posts
    1
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Hey folks,

    I just installed Windows 8 on my little Shuttle XPS ST20G5!

    Second-hand and seven years old, it's still going strong as a audio media server, now running a $40 copy of Windows 8 Pro x64.

    Same problem as others were having with Win 7 x64, and solved with the same solution, installing the driver recommended by others (in the link below) during install.


    Quote Originally Posted by csjjpm View Post
    Doh, should have suggested that too.

    Glad you have it working. Any future visitor should be able to overcome most problems now. I had problems with zip file corruption on my download site but it is fixed now. Just a reminder of the link

  14. #30
    Registered User
    Join Date
    Oct 2009
    Posts
    11
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Mine is happily running with a dual core AMD, a NVidia 240GT and 2GB RAM with Windows 7 and XBMC. I am not sure if I'll bother with Windows 8. Glad to hear it works for you.

    I tried Openelec but it didn't load a network card driver and my linux skills are not that hot. May play with it sometime when I am bored but I may just replace the whole lot with RaspBMC and that will be the end of my ST20G5 ;-(

    Quote Originally Posted by stevemaher View Post
    Hey folks,

    I just installed Windows 8 on my little Shuttle XPS ST20G5!

    Second-hand and seven years old, it's still going strong as a audio media server, now running a $40 copy of Windows 8 Pro x64.

    Same problem as others were having with Win 7 x64, and solved with the same solution, installing the driver recommended by others (in the link below) during install.

  15. #31
    Registered+
    Join Date
    Jul 2010
    Posts
    24
    Thanks
    0
    Thanked
    1 time in 1 post

    Re: Shuttle ST20G5 Windows 7 SATA driver working

    Sorry for the mega bump, but csjjpm's driver link worked perfectly on Windows 8 Pro x64.

    Thanks for the link mate, saved a lot of time!

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 63
    Last Post: 14-11-2011, 09:17 AM
  2. Replies: 11
    Last Post: 14-07-2009, 11:41 AM
  3. On Windows 7
    By Paul Adams in forum Software
    Replies: 1
    Last Post: 02-06-2009, 12:59 AM
  4. Replies: 0
    Last Post: 09-02-2009, 04:48 AM
  5. Upgrading my Acer ! [Dxdiag inside]
    By Jack6114 in forum Pre-Built Computers Systems
    Replies: 11
    Last Post: 07-12-2008, 04:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •