Results 1 to 4 of 4

Thread: Incredibly Frustrating Returns Process

  1. #1
    Registered User
    Join Date
    Jul 2017
    Posts
    3
    Thanks
    0
    Thanked
    0 times in 0 posts

    Angry Incredibly Frustrating Returns Process

    Hi,
    I'm just posting here to get some opinions/help with my issue.

    So around the end of May I purchased an MSI GTX 1070 from scan. Card arrived a few days later. I noticed that one of the fans was making a ticking sound. I previously had a the same variant 970 which made no such sound.

    So I contacted Scan and included an attachment of an audio recording of the sound in the email. I made note of this in the email so they were aware of the attachment. Their response didn't acknowledge anything about the recording just a confirmation of the RMA.

    I sent off the card and a few days later around 5.p.m received notice they'd received it. The next morning after 9 I got an email saying there was 'No Fault Found'. After a series of back and forth emails of Scan refusing to replace the card, informing me they hadn't heard the audio clip and saying my only options were to either receive the card back or have them send it to MSI ( which I wasn't willing to do having only had the card less than a month this shouldn't be necessary as my contract was with Scan, the retailer )

    I opted to receive the card back hoping that perhaps the issue had resolved itself given that Scan's testers couldn't replicate it.

    So around a week later and the card is still making the sound. I've contacted Scan again. I sent them a link to an audio clip and they listened and confirmed they could hear the sound. I informed them that the rest of my case fans were off when recording the sound clip and the sound is only apparent while the GPU fans are active. I thought surely now they will offer a replacement having already gone through the RMA process, but no , they want to do further testing.

    This is incredibly frustrating. What if I send the card back a second time and get the same 'No Fault Found' response?

    Scan have informed me that it is their policy to confirm items are faulty before taking further action.

    Is this not a breach of consumer rights?

    Within 30 days of purchase if the product is not of satisfactory quality i.e contains no defects large or small then the consumer should be entitled to a refund.

    Doesn't this conflict with Scan's policy? where basically if scan don't deem it faulty its not.

    The ticking sound this card is making means that, to me, it is of unsatisfactory quality. Whether or not Scan are able to replicate this issue in their test environment doesn't and shouldn't affect my rights as a consumer.

    I just want what I paid for. What are your thoughts on this?

  2. #2
    Moderator Mick@SCAN's Avatar
    Join Date
    Aug 2007
    Posts
    580
    Thanks
    35
    Thanked
    79 times in 64 posts
    • Mick@SCAN's system
      • Motherboard:
      • Gigabyte GA-Z87X-OC
      • CPU:
      • i5 4670k @ 4.7 Ghz
      • Memory:
      • 16GB Corsair Vengeance LP 1600
      • Storage:
      • 120GB Samsung 840 / 2TB Seagate SATA III ST2000DM001 / 120GB Vertex Plus
      • Graphics card(s):
      • 8GB MSI 290X
      • PSU:
      • Enermax Modular Infiniti 650Watt
      • Case:
      • Fractal Design ARC MIDI R2 Tower Case
      • Operating System:
      • Windows 10
      • Monitor(s):
      • Iiyama ProLite G2773HS-2
      • Internet:
      • Virgin Media 200Mb

    Re: Incredibly Frustrating Returns Process

    steve3194,

    Can you please provide us with your invoice or query number and we can look into this for you.

    Kind regards,

  3. #3
    Registered User
    Join Date
    Jul 2017
    Posts
    3
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Incredibly Frustrating Returns Process

    Quote Originally Posted by Mick@SCAN View Post
    steve3194,

    Can you please provide us with your invoice or query number and we can look into this for you.

    Kind regards,
    Sorry about late response
    A new RMA 418537 has been issued for the card. Hoping it will be replaced this time. I'll keep you posted

  4. #4
    Registered User
    Join Date
    Jul 2017
    Posts
    3
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Incredibly Frustrating Returns Process

    Card was tested again and confirmed faulty. I've received the replacement and it's working perfectly with no ticking or clicking sounds.

    Glad to have this resolved but disappointed it took returning the card twice to do it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •