Results 1 to 15 of 15

Thread: New Creative X-FI beta drivers available..

  1. #1
    "You're my wife now!" Ravens Nest's Avatar
    Join Date
    Jul 2003
    Location
    The Pandemonium Carnival
    Posts
    1,564
    Thanks
    26
    Thanked
    47 times in 28 posts

    New Creative X-FI beta drivers available..

    Yippee new drivers for the X-FI available

    The only problem is there beta.... but last for 120 days so not too sad

    http://uk.europe.creative.com/support/downloads/
    "Mmm... I want you for my wife!"
    "Autom...Sprow...Canna...Tik banna...Sandwol...But no sera smee?"
    "Of course you can. We would love for you to join us."

  2. #2
    hi unreal's Avatar
    Join Date
    Jan 2005
    Location
    East London & Birmingham City Uni
    Posts
    3,657
    Thanks
    14
    Thanked
    37 times in 30 posts
    • unreal's system
      • Motherboard:
      • Intel iMac 20" & Macbook
      • CPU:
      • Intel Core 2 Duo T7200 2.0Ghz
      • Memory:
      • 4gb DDR667
      • Storage:
      • 1TB 7200 Int + 1.5Tb Ext
      • Graphics card(s):
      • ATi Radeon 2400XT
      • PSU:
      • 95W or something?
      • Case:
      • Intel iMac 20" Aluminium
      • Operating System:
      • OSX Snow Leopard (Win 7 x64 on Macbook Bootcamp)
      • Monitor(s):
      • 20" @ 1680x1050 & 27" 1080p HDTV
      • Internet:
      • O2 10mb
    Thanks a lot bro Actually I've had no complaint with the X-Fi card/software all this time UP UNTIL TODAY :/ It's funny, I needed to try Rewire with my music software Reason with a VST compatible host, so I tried Fruity Loops, but I didn't know how to switch MIDI channels on Fruity Loops - which meant I couldn't use the VST plug in (Orchestral) properly Cubase finally did it, but, apparently theres a huge issue with Cubase and X-Fi cards involving latency :@ And for like 3 hours today I was fiddling with buffer sizes and all sorts trying to get the latency gone (and some custom ASIO driver thing) and nothing even improved it

    So yeh I hope this aids at least that problem...

  3. #3
    "You're my wife now!" Ravens Nest's Avatar
    Join Date
    Jul 2003
    Location
    The Pandemonium Carnival
    Posts
    1,564
    Thanks
    26
    Thanked
    47 times in 28 posts
    No problem, hope this driver helps..

    I dont personally have any experience with the X-FI and music creation software, sorry.

    I know this is a silly question but did you make sure you switch to "Audio creation mode" via the creative audio console?

    I find it strange that your having latency problems using ASIO as that should be the correct standard, oh well.

    My brother is using REASON, Logic Audio Pro 5 and rewire together to create his music, but he has an EMU0404 (Which is like an early version of the X-FI) but only for music.
    Actually i have a link to his music at the bottom of my sig if your interested
    "Mmm... I want you for my wife!"
    "Autom...Sprow...Canna...Tik banna...Sandwol...But no sera smee?"
    "Of course you can. We would love for you to join us."

  4. #4
    hi unreal's Avatar
    Join Date
    Jan 2005
    Location
    East London & Birmingham City Uni
    Posts
    3,657
    Thanks
    14
    Thanked
    37 times in 30 posts
    • unreal's system
      • Motherboard:
      • Intel iMac 20" & Macbook
      • CPU:
      • Intel Core 2 Duo T7200 2.0Ghz
      • Memory:
      • 4gb DDR667
      • Storage:
      • 1TB 7200 Int + 1.5Tb Ext
      • Graphics card(s):
      • ATi Radeon 2400XT
      • PSU:
      • 95W or something?
      • Case:
      • Intel iMac 20" Aluminium
      • Operating System:
      • OSX Snow Leopard (Win 7 x64 on Macbook Bootcamp)
      • Monitor(s):
      • 20" @ 1680x1050 & 27" 1080p HDTV
      • Internet:
      • O2 10mb
    I know I thought it was strange too... and yeah I use audio creation mode when I've got the software open

    The reason that I've made such a basis upon it though is that people seem to have the exact same problem all over the net, and there are even big posts on it in the Creative forums themselves.

    However I looked on the release notes, and there are lots of Cubase and ASIO involved fixes, so I hope it worked


    The music on that page is the business by the way, nice one - mine is www.myspace.com/unrealbeatz harhar

  5. #5
    mutantbass head Lee H's Avatar
    Join Date
    Dec 2003
    Location
    M28, Manchester
    Posts
    14,204
    Thanks
    337
    Thanked
    671 times in 580 posts
    • Lee H's system
      • Motherboard:
      • MSI Z370 Carbon Gaming
      • CPU:
      • Intel i7 8700K Unlocked CPU
      • Memory:
      • 16 GB Corsair Vengeance 3200 LPX
      • Storage:
      • 250GB 960 EVO + a few more drives
      • Graphics card(s):
      • 6GB Palit GTX 1060 Dual
      • PSU:
      • Antec Truepower 750W Modular Blue
      • Case:
      • Corsair 600T White Edition
      • Operating System:
      • Windows 10 PRO
      • Monitor(s):
      • 27" Asus MX279H & 24" Acer 3D GD245HQ + the 3D glasses
      • Internet:
      • Virgin Media
    Hmmph

    Nice to see another manufacturer ignore MCE2005 and just release a bunch of beta drivers for windows XP.

    I've had no issues regarding ASIO and latency with ableton

  6. #6
    "You're my wife now!" Ravens Nest's Avatar
    Join Date
    Jul 2003
    Location
    The Pandemonium Carnival
    Posts
    1,564
    Thanks
    26
    Thanked
    47 times in 28 posts
    Thanks unreal, my brother would appreciate that i'll let him know and pass on your Myspace account as well.

    Nice mediteranean or arabian nights feel to "No acclaim" like it
    "Mmm... I want you for my wife!"
    "Autom...Sprow...Canna...Tik banna...Sandwol...But no sera smee?"
    "Of course you can. We would love for you to join us."

  7. #7
    "You're my wife now!" Ravens Nest's Avatar
    Join Date
    Jul 2003
    Location
    The Pandemonium Carnival
    Posts
    1,564
    Thanks
    26
    Thanked
    47 times in 28 posts
    Quote Originally Posted by Lee @ SCAN
    Hmmph

    Nice to see another manufacturer ignore MCE2005 and just release a bunch of beta drivers for windows XP.

    I've had no issues regarding ASIO and latency with ableton
    Tee hee shows you how much i know about music creation, it was Ableton live 5 my brother uses with reason and rewire
    "Mmm... I want you for my wife!"
    "Autom...Sprow...Canna...Tik banna...Sandwol...But no sera smee?"
    "Of course you can. We would love for you to join us."

  8. #8
    hi unreal's Avatar
    Join Date
    Jan 2005
    Location
    East London & Birmingham City Uni
    Posts
    3,657
    Thanks
    14
    Thanked
    37 times in 30 posts
    • unreal's system
      • Motherboard:
      • Intel iMac 20" & Macbook
      • CPU:
      • Intel Core 2 Duo T7200 2.0Ghz
      • Memory:
      • 4gb DDR667
      • Storage:
      • 1TB 7200 Int + 1.5Tb Ext
      • Graphics card(s):
      • ATi Radeon 2400XT
      • PSU:
      • 95W or something?
      • Case:
      • Intel iMac 20" Aluminium
      • Operating System:
      • OSX Snow Leopard (Win 7 x64 on Macbook Bootcamp)
      • Monitor(s):
      • 20" @ 1680x1050 & 27" 1080p HDTV
      • Internet:
      • O2 10mb
    Yeah I downloaded the Ableton trial today, my uncle keeps urging me to try it, it isn't too expensive too (compared to others anyhow)... but it looks good and I don't get the latency problem I did with Cubase, so it seems cubase is the ONLY program to experience it so far which does show some kind of bug. However, I got the new drivers installed so I might reinstall Cubase to see how it goes....

    Quote Originally Posted by Ravens Nest
    Thanks unreal, my brother would appreciate that i'll let him know and pass on your Myspace account as well.

    Nice mediteranean or arabian nights feel to "No acclaim" like it
    Thanks much I used to have a good Promiscuous music video on there until it got taken down

  9. #9
    . bledd's Avatar
    Join Date
    Jul 2003
    Posts
    1,886
    Thanks
    22
    Thanked
    135 times in 85 posts
    they've got a 120day timeout on them, but i read somewhere that they're releasing new official drivers at the end of june..

    i'm using these beta's and they seem cool so far

    there's a lot of bug fixes in the release notes (a LOT)

  10. #10
    Member
    Join Date
    Sep 2005
    Location
    suffolk
    Posts
    183
    Thanks
    31
    Thanked
    10 times in 5 posts
    • andyjhill's system
      • Motherboard:
      • Asus P6X58D
      • CPU:
      • Intel I7 980X
      • Memory:
      • 6GB DDR3
      • Storage:
      • 120GB SSD boot 1TB and 2tb data
      • Graphics card(s):
      • GTX470 x2 in SLI
      • PSU:
      • coolermaster pro gold 1000w
      • Case:
      • Silverstone TJ-07
      • Operating System:
      • Windows 7 x64
      • Monitor(s):
      • Dell 23"
      • Internet:
      • VG 60mb adsl :)
    thanks for this been waiting for creative labs to sort out this driver

  11. #11
    "You're my wife now!" Ravens Nest's Avatar
    Join Date
    Jul 2003
    Location
    The Pandemonium Carnival
    Posts
    1,564
    Thanks
    26
    Thanked
    47 times in 28 posts
    No problem , Didnt think there was so many X-FI owners on HEXUS, i was wrong
    "Mmm... I want you for my wife!"
    "Autom...Sprow...Canna...Tik banna...Sandwol...But no sera smee?"
    "Of course you can. We would love for you to join us."

  12. #12
    Banned Smokey21's Avatar
    Join Date
    May 2005
    Location
    Stafford, Midlands
    Posts
    1,752
    Thanks
    0
    Thanked
    0 times in 0 posts
    Hmmm, think ill keep the current one's. ive got no problems here. Xi-Fi Plat.

  13. #13
    Syd
    Syd is offline
    Hanging on the Edge Syd's Avatar
    Join Date
    Jan 2006
    Location
    Kent
    Posts
    1,636
    Thanks
    69
    Thanked
    32 times in 29 posts
    • Syd's system
      • Motherboard:
      • EVGA 760 Classified / MSI P35 / gigabyte gaming 7 1150
      • CPU:
      • I7 920@3.8 / E8400 / 4790k
      • Memory:
      • 18GB Dominator DDR3 1600 / 4GB / 16GB GSill
      • Storage:
      • 2 x Samsung 830 256/ 120GB Vertex 2 / Sam840's/ Sam SM951
      • Graphics card(s):
      • 690GTX on Water/IGP/ 980ti
      • PSU:
      • AX860/1250w Seasonic
      • Case:
      • TJ07 / PCV700
      • Operating System:
      • 7 64/ 10 64
      • Monitor(s):
      • NEC 3090 + Dell 2405PW
      • Internet:
      • Sky Fibre
    Is there any reason for a gamer/mp3 user to change to these drivers?

    as I don't think i've had any problems with the existing set.

  14. #14
    hi unreal's Avatar
    Join Date
    Jan 2005
    Location
    East London & Birmingham City Uni
    Posts
    3,657
    Thanks
    14
    Thanked
    37 times in 30 posts
    • unreal's system
      • Motherboard:
      • Intel iMac 20" & Macbook
      • CPU:
      • Intel Core 2 Duo T7200 2.0Ghz
      • Memory:
      • 4gb DDR667
      • Storage:
      • 1TB 7200 Int + 1.5Tb Ext
      • Graphics card(s):
      • ATi Radeon 2400XT
      • PSU:
      • 95W or something?
      • Case:
      • Intel iMac 20" Aluminium
      • Operating System:
      • OSX Snow Leopard (Win 7 x64 on Macbook Bootcamp)
      • Monitor(s):
      • 20" @ 1680x1050 & 27" 1080p HDTV
      • Internet:
      • O2 10mb
    Not really, if you haven't had much problems then don't change. However check the changelog, some of the changes may fancy your pick, such as BF2 changes etc, and one fix I noticed was to let Prey actually work (assuming once the demo/game comes out, the card doesn't cause instability)

  15. #15
    Syd
    Syd is offline
    Hanging on the Edge Syd's Avatar
    Join Date
    Jan 2006
    Location
    Kent
    Posts
    1,636
    Thanks
    69
    Thanked
    32 times in 29 posts
    • Syd's system
      • Motherboard:
      • EVGA 760 Classified / MSI P35 / gigabyte gaming 7 1150
      • CPU:
      • I7 920@3.8 / E8400 / 4790k
      • Memory:
      • 18GB Dominator DDR3 1600 / 4GB / 16GB GSill
      • Storage:
      • 2 x Samsung 830 256/ 120GB Vertex 2 / Sam840's/ Sam SM951
      • Graphics card(s):
      • 690GTX on Water/IGP/ 980ti
      • PSU:
      • AX860/1250w Seasonic
      • Case:
      • TJ07 / PCV700
      • Operating System:
      • 7 64/ 10 64
      • Monitor(s):
      • NEC 3090 + Dell 2405PW
      • Internet:
      • Sky Fibre
    Quote Originally Posted by unreal
    Not really, if you haven't had much problems then don't change. However check the changelog, some of the changes may fancy your pick, such as BF2 changes etc, and one fix I noticed was to let Prey actually work (assuming once the demo/game comes out, the card doesn't cause instability)
    Hmmm thanks for that, will have a look

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ForceWare 81.87 Beta drivers
    By Tobeman in forum Graphics Cards
    Replies: 0
    Last Post: 27-10-2005, 05:59 PM
  2. Creative Audigy, mp3, speakers etc
    By Flibb in forum Retail Therapy and Bargains
    Replies: 13
    Last Post: 25-07-2005, 12:32 PM
  3. Longhorn beta dates...
    By myth in forum Software
    Replies: 7
    Last Post: 20-03-2005, 04:46 PM
  4. Replies: 17
    Last Post: 05-08-2004, 04:51 PM
  5. new beta nforce 2/3 drivers
    By CoDa in forum PC Hardware and Components
    Replies: 6
    Last Post: 15-07-2004, 08:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •