Results 1 to 10 of 10

Thread: Sky DigiBox problems...

  1. #1
    Member
    Join Date
    Jul 2006
    Location
    Lincolnshire
    Posts
    157
    Thanks
    0
    Thanked
    0 times in 0 posts

    Sky DigiBox problems...

    Hi all,

    Been having some problems with my dads sky digibox, now he's all set to get a new one, but I was wondering if it was the signal to the dish causing the problems and not the box itself, anyone here have any help regarding this, its normal sky, not sky+ and the image breaks up quite often (even in good weather) and its very slow when browsing through the TV guide. if this is the problem, what sky boxes do you recommend, we currently have an old sony one.

    Cheers,
    James

  2. #2
    Are you Junglin' guy? jamin's Avatar
    Join Date
    Jul 2003
    Location
    Sunny Southend On Sea
    Posts
    921
    Thanks
    17
    Thanked
    11 times in 10 posts
    Have you checked the siganl level in the installers menu? Your mini dish may had moved a fraction. Does it happen on certain channels and not others (Signs that the lnb is loosing vertical / horizontal polarization)

    Access the installers menu by pressing : SERVICES - 4 - 0 - 1 SELECT

    In that order one after the other. Check the signal bar and whether its locked to a transport stream and post back.
    Beer is life, life is good!

  3. #3
    Member
    Join Date
    Jul 2006
    Location
    Lincolnshire
    Posts
    157
    Thanks
    0
    Thanked
    0 times in 0 posts
    Signal is just over three quarters of the way full, which seems ok...

  4. #4
    Are you Junglin' guy? jamin's Avatar
    Join Date
    Jul 2003
    Location
    Sunny Southend On Sea
    Posts
    921
    Thanks
    17
    Thanked
    11 times in 10 posts
    Does seem fine to me, you could check the cable and connectors for damage and degradation though as bad connections can cause uncorrectable errors even though the signal is fine as can a squashed / kinked cable.
    Beer is life, life is good!

  5. #5
    DILLIGAF GoNz0's Avatar
    Join Date
    Jun 2006
    Location
    Derby
    Posts
    10,869
    Thanks
    632
    Thanked
    1,192 times in 945 posts
    • GoNz0's system
      • Motherboard:
      • Asus Rampage V Extreme
      • CPU:
      • i7 something X99 based
      • Memory:
      • 16gb GSkill
      • Storage:
      • 4 SSD's + WD Red
      • Graphics card(s):
      • GTX980 Strix WC
      • PSU:
      • Enermax Galaxy 1250 (9 years and counting)
      • Case:
      • Corsair 900D
      • Operating System:
      • win10 64bit
      • Monitor(s):
      • Dell 24"
      • Internet:
      • 220mb Cable
    i hope your getting a new one for free.. if so they will just send you one.
    if they want to charge you, ring up and cancel your contract and take out a new one

  6. #6
    Herr Doktor Oetker, ja!!! pollaxe's Avatar
    Join Date
    Jul 2006
    Location
    West of England
    Posts
    2,969
    Thanks
    1,013
    Thanked
    280 times in 225 posts
    My father had a similar problem - Sky tech support talked him through a reboot of the box and it sorted it out for him - I'm not sure if this'll help in your case, just posting in case it might. Good luck anyway.

  7. #7
    Are you Junglin' guy? jamin's Avatar
    Join Date
    Jul 2003
    Location
    Sunny Southend On Sea
    Posts
    921
    Thanks
    17
    Thanked
    11 times in 10 posts
    Sky tech support example:

    Customer: My box isn't working properly.
    Sky: Ok, can you unplug the box and remove the plug.
    Customer: Ok done that.
    Sky: What kind of flooring do you have?
    Customer: Er......... Laminate. Why?
    Sky: Good, can you rub the plug on the laminate flooring please.
    Customer: What? Why?
    Sky: You need to ground the static charge that has built up in the digibox due by your laminate floor.
    Customer: What? Put me on to your manger....... NOW.
    Sky: Thanks for your call.................... Beeeeeeeeeeeeeeeeeee!

    Sky terminated the call, and the customer was a very good mate of mine who I have worked with at NTL:Telewest for the last 10 years. I kid you not this was a genuine sky tech support conversation, we laughed about it for months. And I still wind him up about it.

    It turned out his LNB had gone faulty and he had lost all the horizontal transport streams. But it took 3 calls for sky to send anyone out to have a look! He was within the 12 month contract at the time.

    I had sky for 3 years though and every time I phoned up they were fine to talk to even when I "accidently" unplugged my box from the phone line for 3 months and recieved threatening letters during my first 12 months.
    Beer is life, life is good!

  8. #8
    DILLIGAF GoNz0's Avatar
    Join Date
    Jun 2006
    Location
    Derby
    Posts
    10,869
    Thanks
    632
    Thanked
    1,192 times in 945 posts
    • GoNz0's system
      • Motherboard:
      • Asus Rampage V Extreme
      • CPU:
      • i7 something X99 based
      • Memory:
      • 16gb GSkill
      • Storage:
      • 4 SSD's + WD Red
      • Graphics card(s):
      • GTX980 Strix WC
      • PSU:
      • Enermax Galaxy 1250 (9 years and counting)
      • Case:
      • Corsair 900D
      • Operating System:
      • win10 64bit
      • Monitor(s):
      • Dell 24"
      • Internet:
      • 220mb Cable
    Quote Originally Posted by jamin View Post

    I had sky for 3 years though and every time I phoned up they were fine to talk to even when I "accidently" unplugged my box from the phone line for 3 months and recieved threatening letters during my first 12 months.
    that led to us getting a new contract, lightning strike blew the box via the phone line, you could see the burn marks inside the box to prove it, sky wouldn't warranty the box due to this, after the new contract we got the letters about the phone line, i pointed out that if plugging it in the phone line could damage the box, and the outcome would be an expensive bill if we were within the 12 month contract that i would refuse to plug the phone line in again. if they didn't like it they can cancel the contract.

    never heard from them again about it, and its still unplugged about 5 years later

  9. #9
    Are you Junglin' guy? jamin's Avatar
    Join Date
    Jul 2003
    Location
    Sunny Southend On Sea
    Posts
    921
    Thanks
    17
    Thanked
    11 times in 10 posts
    I had my box in my flat for 3 years, then bought a place in Southend (Born there!) and in a cable area, as I get the Telewest staff package I gave my box to mother and father in law in Spain and I put up a 2.4m dish for them so they could get BBC etc. (They give me the money for the sub and sky take the DD) It hasnt been plugged in for years but as its outside contract, theres nothing sky can do.

    The box died last month after years of service, they bought a new one from a satellite guy out there and gave me the serial and the card number. I phoned sky and the guy said that I would have renew the contract. When I told him I had been a customer for 6 years and that sky could not enforce a new contract on a non subsidised box he ate humble pie and paired the new box to the card.

    In short, know what you are talking about before speaking to them as they will try to enforce a new contract on you!
    Beer is life, life is good!

  10. #10
    Senior Member
    Join Date
    Oct 2006
    Location
    Rainham, Kent
    Posts
    738
    Thanks
    19
    Thanked
    33 times in 23 posts
    • ukengineer's system
      • Motherboard:
      • ASUS A8N-SLi DELUXE
      • CPU:
      • AMD 4600 X2 S939 @ 2.8Ghz
      • Memory:
      • 2GB GEIL ULTRA PLATINUM DUAL CHANNEL DDR PC3500
      • Storage:
      • 1.2TB OVER 4 FAST SATA DRIVES
      • Graphics card(s):
      • ATi X1950XTX GDDR4 512MB
      • PSU:
      • Mesh
      • Case:
      • Mesh MatriX
      • Monitor(s):
      • 19" DVi LCD 6ms
      • Internet:
      • 20Mbit Blueyonder/Telewest now Virgin
    I had sky for 2yrs, never plugged the phoneline in, never recieved a letter, but when i did ring them for support, they did say it needed to be connected, I told them it was never connected when installed, so send out an engineer to connect, or it stays unconnected. They never sent an engineer just told me to unplug the coax, for 1min, to discharge Static? !! It worked anyways, after this.

    Back on Telewest, that just works, no silly support, ring Telewest up, they do everything direct to my box, and its mad watching them change channels, turn it off and on, and various other things.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My experience with Windows XP Pro x64 Edition
    By Paul Adams in forum Software
    Replies: 7
    Last Post: 20-04-2007, 11:59 PM
  2. Sky now taking orders for HD TV service
    By Bob Crabtree in forum HEXUS News
    Replies: 13
    Last Post: 29-03-2006, 11:30 PM
  3. Sky by Broadband
    By darrensen in forum Help! Quick Relief From Tech Headaches
    Replies: 2
    Last Post: 27-01-2006, 02:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •