Page 1 of 2 12 LastLast
Results 1 to 16 of 26

Thread: 4870 trouble (black screen, crazy RPM)

  1. #1
    Registered+
    Join Date
    Jul 2008
    Posts
    17
    Thanks
    0
    Thanked
    0 times in 0 posts

    4870 trouble (black screen, crazy RPM)

    In desperate need of help here. My newly built computer was working fine yesturday, I went on today and checked the temps of the card and was supprised at the high temps I was getting, so I decided to up the fan speed to 41%. About 10 minutes after I did this I lost signal and the fan started making an extremely loud noise (sounded like a plane taking off) Now whenever I turn on my PC all I get it is a black screen and this very loud fan noise as a greeting.

    I have tried switching monitors but that does not seem to do anything, probably something wrong with the card but I'm not sure.

    Any help would be greatly appreciated.

    Thanks.

  2. #2
    Senior Member AdamAnubis's Avatar
    Join Date
    Jul 2008
    Location
    Rugby
    Posts
    826
    Thanks
    27
    Thanked
    33 times in 18 posts
    • AdamAnubis's system
      • Motherboard:
      • GA-EP45-DS3
      • CPU:
      • Intel E8400 Stock cooler + speeds
      • Memory:
      • 4GB Corsair 2x2gb
      • Storage:
      • 500GB Seagate Barracude S-ATA
      • Graphics card(s):
      • Gigabyte GTX 460 1GB
      • PSU:
      • Corsair 650W
      • Operating System:
      • Windows Vista 64bit
      • Monitor(s):
      • VX2240 Viewsoic 22"
      • Internet:
      • 2MB Virgin Media

    Re: 4870 trouble (black screen, crazy RPM)

    What were the temps it was running at?

  3. #3
    Ninja Noxvayl's Avatar
    Join Date
    May 2007
    Location
    In the shadows
    Posts
    2,451
    Thanks
    748
    Thanked
    215 times in 173 posts
    • Noxvayl's system
      • Motherboard:
      • GigabyteZ87X-UD4H-CF
      • CPU:
      • Intel i7 4770K
      • Memory:
      • 16GB Corsair Vengaence LPX + 8GB Kingston HyperX Beast
      • Storage:
      • 120GB Snadisk + 256GB Crucial SSDs
      • Graphics card(s):
      • 4GB Sapphire R9 380
      • PSU:
      • ENermax Platimax 750W
      • Case:
      • Fractal Design Define S
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • ATMT + Dell 1024x1280
      • Internet:
      • Sky Fibre

    Re: 4870 trouble (black screen, crazy RPM)

    The HD4870 is normally pretty hot, compared to what we would normally expect to be hot. 70-80 degree's is normal for those cards. They only overheat at 110 degree's which is far beyond what we deem too hot.

    You should try un-installing the drivers and then installing them again, there have been problems with the fan speeds and it seemed to be a driver issue from what I have read.

    If that doesn't work try taking the card out of the slot and placing it in the second PCI-E slot(if you have a second one). That should force windows to reassign drivers which hopefully will sort out the problem.

  4. #4
    Registered+
    Join Date
    Jul 2008
    Posts
    17
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: 4870 trouble (black screen, crazy RPM)

    Quote Originally Posted by ExHail View Post
    The HD4870 is normally pretty hot, compared to what we would normally expect to be hot. 70-80 degree's is normal for those cards. They only overheat at 110 degree's which is far beyond what we deem too hot.

    You should try un-installing the drivers and then installing them again, there have been problems with the fan speeds and it seemed to be a driver issue from what I have read.

    If that doesn't work try taking the card out of the slot and placing it in the second PCI-E slot(if you have a second one). That should force windows to reassign drivers which hopefully will sort out the problem.
    May sound like a dumb question but - how can I uninstall the drivers when I can't see anything on the monitor? :S

    As for changing card slots, I'll give it ago.

  5. #5
    Senior Member AdamAnubis's Avatar
    Join Date
    Jul 2008
    Location
    Rugby
    Posts
    826
    Thanks
    27
    Thanked
    33 times in 18 posts
    • AdamAnubis's system
      • Motherboard:
      • GA-EP45-DS3
      • CPU:
      • Intel E8400 Stock cooler + speeds
      • Memory:
      • 4GB Corsair 2x2gb
      • Storage:
      • 500GB Seagate Barracude S-ATA
      • Graphics card(s):
      • Gigabyte GTX 460 1GB
      • PSU:
      • Corsair 650W
      • Operating System:
      • Windows Vista 64bit
      • Monitor(s):
      • VX2240 Viewsoic 22"
      • Internet:
      • 2MB Virgin Media

    Re: 4870 trouble (black screen, crazy RPM)

    If your motherboard has onboard graphics If not, borrow a mates graphics card or use a spare one

  6. #6
    Ninja Noxvayl's Avatar
    Join Date
    May 2007
    Location
    In the shadows
    Posts
    2,451
    Thanks
    748
    Thanked
    215 times in 173 posts
    • Noxvayl's system
      • Motherboard:
      • GigabyteZ87X-UD4H-CF
      • CPU:
      • Intel i7 4770K
      • Memory:
      • 16GB Corsair Vengaence LPX + 8GB Kingston HyperX Beast
      • Storage:
      • 120GB Snadisk + 256GB Crucial SSDs
      • Graphics card(s):
      • 4GB Sapphire R9 380
      • PSU:
      • ENermax Platimax 750W
      • Case:
      • Fractal Design Define S
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • ATMT + Dell 1024x1280
      • Internet:
      • Sky Fibre

    Re: 4870 trouble (black screen, crazy RPM)

    Quote Originally Posted by AdamAnubis View Post
    If your motherboard has onboard graphics If not, borrow a mates graphics card or use a spare one
    What AdamAnubis said

    I always like to have a spare option available in case something goes wrong, either a different GFX card or onboard GFX.

  7. #7
    Registered+
    Join Date
    Jul 2008
    Posts
    17
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: 4870 trouble (black screen, crazy RPM)

    Ok thanks guys, got my hands on a mates old card so going to give it ago today.

    Where are the drivers stored on the PC and how would I go about removing them?

    Cheers.

  8. #8
    Senior Member Pob255's Avatar
    Join Date
    Apr 2007
    Location
    The land of Brum
    Posts
    9,945
    Thanks
    572
    Thanked
    1,196 times in 1,099 posts
    • Pob255's system
      • Motherboard:
      • Asus M5A99X EVO
      • CPU:
      • PhenomII x4 955 & CM Hyper 212+
      • Memory:
      • 2x 4gb Corsair Vengence 1600mhz cas9
      • Storage:
      • 250gb SATA Westerndigital + 500gb samsung +1tb Samsung
      • Graphics card(s):
      • Asus GTX560ti CuII
      • PSU:
      • Be Quiet E9 680w
      • Case:
      • HAF 912+
      • Operating System:
      • W7 Pro
      • Monitor(s):
      • Dell 21" ips something

    Re: 4870 trouble (black screen, crazy RPM)

    You should find it in the control pannel, add / remove programs
    ATi did a good ati driver cleaner as well, here it is https://a248.e.akamai.net/f/674/9206...ninstaller.exe

  9. #9
    Registered+
    Join Date
    Jul 2008
    Posts
    17
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: 4870 trouble (black screen, crazy RPM)

    Well I installed a 8600GT, booted and left the PC uninstalling the drivers, I come back and BAM, black screen.

    So dunno WTF is going on. Mobo is to blame?

    EDIT: PC doesn't seem to be booting at all. Weird as it booted a few minutes ago.
    Last edited by painkiller10; 19-07-2008 at 10:20 PM.

  10. #10
    Ninja Noxvayl's Avatar
    Join Date
    May 2007
    Location
    In the shadows
    Posts
    2,451
    Thanks
    748
    Thanked
    215 times in 173 posts
    • Noxvayl's system
      • Motherboard:
      • GigabyteZ87X-UD4H-CF
      • CPU:
      • Intel i7 4770K
      • Memory:
      • 16GB Corsair Vengaence LPX + 8GB Kingston HyperX Beast
      • Storage:
      • 120GB Snadisk + 256GB Crucial SSDs
      • Graphics card(s):
      • 4GB Sapphire R9 380
      • PSU:
      • ENermax Platimax 750W
      • Case:
      • Fractal Design Define S
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • ATMT + Dell 1024x1280
      • Internet:
      • Sky Fibre

    Re: 4870 trouble (black screen, crazy RPM)

    What are you system specs? As much detail as you can for your spec would be helpful specially with the Power Supply.

    I think its possible to be a fault on the motherboard... need to check on a few details though.

    When the PC was on the black screen were the fans running? Ie is power still being supplied to your machine?

    When you turn your PC on now does it attempt to start or does nothing happen at all?

    Have you tried putting the HD4870 card back into your computer? If not try that and let us know what happens with regard to the above questions.

    The more detail you can give on the problem the better for us diagnosing

  11. #11
    Registered+
    Join Date
    Jul 2008
    Posts
    17
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: 4870 trouble (black screen, crazy RPM)

    Quote Originally Posted by ExHail View Post
    What are you system specs? As much detail as you can for your spec would be helpful specially with the Power Supply.

    I think its possible to be a fault on the motherboard... need to check on a few details though.

    When the PC was on the black screen were the fans running? Ie is power still being supplied to your machine?

    When you turn your PC on now does it attempt to start or does nothing happen at all?

    Have you tried putting the HD4870 card back into your computer? If not try that and let us know what happens with regard to the above questions.

    The more detail you can give on the problem the better for us diagnosing
    Specs:

    Intel Quad core 4GB Q6600
    Corsair 4GB DDR2 800mhz RAM
    Seagate 500GB hard drive
    Samsung 22X DVD drive
    Sapphire HD 4870 512mb GDDR5 Graphics card/Inno3D 8600 Graphics Card
    Asus P5Q Pro Motherboard
    Corsair 520W PSU
    Arctic cooling 7 processor cooler

    1. Yes, for the 4870,the fans were still running when I was on the black screen

    2. Now, when I turned on with the side open all I could see happening was the fans going, other than that it does not seem to be doing anything else

    3. I will put the 4870 back in now.

    EDIT: Just put the 4870 back in, same as 2.
    Last edited by painkiller10; 20-07-2008 at 10:37 AM.

  12. #12
    Ninja Noxvayl's Avatar
    Join Date
    May 2007
    Location
    In the shadows
    Posts
    2,451
    Thanks
    748
    Thanked
    215 times in 173 posts
    • Noxvayl's system
      • Motherboard:
      • GigabyteZ87X-UD4H-CF
      • CPU:
      • Intel i7 4770K
      • Memory:
      • 16GB Corsair Vengaence LPX + 8GB Kingston HyperX Beast
      • Storage:
      • 120GB Snadisk + 256GB Crucial SSDs
      • Graphics card(s):
      • 4GB Sapphire R9 380
      • PSU:
      • ENermax Platimax 750W
      • Case:
      • Fractal Design Define S
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • ATMT + Dell 1024x1280
      • Internet:
      • Sky Fibre

    Re: 4870 trouble (black screen, crazy RPM)

    Sounds like a Motherboard fault.

    If it was driver related changing the GFX would of easily solved the issue. If it was the PSU it would continue to reboot plus the 8600 wouldn't of had a problem since it uses far less power than the HD4870. The memory normally gives out errors in the form of BSOD's not black screens. It could also be the CPU but without it coming on you can't really test... If you have a second motherboard to try your CPU and memory in that should tell you without any doubts whether the motherboard is to blame but as it stands I think the motherboard is the most likely cause.

  13. #13
    Registered+
    Join Date
    Jul 2008
    Posts
    17
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: 4870 trouble (black screen, crazy RPM)

    I just put the 8600 into the other graphics card slot and it is working fine now. Other slot must not be working properly, will try the 4870 in the other slot aswell and see if that does it.

  14. #14
    Ninja Noxvayl's Avatar
    Join Date
    May 2007
    Location
    In the shadows
    Posts
    2,451
    Thanks
    748
    Thanked
    215 times in 173 posts
    • Noxvayl's system
      • Motherboard:
      • GigabyteZ87X-UD4H-CF
      • CPU:
      • Intel i7 4770K
      • Memory:
      • 16GB Corsair Vengaence LPX + 8GB Kingston HyperX Beast
      • Storage:
      • 120GB Snadisk + 256GB Crucial SSDs
      • Graphics card(s):
      • 4GB Sapphire R9 380
      • PSU:
      • ENermax Platimax 750W
      • Case:
      • Fractal Design Define S
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • ATMT + Dell 1024x1280
      • Internet:
      • Sky Fibre

    Re: 4870 trouble (black screen, crazy RPM)

    Quote Originally Posted by painkiller10 View Post
    I just put the 8600 into the other graphics card slot and it is working fine now. Other slot must not be working properly, will try the 4870 in the other slot aswell and see if that does it.
    Thought you tried that before when I first suggested it... its pretty obvious its a fault with the motherboard if the second slot works fine

    At least your PC is working now... sure a quick RMA can easily be arranged as you said your system is new. Hopefully you get a new board pretty soon

  15. #15
    Registered+
    Join Date
    Jul 2008
    Posts
    17
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: 4870 trouble (black screen, crazy RPM)

    Put the card in the second slot when I had removed all previous drivers, installed the Vista hotfix.

    4870 ran FINE for around 4 hours, Just shut down and switched it back on and its back to black screen etc. again.



    ****ing annoying..

  16. #16
    Ninja Noxvayl's Avatar
    Join Date
    May 2007
    Location
    In the shadows
    Posts
    2,451
    Thanks
    748
    Thanked
    215 times in 173 posts
    • Noxvayl's system
      • Motherboard:
      • GigabyteZ87X-UD4H-CF
      • CPU:
      • Intel i7 4770K
      • Memory:
      • 16GB Corsair Vengaence LPX + 8GB Kingston HyperX Beast
      • Storage:
      • 120GB Snadisk + 256GB Crucial SSDs
      • Graphics card(s):
      • 4GB Sapphire R9 380
      • PSU:
      • ENermax Platimax 750W
      • Case:
      • Fractal Design Define S
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • ATMT + Dell 1024x1280
      • Internet:
      • Sky Fibre

    Re: 4870 trouble (black screen, crazy RPM)

    Does it still give you a black screen with the first slot?

    Did you use the new Catalyst 8.7 drivers?

    Try using the card in the first slot again... if it works for a while you know its a driver problem and not your hardware. Best thing to do in this situation, because you don't know what exactly has caused the problem, would be to format your hard drive(back up all your important files) and then install a fresh copy of Vista. This is the perfect solution for all driver errors and viruses but is only really used as a last resort if your not able to locate the source of the problem.

    Personally I use DBAN to format my HDD because it's the most secure(basically means it gets rid of things a basic format would not). Use the automatic option

    If the problem is not driver related... which at the moment I believe to be the most favourable option for the cause of the problem... then it could be hardware but I don't think its hardware because it works for short periods of time and then fails with each new hardware configuration you use. This indicates that the hardware works but some software is getting in the way somewhere along the line.

    I hope you are able to format to see if my assumption is correct... not nice to have your new PC not working that's for sure.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. KOTOR II Black Screen?
    By Smokey21 in forum Gaming
    Replies: 5
    Last Post: 14-03-2006, 12:41 PM
  2. SN85G4 can't post / black screen after 6800gt install
    By Raptor235 in forum PC Hardware and Components
    Replies: 2
    Last Post: 24-11-2005, 10:59 AM
  3. Black screen with MCE
    By davejp in forum Software
    Replies: 0
    Last Post: 12-05-2005, 10:04 AM
  4. x800 pro loads to a black windows xp screen
    By charger in forum Graphics Cards
    Replies: 5
    Last Post: 27-08-2004, 01:28 PM
  5. Black Screen ???.
    By HarryOatcake in forum PC Hardware and Components
    Replies: 8
    Last Post: 26-01-2004, 11:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •