Results 1 to 13 of 13

Thread: flashing 6950 problems

  1. #1
    S1L3NT danroyle's Avatar
    Join Date
    Aug 2006
    Location
    sussex
    Posts
    4,241
    Thanks
    145
    Thanked
    186 times in 153 posts
    • danroyle's system
      • Motherboard:
      • N/A
      • CPU:
      • Intel Core I7 4720HQ
      • Memory:
      • 8GB
      • Storage:
      • 128GB SSD +1tb HDD
      • Graphics card(s):
      • Geforce Gtx960m
      • PSU:
      • N/A
      • Case:
      • N/A
      • Operating System:
      • WINDOWS 10 64bit
      • Monitor(s):
      • 15.6" IPS
      • Internet:
      • BT Fibre

    flashing 6950 problems

    hey guys i got the powercolour 6950 with the dual cooler and tried to flash the bios.

    Initially i got a subsytems id mismatch, Eventually i found a batch file from techpowerup that flashes it and it seemed to flash however when i reboot the pc i get nothing systems spins up but no bios beep no picture. Tried flashing it 4 times and had to flick back to switch 2 go into wiindows and reload original bios

    have i got a bad one that wont flash or am i doing something wrong.


  2. #2
    Senior Member Max Tractor's Avatar
    Join Date
    Jan 2006
    Posts
    1,248
    Thanks
    44
    Thanked
    41 times in 38 posts
    • Max Tractor's system
      • Motherboard:
      • Biostar TA890GXE
      • CPU:
      • 95w 1055T@x4-3.5Ghz-1.15v
      • Memory:
      • Samsung Green 30nm low voltage 2x4GB@1.26v
      • Storage:
      • Corsair 3 60GB-Sandisk Extreme 240GB
      • Graphics card(s):
      • 7850 2GB
      • PSU:
      • Seasonic SS-1050XM
      • Case:
      • Coolermaster elite 120(Modd)
      • Monitor(s):
      • BenQ EW2430

    Re: flashing 6950 problems

    I have only skimmed on this subject as I was in 2 minds to get that powercolour off ebuyer, not sure which bios you have, but apparently you can get one that just unlocks rather than a full flash to 6970. Have also read conflicting threads/posts as to what can be flashed, comments regarding revision1 etc.

    Other another note what do you think of the powercolour, what is the fan like

    cheers

  3. #3
    Pork & Beans Powerup Phage's Avatar
    Join Date
    May 2009
    Location
    Kent
    Posts
    6,108
    Thanks
    1,530
    Thanked
    581 times in 497 posts
    • Phage's system
      • Motherboard:
      • Asus Crosshair VI
      • CPU:
      • 1700x @ 3.9
      • Memory:
      • 16Gb Corsair LPX
      • Storage:
      • Samsung 960 512Gb + 2Tb Seagate SSHD
      • Graphics card(s):
      • EVGA 1080ti
      • PSU:
      • BeQuiet 850w
      • Case:
      • Fractal R4
      • Operating System:
      • W10 64
      • Monitor(s):
      • Agon Gsync

    Re: flashing 6950 problems

    A quick Google tells me that Powercolor can't be flashed.
    http://www.overclock.net/ati/957870-...50-6970-a.html
    Last edited by Phage; 07-03-2011 at 01:00 PM.
    Society's to blame,
    Or possibly Atari.

  4. #4
    I'm Very Important
    Join Date
    Jul 2009
    Posts
    2,741
    Thanks
    307
    Thanked
    310 times in 278 posts
    • Domestic_Ginger's system
      • Motherboard:
      • Gigabyte GA-MA770-UD3
      • CPU:
      • Phenom II X2 550
      • Memory:
      • 4GB DDR2
      • Storage:
      • F3 500gb
      • Graphics card(s):
      • 5850
      • PSU:
      • Corsair 550vx
      • Case:
      • NZXT beta evo
      • Operating System:
      • W7
      • Monitor(s):
      • G2222HDL

    Re: flashing 6950 problems

    TPU discussion

    You should not have to flash the second bios. Can't help more I'm afraid.

  5. #5
    S1L3NT danroyle's Avatar
    Join Date
    Aug 2006
    Location
    sussex
    Posts
    4,241
    Thanks
    145
    Thanked
    186 times in 153 posts
    • danroyle's system
      • Motherboard:
      • N/A
      • CPU:
      • Intel Core I7 4720HQ
      • Memory:
      • 8GB
      • Storage:
      • 128GB SSD +1tb HDD
      • Graphics card(s):
      • Geforce Gtx960m
      • PSU:
      • N/A
      • Case:
      • N/A
      • Operating System:
      • WINDOWS 10 64bit
      • Monitor(s):
      • 15.6" IPS
      • Internet:
      • BT Fibre

    Re: flashing 6950 problems

    Quote Originally Posted by Domestic_Ginger View Post
    TPU discussion

    You should not have to flash the second bios. Can't help more I'm afraid.
    mine is not the pcs++ ebuyer pulled that from their site last week it now says discontinued mine is the standard version 2gb but with the better cooler.

    It does have the bios switch though


  6. #6
    S1L3NT danroyle's Avatar
    Join Date
    Aug 2006
    Location
    sussex
    Posts
    4,241
    Thanks
    145
    Thanked
    186 times in 153 posts
    • danroyle's system
      • Motherboard:
      • N/A
      • CPU:
      • Intel Core I7 4720HQ
      • Memory:
      • 8GB
      • Storage:
      • 128GB SSD +1tb HDD
      • Graphics card(s):
      • Geforce Gtx960m
      • PSU:
      • N/A
      • Case:
      • N/A
      • Operating System:
      • WINDOWS 10 64bit
      • Monitor(s):
      • 15.6" IPS
      • Internet:
      • BT Fibre

    Re: flashing 6950 problems

    Have tried four different Bioses for this card by the looks of it they have fixed them so they cant be flashed as 6970's which is a bummer although have overclocked it to 890/1325 and it has given it a huge boost in power.


  7. #7
    Pork & Beans Powerup Phage's Avatar
    Join Date
    May 2009
    Location
    Kent
    Posts
    6,108
    Thanks
    1,530
    Thanked
    581 times in 497 posts
    • Phage's system
      • Motherboard:
      • Asus Crosshair VI
      • CPU:
      • 1700x @ 3.9
      • Memory:
      • 16Gb Corsair LPX
      • Storage:
      • Samsung 960 512Gb + 2Tb Seagate SSHD
      • Graphics card(s):
      • EVGA 1080ti
      • PSU:
      • BeQuiet 850w
      • Case:
      • Fractal R4
      • Operating System:
      • W10 64
      • Monitor(s):
      • Agon Gsync
    Society's to blame,
    Or possibly Atari.

  8. #8
    S1L3NT danroyle's Avatar
    Join Date
    Aug 2006
    Location
    sussex
    Posts
    4,241
    Thanks
    145
    Thanked
    186 times in 153 posts
    • danroyle's system
      • Motherboard:
      • N/A
      • CPU:
      • Intel Core I7 4720HQ
      • Memory:
      • 8GB
      • Storage:
      • 128GB SSD +1tb HDD
      • Graphics card(s):
      • Geforce Gtx960m
      • PSU:
      • N/A
      • Case:
      • N/A
      • Operating System:
      • WINDOWS 10 64bit
      • Monitor(s):
      • 15.6" IPS
      • Internet:
      • BT Fibre

    Re: flashing 6950 problems

    thats the guide i used mate no joy at all it flashes the bios but wont boot after restart.


  9. #9
    Pork & Beans Powerup Phage's Avatar
    Join Date
    May 2009
    Location
    Kent
    Posts
    6,108
    Thanks
    1,530
    Thanked
    581 times in 497 posts
    • Phage's system
      • Motherboard:
      • Asus Crosshair VI
      • CPU:
      • 1700x @ 3.9
      • Memory:
      • 16Gb Corsair LPX
      • Storage:
      • Samsung 960 512Gb + 2Tb Seagate SSHD
      • Graphics card(s):
      • EVGA 1080ti
      • PSU:
      • BeQuiet 850w
      • Case:
      • Fractal R4
      • Operating System:
      • W10 64
      • Monitor(s):
      • Agon Gsync

    Re: flashing 6950 problems

    Society's to blame,
    Or possibly Atari.

  10. #10
    S1L3NT danroyle's Avatar
    Join Date
    Aug 2006
    Location
    sussex
    Posts
    4,241
    Thanks
    145
    Thanked
    186 times in 153 posts
    • danroyle's system
      • Motherboard:
      • N/A
      • CPU:
      • Intel Core I7 4720HQ
      • Memory:
      • 8GB
      • Storage:
      • 128GB SSD +1tb HDD
      • Graphics card(s):
      • Geforce Gtx960m
      • PSU:
      • N/A
      • Case:
      • N/A
      • Operating System:
      • WINDOWS 10 64bit
      • Monitor(s):
      • 15.6" IPS
      • Internet:
      • BT Fibre

    Re: flashing 6950 problems

    Quote Originally Posted by Phage View Post
    Am mildly gutted have tried the powercolor pcs++ bios saphire bios asus bios and normal powercolor 6970 bios and the same thing happens everytime.


  11. #11
    Pork & Beans Powerup Phage's Avatar
    Join Date
    May 2009
    Location
    Kent
    Posts
    6,108
    Thanks
    1,530
    Thanked
    581 times in 497 posts
    • Phage's system
      • Motherboard:
      • Asus Crosshair VI
      • CPU:
      • 1700x @ 3.9
      • Memory:
      • 16Gb Corsair LPX
      • Storage:
      • Samsung 960 512Gb + 2Tb Seagate SSHD
      • Graphics card(s):
      • EVGA 1080ti
      • PSU:
      • BeQuiet 850w
      • Case:
      • Fractal R4
      • Operating System:
      • W10 64
      • Monitor(s):
      • Agon Gsync

    Re: flashing 6950 problems

    Did you see the comment in the thread in the first link ? Appareently the Powercolors won't flash.
    Society's to blame,
    Or possibly Atari.

  12. #12
    Bows out! CAT-THE-FIFTH's Avatar
    Join Date
    Aug 2006
    Location
    Hopefully somewhere less backstabby
    Posts
    28,789
    Thanks
    3,203
    Thanked
    4,456 times in 3,442 posts
    • CAT-THE-FIFTH's system
      • Motherboard:
      • Less E-PEEN
      • CPU:
      • Massive E-PEEN
      • Memory:
      • RGB E-PEEN
      • Storage:
      • Not in any order
      • Graphics card(s):
      • EVEN BIGGER E-PEEN
      • PSU:
      • OVERSIZED
      • Case:
      • UNDERSIZED
      • Operating System:
      • DOS 6.22
      • Monitor(s):
      • NOT USUALLY ON....WHEN I POST
      • Internet:
      • FUNCTIONAL

    Re: flashing 6950 problems

    Flashing an HD6950 2GB using an HD6970 BIOS is not a good idea as the HD6970 uses different RAM. You should only try unlocking the shaders.


    Those despicable Elk,stealing the pond weed!

  13. #13
    S1L3NT danroyle's Avatar
    Join Date
    Aug 2006
    Location
    sussex
    Posts
    4,241
    Thanks
    145
    Thanked
    186 times in 153 posts
    • danroyle's system
      • Motherboard:
      • N/A
      • CPU:
      • Intel Core I7 4720HQ
      • Memory:
      • 8GB
      • Storage:
      • 128GB SSD +1tb HDD
      • Graphics card(s):
      • Geforce Gtx960m
      • PSU:
      • N/A
      • Case:
      • N/A
      • Operating System:
      • WINDOWS 10 64bit
      • Monitor(s):
      • 15.6" IPS
      • Internet:
      • BT Fibre

    Re: flashing 6950 problems

    Quote Originally Posted by Phage View Post
    Did you see the comment in the thread in the first link ? Appareently the Powercolors won't flash.
    Yeah i did and that says the powercolour doesnt have dual bios but it does have the dual bios switch.


    @cat

    i tried weith the pcs++ bios which is only unlocked shader and 880 core that didnt work.

    also tried an xfx and hix bios that were 6950 bios with shaders unlocked only, whatever i do i reboot and an the pc fails to post it just sits with everything running and no post.


    am guessing this one wimply wont do it have read alot about people having issues the PCS++ version that is supposed to have shaders unlocked and not having them unlocked.


    @ max tractor fan spins at 100% before pc posts for 5 second like the 8800gts did and thats noisy but once it posts its pretty quiet running furmark it gets a little louder but not majorly.

    It's still a very good card and overclocks very well But i wish i'd paid a little extra and got a reference one
    Last edited by danroyle; 08-03-2011 at 09:28 AM.


  14. Received thanks from:

    Max Tractor (08-03-2011)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XFX 7900GT Artifacting Problems
    By scrandman in forum SCAN.care@HEXUS
    Replies: 1
    Last Post: 23-05-2006, 12:35 PM
  2. Epox 8RDA+ Problems
    By M@dOc in forum PC Hardware and Components
    Replies: 20
    Last Post: 17-07-2004, 03:55 AM
  3. Troubleshooting - Software & Driver problems
    By Steve in forum Help! Quick Relief From Tech Headaches
    Replies: 0
    Last Post: 09-07-2004, 06:30 PM
  4. Flashing
    By Frosty in forum PC Hardware and Components
    Replies: 8
    Last Post: 16-12-2003, 01:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •