Results 1 to 8 of 8

Thread: Graphics Issue

  1. #1
    Member
    Join Date
    Jan 2004
    Posts
    124
    Thanks
    3
    Thanked
    0 times in 0 posts
    • chris123's system
      • Motherboard:
      • Abit NF7-s v2.0
      • CPU:
      • AMD 2600+
      • Memory:
      • 1 gig
      • Storage:
      • 1 x Maxtor 120 gig (ststem disk) , 1 x Western Digital 250 gig
      • Graphics card(s):
      • Ati 9800 pro
      • Case:
      • Antec Sonata
      • Monitor(s):
      • Hanns-G HW191D

    Angry Graphics Issue

    My computer is driving me mad!!

    The spec is in my profile.

    For some reason games are not running on it. This is after a fresh XP install.

    I installed GTA Vice City and Far Cry. Once installed i double clicked the run icon, the screen goes black for a few seconds and then just returns to the desktop.
    I then installed a very old game, Return To Castle Wolfenstein, and it runs fine.

    I don't know if this is connected, but on iTunes i get the message 'itunes is unable to browse album covers on this computer' when trying to look at coverflow.

    Any ideas?

    Cheers in advance.

  2. #2
    ***** Lurker
    Join Date
    Aug 2005
    Posts
    722
    Thanks
    2
    Thanked
    15 times in 15 posts
    • d3fiant's system
      • Motherboard:
      • GB X58A-UDR3 FB11
      • CPU:
      • Core i7 950
      • Memory:
      • Corsair 12GB DDR3 1600
      • Storage:
      • 2x 120GB OCZ Agility SSD + 500GB SP F3
      • Graphics card(s):
      • GB Windforce GTX670 2GB
      • PSU:
      • 850W Akasa
      • Case:
      • Fractal R3
      • Operating System:
      • Windows 7 x64 HP Retail
      • Monitor(s):
      • 24" 1920x1080 Iiyama LED
      • Internet:
      • 60MB VM

    Re: Graphics Issue

    assuming ur running the ATI drivers for ur card, as its an older card the latest catalysts arnt always the best option and can even cause issues. I dont know whats good for older cards, will have a dig around. definately soiunds like a 3d issue, have u run dxdiag to see if the tests run fine?

  3. Received thanks from:

    chris123 (30-12-2007)

  4. #3
    Senior Member grayg1's Avatar
    Join Date
    Jan 2007
    Posts
    661
    Thanks
    10
    Thanked
    31 times in 27 posts
    • grayg1's system
      • Motherboard:
      • Asus P8Z77-V LX
      • CPU:
      • i5 3570k
      • Memory:
      • 24GB Patriot Viper 3 (x2 8GB, x2 4GB)
      • Storage:
      • Crucial 240GB M500 | 1TB Samsung F3
      • Graphics card(s):
      • MSI R9 270X 4GB
      • PSU:
      • Corsair HX650
      • Case:
      • Nanoxia DS1

    Re: Graphics Issue

    Start > Run > open: dxdiag > display tab > test DirectDraw & test Direct3D

    do they work/pass?

  5. Received thanks from:

    chris123 (30-12-2007)

  6. #4
    Mostly Me Lucio's Avatar
    Join Date
    Mar 2007
    Location
    Tring
    Posts
    5,163
    Thanks
    443
    Thanked
    448 times in 351 posts
    • Lucio's system
      • Motherboard:
      • Gigabyte GA-970A-UD3P
      • CPU:
      • AMD FX-6350 with Cooler Master Seldon 240
      • Memory:
      • 2x4GB Corsair DDR3 Vengeance
      • Storage:
      • 128GB Toshiba, 2.5" SSD, 1TB WD Blue WD10EZEX, 500GB Seagate Baracuda 7200.11
      • Graphics card(s):
      • Sapphire R9 270X 4GB
      • PSU:
      • 600W Silverstone Strider SST-ST60F
      • Case:
      • Cooler Master HAF XB
      • Operating System:
      • Windows 8.1 64Bit
      • Monitor(s):
      • Samsung 2032BW, 1680 x 1050
      • Internet:
      • 16Mb Plusnet

    Re: Graphics Issue

    Is there anything in the event log when you try and run the games?

    It's almost certainly a driver issue, because I think that RtCW is an OpenGL game and the others are Direct3D. Best way to test this, uninstall the current drivers and re-install the ones that came on the CD with the card.

    (\___/) (\___/) (\___/) (\___/) (\___/) (\___/) (\___/)
    (='.'=) (='.'=) (='.'=) (='.'=) (='.'=) (='.'=) (='.'=)
    (")_(") (")_(") (")_(") (")_(") (")_(") (")_(") (")_(")


    This is bunny and friends. He is fed up waiting for everyone to help him out, and decided to help himself instead!

  7. Received thanks from:

    chris123 (30-12-2007)

  8. #5
    Member
    Join Date
    Jan 2004
    Posts
    124
    Thanks
    3
    Thanked
    0 times in 0 posts
    • chris123's system
      • Motherboard:
      • Abit NF7-s v2.0
      • CPU:
      • AMD 2600+
      • Memory:
      • 1 gig
      • Storage:
      • 1 x Maxtor 120 gig (ststem disk) , 1 x Western Digital 250 gig
      • Graphics card(s):
      • Ati 9800 pro
      • Case:
      • Antec Sonata
      • Monitor(s):
      • Hanns-G HW191D

    Re: Graphics Issue

    It seems like it may be a driver issue.

    I checked dxdiag. The DirectDraw tests ran fine. But the Direct3D were a different matter...

    "Direct3D 7 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x80004005 (Generic failure)
    Direct3D 8 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)
    Direct3D 9 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)"

    I do have the latest drivers so this may be the problem.
    Cheers for the suggestion Lucio, but it was OEM, so no CD.

    Does anyone know which ones will work for my card?

    Also don't know where of how to view the event log.

  9. #6
    Member
    Join Date
    Jan 2004
    Posts
    124
    Thanks
    3
    Thanked
    0 times in 0 posts
    • chris123's system
      • Motherboard:
      • Abit NF7-s v2.0
      • CPU:
      • AMD 2600+
      • Memory:
      • 1 gig
      • Storage:
      • 1 x Maxtor 120 gig (ststem disk) , 1 x Western Digital 250 gig
      • Graphics card(s):
      • Ati 9800 pro
      • Case:
      • Antec Sonata
      • Monitor(s):
      • Hanns-G HW191D

    Re: Graphics Issue

    Been having a bit of a dig around on the Ati support forums. It would appear it is to do with problems with AGP cards.

    I'm going to go back to 7.7, as suggested on the forum.

    Anyone know where i can get this?

  10. #7
    Senior Member Mithrandir's Avatar
    Join Date
    Sep 2005
    Posts
    2,746
    Thanks
    461
    Thanked
    370 times in 188 posts
    • Mithrandir's system
      • Motherboard:
      • Biostar TP45-HP
      • CPU:
      • C2D e4600 (w/ Xigmatek Red Scorpion)
      • Memory:
      • OCZ ReaperX (2x2gb)
      • Storage:
      • Samsung F1 500gb
      • Graphics card(s):
      • xfx 9600gt Alphadog edition
      • PSU:
      • Xigmatek NRP-MC651
      • Case:
      • Coolermaster Cavalier 3 silver (windowed)
      • Monitor(s):
      • Fujitsu Siemens SCALEOVIEW D22W-1

    Re: Graphics Issue

    I had that problem with Farcry. I would keep loading it and it would flash to black screen then back to desktop. I would reload the prgramme and after several attempts it would work. Sometimes I wold restart the Pc and it would load first time. Wasn't sure what casued it butthen I was using WinXP64.
    Cavalier-X: Biostar TP45-HP ¦ E4600@3.1ghz - Xigmatek Red Scorpion (OCZ Freeze) ¦ OCZ ReaperX 2x2gb (792mhz @ 4-4-4--12) ¦ Xigmatek NRP-MC651 ¦
    Palit 8800gt ¦ X-fi Fatal1ty Gamer ¦ Coolermaster Cavalier 3 (Silver/Windowed) ¦

    Poseidon Magma: MSI P45 Zilent ¦ E6300@3.0ghz - Coolermaster Hyper 212 (MX-2) ¦ Corsair 2x2gb (880mhz @ 5-5-5-15) ¦ Corsair HX450w ¦
    xfx 9600gt Alphadog edition (780/1950/1000) ¦ X-fi Gamer ¦ Gigabyte Poseiden ¦

  11. #8
    Member
    Join Date
    Jan 2004
    Posts
    124
    Thanks
    3
    Thanked
    0 times in 0 posts
    • chris123's system
      • Motherboard:
      • Abit NF7-s v2.0
      • CPU:
      • AMD 2600+
      • Memory:
      • 1 gig
      • Storage:
      • 1 x Maxtor 120 gig (ststem disk) , 1 x Western Digital 250 gig
      • Graphics card(s):
      • Ati 9800 pro
      • Case:
      • Antec Sonata
      • Monitor(s):
      • Hanns-G HW191D

    Re: Graphics Issue

    Cheers for the help on the dxdiag guys.

    I found the old 7.7 drivers on guru3d.com - everything now works again.

    Seems Ati have messed up the latest drivers with support for AGP and nforce boards.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. graphics card for vista advice
    By MKA in forum Graphics Cards
    Replies: 47
    Last Post: 19-09-2007, 07:02 PM
  2. ECS to resume graphics card business
    By Steve in forum HEXUS News
    Replies: 0
    Last Post: 28-12-2005, 11:55 AM
  3. Replies: 14
    Last Post: 24-12-2004, 08:50 PM
  4. Graphics Cards Advice Please
    By smokie10 in forum Graphics Cards
    Replies: 6
    Last Post: 22-11-2004, 10:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •