Results 1 to 7 of 7

Thread: Weird Internet connection issues in Windows 11

  1. #1
    Evil Monkey! MrJim's Avatar
    Join Date
    Aug 2012
    Location
    London
    Posts
    2,167
    Thanks
    241
    Thanked
    397 times in 307 posts
    • MrJim's system
      • Motherboard:
      • MSI Tomahawk X570
      • CPU:
      • AMD Ryzen 5900X
      • Memory:
      • 32gb Kingston 3600 DDR4
      • Storage:
      • Aorus 1Tb NVME SSD, Samsung 1Tb 970 Evo SSD, Crucial 2tb MX500 SSD, Seagate Ironwolf 4Tb SSD
      • Graphics card(s):
      • EVGA 3080Ti
      • PSU:
      • Seasonic Prime Ultra Platinum 1300W
      • Case:
      • Fractal Meshify 2
      • Operating System:
      • Windows 11 Pro
      • Monitor(s):
      • Viewsonic 27" XG2703-GS
      • Internet:
      • BT 900 mb/s FTTP

    Weird Internet connection issues in Windows 11

    As the title says, I'm having a weird connection issue with Internet access using my motherboard's ethernet connection in Windows 11.

    When I cold-boot the PC into Windows 11, the PC reports problems connecting to the Internet. If I then do a warm-boot and restart the PC, everything is fine and the connection is solid. I've tried updating to the most up-to-date ethernet driver, but the problem remains. I'm using all the Windows default settings, with my IP address & DNS being supplied by my ISP.

    I'm using the most recent stable version of the motherboard BIOS. There is a more recent 'beta' version of the BIOS available which states that it improves Windows 11 compatibility, but I generally prefer not to use beta BIOSes, if I can help it.

    Can anyone offer any help? I should mention that I don't have the problem if I connect to my router via wifi rather than ethernet cable.
    Last edited by MrJim; 01-01-2022 at 12:59 PM.

  2. #2
    DDY
    DDY is offline
    Senior Member DDY's Avatar
    Join Date
    Jun 2006
    Posts
    2,814
    Thanks
    180
    Thanked
    616 times in 425 posts
    • DDY's system
      • Motherboard:
      • ASRock Z390M Pro 4
      • CPU:
      • i5 9600k
      • Memory:
      • 32GB (2x16GB) 3600MHz
      • Storage:
      • Adata SX8200 NVME 1TB
      • Graphics card(s):
      • RX 5700
      • PSU:
      • Seasonic Focus Gold 550W
      • Operating System:
      • Win 7 Pro
      • Monitor(s):
      • Dell U2715H

    Re: Weird Internet connection issues in Windows 11

    I've had bad ethernet cables cause this issue, try another cable. Similarly, slightly oxidised connector contacts on both the cable-side and ethernet port has cause the same issue, check and clean the contacts.

  3. Received thanks from:

    MrJim (30-12-2021)

  4. #3
    Evil Monkey! MrJim's Avatar
    Join Date
    Aug 2012
    Location
    London
    Posts
    2,167
    Thanks
    241
    Thanked
    397 times in 307 posts
    • MrJim's system
      • Motherboard:
      • MSI Tomahawk X570
      • CPU:
      • AMD Ryzen 5900X
      • Memory:
      • 32gb Kingston 3600 DDR4
      • Storage:
      • Aorus 1Tb NVME SSD, Samsung 1Tb 970 Evo SSD, Crucial 2tb MX500 SSD, Seagate Ironwolf 4Tb SSD
      • Graphics card(s):
      • EVGA 3080Ti
      • PSU:
      • Seasonic Prime Ultra Platinum 1300W
      • Case:
      • Fractal Meshify 2
      • Operating System:
      • Windows 11 Pro
      • Monitor(s):
      • Viewsonic 27" XG2703-GS
      • Internet:
      • BT 900 mb/s FTTP

    Re: Weird Internet connection issues in Windows 11

    Quote Originally Posted by DDY View Post
    I've had bad ethernet cables cause this issue, try another cable. Similarly, slightly oxidised connector contacts on both the cable-side and ethernet port has cause the same issue, check and clean the contacts.
    Thanks for your reply. It's an interesting idea, but 1) the same cable was used with my old pc, and was working perfectly, and 2), if it's the cable, why would the Internet connection be fine after a warm-boot, but not after a cold-boot? I will see if I can dig out a different cable though, just to see what happens...

  5. #4
    Senior Member
    Join Date
    Jul 2003
    Posts
    11,826
    Thanks
    816
    Thanked
    516 times in 356 posts

    Re: Weird Internet connection issues in Windows 11

    Are you using the random MAC thing in Windows 11?
    How about energy saving in the NIC settings or on the router/switch you are connected too?

  6. Received thanks from:

    MrJim (30-12-2021)

  7. #5
    Evil Monkey! MrJim's Avatar
    Join Date
    Aug 2012
    Location
    London
    Posts
    2,167
    Thanks
    241
    Thanked
    397 times in 307 posts
    • MrJim's system
      • Motherboard:
      • MSI Tomahawk X570
      • CPU:
      • AMD Ryzen 5900X
      • Memory:
      • 32gb Kingston 3600 DDR4
      • Storage:
      • Aorus 1Tb NVME SSD, Samsung 1Tb 970 Evo SSD, Crucial 2tb MX500 SSD, Seagate Ironwolf 4Tb SSD
      • Graphics card(s):
      • EVGA 3080Ti
      • PSU:
      • Seasonic Prime Ultra Platinum 1300W
      • Case:
      • Fractal Meshify 2
      • Operating System:
      • Windows 11 Pro
      • Monitor(s):
      • Viewsonic 27" XG2703-GS
      • Internet:
      • BT 900 mb/s FTTP

    Re: Weird Internet connection issues in Windows 11

    Quote Originally Posted by [GSV]Trig View Post
    Are you using the random MAC thing in Windows 11?
    How about energy saving in the NIC settings or on the router/switch you are connected too?
    Well, it turns out that the beta BIOS fixed it. I thought I'd try the beta, despite my reservations...so far no catastrophic repercussions. The beta I'm using is dated the middle of September...does MSI usually take so long to release updates? The motherboard is the X570 Tomahawk, so not exactly obsolete. Anyway, thanks very much for the valuable help!

  8. #6
    Senior Member AGTDenton's Avatar
    Join Date
    Jun 2009
    Location
    Bracknell
    Posts
    2,177
    Thanks
    679
    Thanked
    554 times in 384 posts
    • AGTDenton's system
      • Motherboard:
      • ASUS P6T7 WS Supercomputer
      • CPU:
      • Intel Core i7 980
      • Memory:
      • 24GB Corsair Dominator GT
      • Storage:
      • Samsung 860 Pro + HDDs
      • Graphics card(s):
      • Asus 1030
      • PSU:
      • Seasonic X-850W
      • Case:
      • Fractal Design R3
      • Operating System:
      • 10 Pro x64
      • Internet:
      • 70MB using BT line

    Re: Weird Internet connection issues in Windows 11

    They often leave it at beta. I've had a few boards where the final BIOS is beta but works fine.

    Interestingly I just built a system for my dad to replace his ageing Media Centre PC with a MSI B450M Mortar Max. Touch wood I've had no problems without the beta BIOS on W11.

  9. #7
    Registered+
    Join Date
    Dec 2021
    Posts
    21
    Thanks
    1
    Thanked
    2 times in 2 posts

    Re: Weird Internet connection issues in Windows 11

    I'm so glad I found this thread, I was having issues with my internet connection on a b550 unify and nothing I found online helped solved the issue. I have never updated the bios and so I wasn't even thinking about that. Updated to the latest bios and no issues whatsoever but I think I might go back to windows 10 for the time being.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •