Results 1 to 10 of 10

Thread: Major Mac OS X Leopard SMB bug solved!

  1. #1
    HEXUS.admin
    Join Date
    Apr 2005
    Posts
    31,661
    Thanks
    0
    Thanked
    2,019 times in 718 posts

    Major Mac OS X Leopard SMB bug solved!

    Soon after deploying OS X Leopard on a series of iMacs, we noticed some worrying behaviour when trying to connect securely to SMB shares. Happily, though, HEXUS discovered a workaround for this bug!
    Read more.
    Last edited by Bob Crabtree; 27-10-2007 at 12:03 AM.

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Posts
    2,536
    Thanks
    15
    Thanked
    4 times in 3 posts

    Re: Major Mac OS X Leopard SMB bug solved!

    Now nobody with a grain of sense is going to be able to say that you've been blinded to any shortcomings in Mac OS X as a result of having made the switch!

    Nice one!
    Last edited by Bob Crabtree; 27-10-2007 at 12:05 AM.

  3. #3
    Senior Member
    Join Date
    Jul 2006
    Posts
    1,457
    Thanks
    33
    Thanked
    75 times in 71 posts

    Re: Major Mac OS X Leopard SMB bug solved!

    I'm sure I've missed something here, but in that link you stated that;

    "My friend knew that I'd made the switch to Leopard earlier in the day and that I also had SMB shares. To try to track down the problem, he first wanted to establish if his iMac could connect to one of the passworded shares on my network - and it could, with no problem at all, even though this was happening remotely via a virtual private network (VPN)."

    Now I assume (I know you shouldn't do that) that your friend typed in the password with the %£$ symbols in it, and he connected fine, this would indicate that the password was accepted with the $%£, and was not the problem.

    Maybe your keyboard settings are not for english(UK), but for english(US), and when you press the % key it was interpretted as another letter/symbol, and so was not recognised as the correct password.

    Sorry if I've totally mis-read the post.

  4. #4
    DR
    DR is offline
    on ye old ship HEXUS DR's Avatar
    Join Date
    Jul 2003
    Location
    HEXUS HQ, Elstree
    Posts
    13,409
    Thanks
    1,054
    Thanked
    831 times in 372 posts

    Re: Major Mac OS X Leopard SMB bug solved!

    Quote Originally Posted by vinnyT View Post
    I'm sure I've missed something here, but in that link you stated that;

    "My friend knew that I'd made the switch to Leopard earlier in the day and that I also had SMB shares. To try to track down the problem, he first wanted to establish if his iMac could connect to one of the passworded shares on my network - and it could, with no problem at all, even though this was happening remotely via a virtual private network (VPN)."

    Now I assume (I know you shouldn't do that) that your friend typed in the password with the %£$ symbols in it, and he connected fine, this would indicate that the password was accepted with the $%£, and was not the problem.

    Maybe your keyboard settings are not for english(UK), but for english(US), and when you press the % key it was interpretted as another letter/symbol, and so was not recognised as the correct password.

    Sorry if I've totally mis-read the post.
    The setup worked fine under Tiger not under Leopard. When he changed the pasword not to include characters such as - %£$ it worked fine.... but when it did include characters such as %£$ it didn't

  5. #5
    Registered User
    Join Date
    Oct 2007
    Posts
    1
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Major Mac OS X Leopard SMB bug solved!

    Try connecting to your Windows shares this way. Works fine for me in Leopard. (No spaces in the actual address.) For added convenience, you then may want to add the share as a Login Item in the Accounts System Preferences.

    cifs://workgroup name or domain name:windows username@IP address/share name

    ---
    GeneH @ genehuller.com

  6. #6
    Senior Member
    Join Date
    Jul 2006
    Posts
    1,457
    Thanks
    33
    Thanked
    75 times in 71 posts

    Re: Major Mac OS X Leopard SMB bug solved!

    Quote Originally Posted by DR View Post
    The setup worked fine under Tiger not under Leopard. When he changed the pasword not to include characters such as - %£$ it worked fine.... but when it did include characters such as %£$ it didn't
    Gotcha. Told you I'd missed something.

  7. #7
    Registered User
    Join Date
    Oct 2007
    Posts
    2
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Major Mac OS X Leopard SMB bug solved!

    I actually have a 10 character alphanumeric with special characters as my login to my Leopard MacBook Pro, and everything works fine except the smb and cifs connections. I get the exact same behavior. This leads me to believe that the problem is focused in the network authentication only, and not OSX Leopard in general.

    hmmmm...

  8. #8
    DR
    DR is offline
    on ye old ship HEXUS DR's Avatar
    Join Date
    Jul 2003
    Location
    HEXUS HQ, Elstree
    Posts
    13,409
    Thanks
    1,054
    Thanked
    831 times in 372 posts

    Re: Major Mac OS X Leopard SMB bug solved!

    Quote Originally Posted by sdlynx View Post
    I actually have a 10 character alphanumeric with special characters as my login to my Leopard MacBook Pro, and everything works fine except the smb and cifs connections. I get the exact same behavior. This leads me to believe that the problem is focused in the network authentication only, and not OSX Leopard in general.

    hmmmm...
    That is interesting that they use different authentication systems....

  9. #9
    Registered User
    Join Date
    Oct 2007
    Posts
    1
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Major Mac OS X Leopard SMB bug solved!

    YMMV, but after reading this thread I was reminded of an issue I've had before regarding passwords and URIs. In short, *some* extended characters must be URI escaped.

    I have a password that contains a % and $, and I was unable to connect using Apple-K with smb://username@server.domain.tld/share. It would prompt for the password, but then hang interminable on the 'Connecting to server smb:// ....' progress bar.

    But, by URI escaping my password, I have just now been able to connect with no problems. One way to URI-escape a password is to type the following at the terminal:
    Code:
    ruby -ruri -e 'puts URI.escape("YourPasswordGoesHere")'
    Hopefully this will help someone!

  10. #10
    Registered User
    Join Date
    Oct 2007
    Posts
    2
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: Major Mac OS X Leopard SMB bug solved!

    Thanks for your escaping method.

    I tried it, but I still couldn't connect. Still getting hung on netauthagent. I think this one is going a little deeper than just a password issue for me.

    It did work for my home network, though.

    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •