Results 1 to 3 of 3

Thread: crossover-cable networking problems

  1. #1
    Join Date
    Aug 2003
    0 times in 0 posts

    crossover-cable networking problems

    I've been tasked with reformatting my girlfriend's laptop (running Win98SE) before her sister borrows it for a year, so I thought I'd hook it up to my main rig (XP Home) to copy all the essential stuff across. So, I've got hold of a crossover cable and strung it between the desktop's PCI NIC and the laptop's PCMCIA Ethernet adaptor. When I try to enable the connection on the XP machine, it fails with "Network cable unplugged".

    I haven't used this cable before, but I bought two at the same time and both give the same symptoms, so I'm assuming the cables themselves are fine. The Ethernet cards on the two machines should also be fine; they certainly both worked six months ago when they were linking the machines to our uni network, and they haven't been used since then.

    I've set the desktop to have an IP of, subnet mask; I also set the default gateway as itself (ie. - is that right? I've disabled as many of the DNS settings as I could; I don't understand why I would need that but if I do, what should I put in?
    The laptop is then set with an IP of, subnet mask again, with the desktop ( as the default gateway. I've tried disabling DNS on this, and enabling it with as the DNS server and with 'LAPTOP' as the host and 'HOME' as the domain (I've also set 'HOME' as the workgroup name for both machines, if that's relevant).

    So, now I don't know what to try next. My gut feeling is that the problem is with the DNS stuff, as I don't understand at all why I would need that here, yet XP is reluctant to let me turn it off. Can anyone shed any light on how I could get this working? Thanks

  2. #2
    Ex-MSFT Paul Adams's Avatar
    Join Date
    Jul 2003
    77 times in 59 posts
    • Paul Adams's system
      • Motherboard:
      • Asus Maximus VIII
      • CPU:
      • Intel Core i7-6700K
      • Memory:
      • 16GB
      • Storage:
      • 2x250GB SSD / 500GB SSD / 2TB HDD
      • Graphics card(s):
      • nVidia GeForce GTX1080
      • Operating System:
      • Windows 10 x64 Pro
      • Monitor(s):
      • Philips 40" 4K
      • Internet:
      • 500Mbps fiber
    Ignore the TCP/IP settings, the "network cable unplugged" is a hardware or flow control issue.
    (Though you do not need a default gateway at all, so leave that blank.)

    Assuming the cable and NICs are good, try setting the duplex and speed the same at both ends (they are probably "Auto").
    If they both support it, I'd try 100Mbps and Full duplex first.

    Hit the "Configure" button in the properties of your NIC to find these settings - it varies from card to card, but most likely is the "Advanced" tab.

    I have had one occasion (with a laptop, oddly enough) where I had to disconnect and reconnect the cable each time I changed the settings, for the OS to realise it was there.
    ~ I have CDO. It's like OCD except the letters are in alphabetical order, as they should be. ~
    PC: Win10 x64 | Asus Maximus VIII | Core i7-6700K | 16GB DDR3 | 2x250GB SSD | 500GB SSD | 2TB SATA-300 | GeForce GTX1080
    Camera: Canon 60D | Sigma 10-20/4.0-5.6 | Canon 100/2.8 | Tamron 18-270/3.5-6.3

  3. #3
    Join Date
    Aug 2003
    0 times in 0 posts
    Thanks for replying. I found the appropriate option on the XP machine but it doesn't seem to exist for the laptop's card. In case it was elsewhere, I went to Device Manager to see if I could get any more configuration options, and the card wasn't listed!

    So, I tried to reinstall the drivers and got a 1F6 error (which Google implied might mean the card is dead ). I removed the device from network properties and tried to reinstall from scratch, trying in turn each of the four drivers that Windows found on the disk.

    ...except the laptop hung as it was restarting after installing the second driver, and as the keyboard isn't responding and there isn't an off switch, I have to wait for the battery to run down before I can do anything else

    Looks like I might be digging out the laplink cable for this job... bah. Thanks for pointing me in the right direction though

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts