Page 1 of 2 12 LastLast
Results 1 to 16 of 17

Thread: 680i Problems

  1. #1
    Member
    Join Date
    Jun 2006
    Location
    London
    Posts
    89
    Thanks
    0
    Thanked
    0 times in 0 posts

    680i Problems

    Been out of touch with 680i chipset motherboards but just wanted to know what problems have occured or are common with these boards.. mainly an EVGA? (just if one occurs to me, i'll know how to fix etc)

    Let me know in terms of both hardware and software.

    Would be a great deal of help not just for me but others who may be interested.
    Rig1: Asus Maximus vi Formula, Intel Haswell 4770K, 16Gb Corsair Vengeance 2400mhz, Corsair AX760i, ATI 280x, Corsair 750D, 4x480Gb Intel 520series SSD, Custom EK Hardline WC

    Rig2: Abit IN9 32X-MAX WiFi NF680i, Intel Core2Duo e6600 Conroe, 2Gb Gskill HZ PC6400, 640MB EVGA 8800GTS, Enermax Galaxy 1Kw, Soundblaster XFI, Lian Li G70, 2x750Gb Seagates, 2x250Gb Samsung Spinpoints, 2x320Gb Seagates, Aquacomputer watercooled, 2xBelinea 102035w 20.1" LCD[/SIZE]

  2. #2
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    The EVGA forums is probably your best bet for info like that mate

  3. #3
    Member
    Join Date
    Jun 2006
    Location
    London
    Posts
    89
    Thanks
    0
    Thanked
    0 times in 0 posts
    Quote Originally Posted by Clunk View Post
    The EVGA forums is probably your best bet for info like that mate
    hehe.. i know but i mean problems with all boards using the same chipset
    Rig1: Asus Maximus vi Formula, Intel Haswell 4770K, 16Gb Corsair Vengeance 2400mhz, Corsair AX760i, ATI 280x, Corsair 750D, 4x480Gb Intel 520series SSD, Custom EK Hardline WC

    Rig2: Abit IN9 32X-MAX WiFi NF680i, Intel Core2Duo e6600 Conroe, 2Gb Gskill HZ PC6400, 640MB EVGA 8800GTS, Enermax Galaxy 1Kw, Soundblaster XFI, Lian Li G70, 2x750Gb Seagates, 2x250Gb Samsung Spinpoints, 2x320Gb Seagates, Aquacomputer watercooled, 2xBelinea 102035w 20.1" LCD[/SIZE]

  4. #4
    finding nemo staffsMike's Avatar
    Join Date
    Jan 2007
    Posts
    11,498
    Thanks
    197
    Thanked
    794 times in 741 posts
    • staffsMike's system
      • Motherboard:
      • evga 680i
      • CPU:
      • e6600
      • Memory:
      • geil ultra pc6400
      • Storage:
      • WD 320gb
      • Graphics card(s):
      • leadtek 8800 GTS 640mb
      • PSU:
      • ocz gameXstream 700w
      • Case:
      • akasa eclipse
      • Monitor(s):
      • dell 2007wfp and Lg L194WT
      • Internet:
      • pipex homecall
    most recent bios update is ****e apparently..mate tried it and he cant overclock properly now lol.

    They don't appriciate most pc8500 RAM out of the box.

    pretty much it.

  5. #5
    No-one's Fanboi Thorsson's Avatar
    Join Date
    Nov 2004
    Location
    Neverneverland
    Posts
    2,749
    Thanks
    47
    Thanked
    93 times in 92 posts
    • Thorsson's system
      • Motherboard:
      • ASUS P8Z77-V PRO
      • CPU:
      • i5 3570k
      • Memory:
      • 2x8Gb Corsair Vengeance PC1866
      • Storage:
      • 256M4 SSD; 2Tb 7200RPM Barracuda; 2Tb Linkstation
      • Graphics card(s):
      • EVGA GTX970 SC
      • PSU:
      • Corsair HX650
      • Case:
      • Antec 300
      • Operating System:
      • Win10 64
      • Monitor(s):
      • Dell 2515H
      • Internet:
      • Fibre Optic 30Mb
    There have been a lot of problems with the chipset. NVidia has been chipping away at them, but there are still issues. Lots of people have had disk corruption problems, and it is reportedly very fussy on voltage settings if you are overclocking.

    Some are lucky, but I wouldn't take the chance.

  6. #6
    Member
    Join Date
    May 2006
    Location
    Geordieland
    Posts
    102
    Thanks
    0
    Thanked
    0 times in 0 posts
    The EVGA website seems to indicate you can only update the bios by floppy, does anyone know if this is true?

  7. #7
    finding nemo staffsMike's Avatar
    Join Date
    Jan 2007
    Posts
    11,498
    Thanks
    197
    Thanked
    794 times in 741 posts
    • staffsMike's system
      • Motherboard:
      • evga 680i
      • CPU:
      • e6600
      • Memory:
      • geil ultra pc6400
      • Storage:
      • WD 320gb
      • Graphics card(s):
      • leadtek 8800 GTS 640mb
      • PSU:
      • ocz gameXstream 700w
      • Case:
      • akasa eclipse
      • Monitor(s):
      • dell 2007wfp and Lg L194WT
      • Internet:
      • pipex homecall
    Quote Originally Posted by UpTheToon View Post
    The EVGA website seems to indicate you can only update the bios by floppy, does anyone know if this is true?
    no thats not true..EVGA have an update program you can use in windows.

  8. #8
    Member
    Join Date
    Jun 2006
    Location
    London
    Posts
    89
    Thanks
    0
    Thanked
    0 times in 0 posts
    are these problems occuring with every 680i chipset boards out there.. ot is it just EVGA?

    As there are many boards i've been referred to such as Abit's IN9 Max or the BFG and Striker.

    Which one would be the best bet?
    Rig1: Asus Maximus vi Formula, Intel Haswell 4770K, 16Gb Corsair Vengeance 2400mhz, Corsair AX760i, ATI 280x, Corsair 750D, 4x480Gb Intel 520series SSD, Custom EK Hardline WC

    Rig2: Abit IN9 32X-MAX WiFi NF680i, Intel Core2Duo e6600 Conroe, 2Gb Gskill HZ PC6400, 640MB EVGA 8800GTS, Enermax Galaxy 1Kw, Soundblaster XFI, Lian Li G70, 2x750Gb Seagates, 2x250Gb Samsung Spinpoints, 2x320Gb Seagates, Aquacomputer watercooled, 2xBelinea 102035w 20.1" LCD[/SIZE]

  9. #9
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    Quote Originally Posted by Carbine View Post

    Which one would be the best bet?
    None of them.

  10. #10
    Old Fool!
    Join Date
    Oct 2003
    Location
    Cambridgeshire
    Posts
    1,027
    Thanks
    11
    Thanked
    37 times in 31 posts
    • EtheAv8r's system
      • Motherboard:
      • ASUS Maximus V Gene
      • CPU:
      • i5 3570K @ 4500 Mhz
      • Memory:
      • 16Gb
      • Storage:
      • 2 x Samsung EVO 850 SSD; 1 x Samsung 2TB HD
      • Graphics card(s):
      • nVidia GeForce GTX 970
      • PSU:
      • Seasonic S-12 650 Energy+
      • Case:
      • Corsair Carbide
      • Operating System:
      • Windows 10 Home 64
      • Monitor(s):
      • Dell U2713H
      • Internet:
      • BT Infinity II
    Agree with Clunk - don't buy a 680i, they are very expensive, and would not be worth the money even if they worked faultlessly, and functioned reliably and brilliantly - for the moment, stick with your 965.
    Try to make each and every day the best it can be.

  11. #11
    Member
    Join Date
    Jun 2006
    Location
    London
    Posts
    89
    Thanks
    0
    Thanked
    0 times in 0 posts
    Quote Originally Posted by EtheAv8r View Post
    Agree with Clunk - don't buy a 680i, they are very expensive, and would not be worth the money even if they worked faultlessly, and functioned reliably and brilliantly - for the moment, stick with your 965.
    well you see, i've just ordered 2 new graphics cards (8800GTX) so i need a board which uses SLi ratehr than crossfire
    Rig1: Asus Maximus vi Formula, Intel Haswell 4770K, 16Gb Corsair Vengeance 2400mhz, Corsair AX760i, ATI 280x, Corsair 750D, 4x480Gb Intel 520series SSD, Custom EK Hardline WC

    Rig2: Abit IN9 32X-MAX WiFi NF680i, Intel Core2Duo e6600 Conroe, 2Gb Gskill HZ PC6400, 640MB EVGA 8800GTS, Enermax Galaxy 1Kw, Soundblaster XFI, Lian Li G70, 2x750Gb Seagates, 2x250Gb Samsung Spinpoints, 2x320Gb Seagates, Aquacomputer watercooled, 2xBelinea 102035w 20.1" LCD[/SIZE]

  12. #12
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    Could be an expensive and unreliable system, good luck
    Quote Originally Posted by Blitzen View Post
    stupid betond belief.
    You owe it to yourself to click here really.

  13. #13
    finding nemo staffsMike's Avatar
    Join Date
    Jan 2007
    Posts
    11,498
    Thanks
    197
    Thanked
    794 times in 741 posts
    • staffsMike's system
      • Motherboard:
      • evga 680i
      • CPU:
      • e6600
      • Memory:
      • geil ultra pc6400
      • Storage:
      • WD 320gb
      • Graphics card(s):
      • leadtek 8800 GTS 640mb
      • PSU:
      • ocz gameXstream 700w
      • Case:
      • akasa eclipse
      • Monitor(s):
      • dell 2007wfp and Lg L194WT
      • Internet:
      • pipex homecall
    They aren't that bad.. I've not had a single problem with mine.

  14. #14
    Old Fool!
    Join Date
    Oct 2003
    Location
    Cambridgeshire
    Posts
    1,027
    Thanks
    11
    Thanked
    37 times in 31 posts
    • EtheAv8r's system
      • Motherboard:
      • ASUS Maximus V Gene
      • CPU:
      • i5 3570K @ 4500 Mhz
      • Memory:
      • 16Gb
      • Storage:
      • 2 x Samsung EVO 850 SSD; 1 x Samsung 2TB HD
      • Graphics card(s):
      • nVidia GeForce GTX 970
      • PSU:
      • Seasonic S-12 650 Energy+
      • Case:
      • Corsair Carbide
      • Operating System:
      • Windows 10 Home 64
      • Monitor(s):
      • Dell U2713H
      • Internet:
      • BT Infinity II
    Quote Originally Posted by Carbine View Post
    well you see, i've just ordered 2 new graphics cards (8800GTX) so i need a board which uses SLi ratehr than crossfire
    Ah I see - that does make a bit of a difference... SLA two 8800GTX's - good luck with the electricity bills!!! LOL
    Try to make each and every day the best it can be.

  15. #15
    finding nemo staffsMike's Avatar
    Join Date
    Jan 2007
    Posts
    11,498
    Thanks
    197
    Thanked
    794 times in 741 posts
    • staffsMike's system
      • Motherboard:
      • evga 680i
      • CPU:
      • e6600
      • Memory:
      • geil ultra pc6400
      • Storage:
      • WD 320gb
      • Graphics card(s):
      • leadtek 8800 GTS 640mb
      • PSU:
      • ocz gameXstream 700w
      • Case:
      • akasa eclipse
      • Monitor(s):
      • dell 2007wfp and Lg L194WT
      • Internet:
      • pipex homecall
    There are cheaper SLi boards..but i think they pci-e x8 rather than x16..

    Check out the 650i chipsets I might be wrong and cant be bothered to check lol

  16. #16
    Senior Member kalniel's Avatar
    Join Date
    Aug 2005
    Posts
    29,196
    Thanks
    1,520
    Thanked
    2,933 times in 2,376 posts
    • kalniel's system
      • Motherboard:
      • Gigabyte X58A UD3R rev 2
      • CPU:
      • Intel Xeon X5680
      • Memory:
      • 12gb DDR3 2000
      • Graphics card(s):
      • nVidia GTX 1060 6GB
      • PSU:
      • Seasonic 600W
      • Case:
      • Cooler Master HAF 912
      • Operating System:
      • Win 10 Pro x64
      • Monitor(s):
      • Dell U2311H
      • Internet:
      • O2 8mbps
    And PCI-E x8 is absolutely no restriction at all, so go for it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My experience with Windows XP Pro x64 Edition
    By Paul Adams in forum Software
    Replies: 7
    Last Post: 20-04-2007, 11:59 PM
  2. CHKDSK, Corruption and Consistency
    By Speed in forum Help! Quick Relief From Tech Headaches
    Replies: 17
    Last Post: 16-09-2006, 02:13 PM
  3. Problems with new machine
    By kasavien in forum SCAN.care@HEXUS
    Replies: 5
    Last Post: 31-01-2006, 01:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •