Results 1 to 6 of 6

Thread: Power Connectors on AB9 and AW9D-Max

  1. #1
    Lover & Fighter Blitzen's Avatar
    Join Date
    Oct 2006
    Location
    Between Your Mum & Sister
    Posts
    6,310
    Thanks
    539
    Thanked
    382 times in 300 posts
    • Blitzen's system
      • Motherboard:
      • ABIT iX38 QuadGT
      • CPU:
      • Intel Quad Q6600 @ 3.6Ghz : 30 Degrees Idle - 41-46 Degrees Load
      • Memory:
      • 4 x 1GB OCZ Platinum PC6400 @ 4-4-4-12
      • Storage:
      • 2 x 500GB Samsung Spinpoints - RAID 0
      • Graphics card(s):
      • GTX 285
      • PSU:
      • Enermax MODU 82+ 625W
      • Case:
      • Antec Nine Hundred
      • Operating System:
      • Windows 7 Ultimate 64Bit
      • Monitor(s):
      • Viewsonic Q22wb 22" Widescreen - 5ms
      • Internet:
      • O2 premium @ 17mb

    Power Connectors on AB9 and AW9D-Max

    I have just been deciding which board to buy and this has cropped up.

    I have looked closely at pictures of both and i see a connector on the boards i am not familiar with.

    On my current board i have a 24 pin power connector and the 4 pin power connector (12V right?).

    Anyway, on the above mentioned boards i dont see this 4 pin power connector......i only see an 8 pin one. Can anyone please enlighten me on this as i have an Enermax Liberty 620W and this doesnt have the 8 pin plug as far as im aware.

    This is the last mobo wuestion.......promise!


  2. #2
    finding nemo staffsMike's Avatar
    Join Date
    Jan 2007
    Posts
    11,497
    Thanks
    197
    Thanked
    794 times in 741 posts
    • staffsMike's system
      • Motherboard:
      • evga 680i
      • CPU:
      • e6600
      • Memory:
      • geil ultra pc6400
      • Storage:
      • WD 320gb
      • Graphics card(s):
      • leadtek 8800 GTS 640mb
      • PSU:
      • ocz gameXstream 700w
      • Case:
      • akasa eclipse
      • Monitor(s):
      • dell 2007wfp and Lg L194WT
      • Internet:
      • pipex homecall
    You use two 4 pins...

  3. #3
    Lover & Fighter Blitzen's Avatar
    Join Date
    Oct 2006
    Location
    Between Your Mum & Sister
    Posts
    6,310
    Thanks
    539
    Thanked
    382 times in 300 posts
    • Blitzen's system
      • Motherboard:
      • ABIT iX38 QuadGT
      • CPU:
      • Intel Quad Q6600 @ 3.6Ghz : 30 Degrees Idle - 41-46 Degrees Load
      • Memory:
      • 4 x 1GB OCZ Platinum PC6400 @ 4-4-4-12
      • Storage:
      • 2 x 500GB Samsung Spinpoints - RAID 0
      • Graphics card(s):
      • GTX 285
      • PSU:
      • Enermax MODU 82+ 625W
      • Case:
      • Antec Nine Hundred
      • Operating System:
      • Windows 7 Ultimate 64Bit
      • Monitor(s):
      • Viewsonic Q22wb 22" Widescreen - 5ms
      • Internet:
      • O2 premium @ 17mb
    Quote Originally Posted by staffsMike View Post
    You use two 4 pins...
    They different to the PCI-E connector ones then?

    The only one i have is the 4 pin power plug...surely a liberty would have the lot wouldnt it?

  4. #4
    Senior Member GSte's Avatar
    Join Date
    Feb 2007
    Location
    Bolton
    Posts
    1,538
    Thanks
    220
    Thanked
    76 times in 64 posts
    • GSte's system
      • Motherboard:
      • P6T Deluxe
      • CPU:
      • i7 920 @ 4.2GHz / TRUE
      • Memory:
      • 6GB GSkill 1600MHz cas6
      • Storage:
      • 250GB Barracuda, 2 x WD 500GB AAKS, 1TB Caviar Black
      • Graphics card(s):
      • GTX470
      • PSU:
      • NorthQ Black Magic Flex 850W
      • Case:
      • X-Clio Windtunnel
      • Operating System:
      • XP Home, Vista Home Premium X64, Win7 Home X64
      • Monitor(s):
      • Samsung 245B
      • Internet:
      • Be Not So Happy
    You'd think so.... my 480W Tagan has two 4 pin plugs that slot together to from an 8 pin one. They look like the PCI-e ones apart from they are 4 pin rather than 6.

  5. #5
    Senior Member
    Join Date
    Jun 2006
    Posts
    748
    Thanks
    14
    Thanked
    25 times in 25 posts
    • DratUK's system
      • Motherboard:
      • ASUS P877-V Pro
      • CPU:
      • I5 3570K with Antec Kuhler 920
      • Memory:
      • 8Gb Corsair Vengance
      • Storage:
      • 120Gb OCZ Vertex 2 Sandforce, 1TB WD
      • Graphics card(s):
      • Palit Jetstream 670
      • PSU:
      • Enermax 720
      • Case:
      • Lian Li A10B
      • Operating System:
      • Win 7 64
      • Monitor(s):
      • Dell 24" 1900x1200
      • Internet:
      • VM 100
    According to the Enermax webbie you have a 4+4 pin power coonector for Dual Core systems.

    http://www.enermax.co.uk/products/ps...0AWT/cable.asp

  6. #6
    Resident abit mourner BUFF's Avatar
    Join Date
    Jul 2003
    Location
    Sunny Glasgow
    Posts
    8,067
    Thanks
    7
    Thanked
    181 times in 171 posts
    both will run fine with just a single 4-pin ATX12V1 connector.

    MSI P55-GD80, i5 750
    abit A-S78H, Phenom 9750,

    My HEXUS.trust abit forums

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •