Results 1 to 3 of 3

Thread: Mobo Chipset

  1. #1
    Senior Member
    Join Date
    Apr 2007
    Location
    Kent
    Posts
    206
    Thanks
    7
    Thanked
    7 times in 6 posts
    • will101's system
      • Motherboard:
      • ASUS M4A79XTD EVO
      • CPU:
      • AMD Phenom II x4 965 Black Edition C3 stepping
      • Memory:
      • 4GB (2 x 2GB) DDR3 Corsiar Dominator
      • Storage:
      • 120GB Corsair Force 3 SSD
      • Graphics card(s):
      • XFX HD6950
      • PSU:
      • Corsair HX620W
      • Case:
      • AKASA Mirage
      • Operating System:
      • Windows 7 Home Premium x64
      • Monitor(s):
      • 22" Samsung Syncmaster 226BW
      • Internet:
      • BT Infinity 70Mbit down/20Mbit up

    Question Mobo Chipset

    Currently I'm thinking along the NF590 route but I won't be running crossfire (or Sli!) as I will be using a single highend card.

    Is there a cheaper alternative to the latest dual graphics card supporting chipsets but which still has the same SATA, USB, firewire, etc performance?

    It'd be worth noting I'm looking for an AM2 mobo!

  2. #2
    Resident abit mourner BUFF's Avatar
    Join Date
    Jul 2003
    Location
    Sunny Glasgow
    Posts
    8,067
    Thanks
    7
    Thanked
    181 times in 171 posts
    http://www.nvidia.com/page/nforce5_specs_amd.html

    nF570 Ultra?
    The performance of the SATA & USB will probably be the same across all of them just a difference in features (no. of SATA/PATA drives supported etc.)
    Firewire is a separate onboard chip anyway.

    Actually some of the nF4 AM2 boards are very good e.g. abit's KN9 (nF4 Ultra) & it's only £42
    http://www.scan.co.uk/Products/Produ...oductID=451486 - no firewire on that if you need it though

    MSI P55-GD80, i5 750
    abit A-S78H, Phenom 9750,

    My HEXUS.trust abit forums

  3. #3
    Senior Member GSte's Avatar
    Join Date
    Feb 2007
    Location
    Bolton
    Posts
    1,538
    Thanks
    220
    Thanked
    76 times in 64 posts
    • GSte's system
      • Motherboard:
      • P6T Deluxe
      • CPU:
      • i7 920 @ 4.2GHz / TRUE
      • Memory:
      • 6GB GSkill 1600MHz cas6
      • Storage:
      • 250GB Barracuda, 2 x WD 500GB AAKS, 1TB Caviar Black
      • Graphics card(s):
      • GTX470
      • PSU:
      • NorthQ Black Magic Flex 850W
      • Case:
      • X-Clio Windtunnel
      • Operating System:
      • XP Home, Vista Home Premium X64, Win7 Home X64
      • Monitor(s):
      • Samsung 245B
      • Internet:
      • Be Not So Happy
    I second that, I had the KN9 and it was an excellent board.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New ABIT AB9 PRO MoBo looks dead.
    By abhide in forum abit.care@HEXUS
    Replies: 15
    Last Post: 26-01-2007, 05:20 PM
  2. Chipset Heatsink installation help!
    By Leepox in forum PC Hardware and Components
    Replies: 12
    Last Post: 12-01-2007, 01:10 PM
  3. Excel Formula Help
    By Lead_Head in forum Software
    Replies: 7
    Last Post: 02-10-2006, 10:09 AM
  4. Asrock K7VT4A PRO - What chipset?!?!?
    By maverick77_uk in forum PC Hardware and Components
    Replies: 2
    Last Post: 30-07-2006, 08:20 PM
  5. ASUS A8N-SLI deluxe Chipset Fan Problem (please help me out)
    By Kusnadi in forum Help! Quick Relief From Tech Headaches
    Replies: 9
    Last Post: 06-10-2005, 07:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •