Results 1 to 14 of 14

Thread: Soundcards with decent vista suport

  1. #1
    SeƱor Member Flewis's Avatar
    Join Date
    Jan 2007
    Location
    Sutton, Surrey
    Posts
    765
    Thanks
    4
    Thanked
    27 times in 24 posts
    • Flewis's system
      • Motherboard:
      • MSI P45 Platinum
      • CPU:
      • Intel E7200 @ 3.5GHz
      • Memory:
      • 4x1GB Corsair PC5400 @ 720MHz 4-4-4-11
      • Storage:
      • 2 x Samsung Spinpoint 500GB
      • Graphics card(s):
      • 2 x ATI HD4850
      • PSU:
      • 750W Silverstone Zeus
      • Case:
      • AOpen H700B custom watercooled
      • Operating System:
      • Vista HP x64
      • Internet:
      • Plusnet fibre

    Soundcards with decent vista suport

    Creative XFI sound drivers at the moment appear to be dire by all accounts and i was wondering whether any of the decent high end sound cards had decent driver support?

    Its all well and good advising people away from creative but what are the alternatives?

  2. #2
    Senior Member
    Join Date
    Aug 2005
    Location
    Brisbane
    Posts
    612
    Thanks
    20
    Thanked
    35 times in 22 posts
    • toolsong's system
      • Motherboard:
      • ASUS P7P55D EVO
      • CPU:
      • i7 860 @ 3.8 GHz
      • Memory:
      • 2 x 4GB Corsair Vengeance
      • Storage:
      • SSDs
      • Graphics card(s):
      • GTX970
      • PSU:
      • Seasonic X650
      • Case:
      • Antec P180
      • Operating System:
      • Win7 x64
      • Monitor(s):
      • Dell U2515H
      • Internet:
      • Fibre @ 100/40
    http://www.rme-audio.de/en_products_hdsp_9632.php

    Stereo only
    No hardware extensions for gaming
    Sounds fantastic!

  3. #3
    Senior Member this_is_gav's Avatar
    Join Date
    Dec 2005
    Location
    Alnwick, Northumberland
    Posts
    4,835
    Thanks
    175
    Thanked
    246 times in 213 posts
    • this_is_gav's system
      • Motherboard:
      • DFI DK X58-T3eH6
      • CPU:
      • Intel i7 920
      • Memory:
      • 12GB Corsair 1333MHz C9
      • Storage:
      • 2xRaptor 150GB (RAID0 300GB), 2.5TB permanent storage
      • Graphics card(s):
      • Nvidia GTX 560 Ti 1GB
      • PSU:
      • Seasonic X-series
      • Case:
      • Lian-Li A70B
      • Operating System:
      • Windows 7 x64
      • Monitor(s):
      • Dell 2408WFP
      • Internet:
      • 8M ADSL24
    Hold back until the UK get some Auzentech X-Meridian 7.1s? There's a few places claiming they'll have stock in a few days (Scan included), but whether it materialises is another matter.

    Auzentech only have beta drivers out for Vista, but they simply can't be worse than the Creative ones.

    //edit: I lie. Scan have it on pre-order but no ETA. I think it was one of the Terratec cards I was thinking of (all of which appear to have stock now). Was other etailers I must have been thinking of.
    Last edited by this_is_gav; 16-05-2007 at 03:24 PM.

  4. #4
    Senior Member
    Join Date
    Sep 2006
    Location
    Leeds
    Posts
    2,594
    Thanks
    80
    Thanked
    106 times in 94 posts
    You can discount pretty much the entire Creative product line with regards to Vista support. My Audigy 4 works fine in vista, but with alot of options not available.

  5. #5
    Member
    Join Date
    Apr 2006
    Location
    Glasgow
    Posts
    195
    Thanks
    1
    Thanked
    4 times in 3 posts
    Why are Creative not sorting this issue out? It makes no sense to have no Vista drivers available for what is probably to biggest selling audio card on the market.

    Surely their must be more to this story, have Creative fallen out with Microsoft???

  6. #6
    Senior Member
    Join Date
    Aug 2005
    Location
    Brisbane
    Posts
    612
    Thanks
    20
    Thanked
    35 times in 22 posts
    • toolsong's system
      • Motherboard:
      • ASUS P7P55D EVO
      • CPU:
      • i7 860 @ 3.8 GHz
      • Memory:
      • 2 x 4GB Corsair Vengeance
      • Storage:
      • SSDs
      • Graphics card(s):
      • GTX970
      • PSU:
      • Seasonic X650
      • Case:
      • Antec P180
      • Operating System:
      • Win7 x64
      • Monitor(s):
      • Dell U2515H
      • Internet:
      • Fibre @ 100/40
    Have you seen or heard of the mess regarding Vista drivers on their support forums?

    Puts the "Fiesty Hexus" thread to shame

  7. #7
    Member
    Join Date
    Apr 2006
    Location
    Glasgow
    Posts
    195
    Thanks
    1
    Thanked
    4 times in 3 posts
    Apart from reading the initial reaction to Vista when it was launched I haven't been following it very closely. I'm very happy with my current installation of XP, until dx10 becomes an issue I can see me upgrading.

    I had assumed like every other launch of Windows eventually all the major players would have drivers ready for their current / recent hardware. It's unbelievable that Creative have left users is limbo for such a long time. This is another issue that would discourage me from upgrading to Vista. Surely a resolution will be forthcoming....

  8. #8
    Senior Member this_is_gav's Avatar
    Join Date
    Dec 2005
    Location
    Alnwick, Northumberland
    Posts
    4,835
    Thanks
    175
    Thanked
    246 times in 213 posts
    • this_is_gav's system
      • Motherboard:
      • DFI DK X58-T3eH6
      • CPU:
      • Intel i7 920
      • Memory:
      • 12GB Corsair 1333MHz C9
      • Storage:
      • 2xRaptor 150GB (RAID0 300GB), 2.5TB permanent storage
      • Graphics card(s):
      • Nvidia GTX 560 Ti 1GB
      • PSU:
      • Seasonic X-series
      • Case:
      • Lian-Li A70B
      • Operating System:
      • Windows 7 x64
      • Monitor(s):
      • Dell 2408WFP
      • Internet:
      • 8M ADSL24
    Quote Originally Posted by wmsteele View Post
    Why are Creative not sorting this issue out? It makes no sense to have no Vista drivers available for what is probably to biggest selling audio card on the market.
    Some seem to think there's a PCIe product (line?) coming along to milk the Vista crowd. That's all very likely I guess, but the timing suggests this isn't the reason for the delay in drivers.

    The simple fact is Creative have been the laziest (major) company on the planet for developing drivers for years now.

  9. #9
    Registered User
    Join Date
    May 2007
    Location
    Telford
    Posts
    91
    Thanks
    0
    Thanked
    0 times in 0 posts
    • Tel_Tech's system
      • Motherboard:
      • P5K
      • CPU:
      • Q6600 @ 3.2Ghz
      • Memory:
      • 4gig DDR2 800
      • Storage:
      • 500gig Samsung
      • Graphics card(s):
      • 8800GT
      • PSU:
      • 750W Thermaltake
      • Case:
      • Coolermaster Blue Flame
      • Monitor(s):
      • 26" Acer
      • Internet:
      • 20meg Virgin
    Bear in mind XFI sound quality in Vista is borked on account of it being defaulted to 16bit instead of 24bit playback. You can adjust that in Playback Device settings as I recall and it made a big difference on my Audigy2 when I was having issues.

  10. #10
    Anthropomorphic Personification shaithis's Avatar
    Join Date
    Apr 2004
    Location
    The Last Aerie
    Posts
    10,830
    Thanks
    645
    Thanked
    870 times in 734 posts
    • shaithis's system
      • Motherboard:
      • Asus P8Z77 WS
      • CPU:
      • i7 3770k @ 4.5GHz
      • Memory:
      • 32GB HyperX 1866
      • Storage:
      • Lots!
      • Graphics card(s):
      • Sapphire Fury X
      • PSU:
      • Corsair HX850
      • Case:
      • Corsair 600T (White)
      • Operating System:
      • Windows 10 x64
      • Monitor(s):
      • 2 x Dell 3007
      • Internet:
      • Zen 80Mb Fibre
    Creative have had working drivers since vista was in beta. Yes, I had to change a few settings after installing them to get things to my liking but sound cards are very configurable devices and that's always been the case regardless of manufacturer or OS.

    I'm currently running Vista x64 with an XFi (hell, even an 8800GTX as well) without driver issues.

    It seems to be very fashionable at the moment to completely knock a company if "someone has heard about someone with a vista driver problem"
    Main PC: Asus Rampage IV Extreme / 3960X@4.5GHz / Antec H1200 Pro / 32GB DDR3-1866 Quad Channel / Sapphire Fury X / Areca 1680 / 850W EVGA SuperNOVA Gold 2 / Corsair 600T / 2x Dell 3007 / 4 x 250GB SSD + 2 x 80GB SSD / 4 x 1TB HDD (RAID 10) / Windows 10 Pro, Yosemite & Ubuntu
    HTPC: AsRock Z77 Pro 4 / 3770K@4.2GHz / 24GB / GTX 1080 / SST-LC20 / Antec TP-550 / Hisense 65k5510 4K TV / HTC Vive / 2 x 240GB SSD + 12TB HDD Space / Race Seat / Logitech G29 / Win 10 Pro
    HTPC2: Asus AM1I-A / 5150 / 4GB / Corsair Force 3 240GB / Silverstone SST-ML05B + ST30SF / Samsung UE60H6200 TV / Windows 10 Pro
    Spare/Loaner: Gigabyte EX58-UD5 / i950 / 12GB / HD7870 / Corsair 300R / Silverpower 700W modular
    NAS 1: HP N40L / 12GB ECC RAM / 2 x 3TB Arrays || NAS 2: Dell PowerEdge T110 II / 24GB ECC RAM / 2 x 3TB Hybrid arrays || Network:Buffalo WZR-1166DHP w/DD-WRT + HP ProCurve 1800-24G
    Laptop: Lenovo Flex 2 / 12GB RAM / 240GB Corsair Force 3 Printer: HP CP1515n || Phone: HTC One U11 || Other: Samsung Galaxy Tab 4 Pro 10.1 CM12.1 / Playstation 4 + G29 + 2TB Hybrid drive

  11. #11
    Gentoo Ricer
    Join Date
    Jan 2005
    Location
    Galway
    Posts
    11,023
    Thanks
    1,008
    Thanked
    944 times in 704 posts
    • aidanjt's system
      • Motherboard:
      • Asus Strix Z370-G
      • CPU:
      • Intel i7-8700K
      • Memory:
      • 2x8GB Corsiar LPX 3000C15
      • Storage:
      • 500GB Samsung 960 EVO
      • Graphics card(s):
      • EVGA GTX 970 SC ACX 2.0
      • PSU:
      • EVGA G3 750W
      • Case:
      • Fractal Design Define C Mini
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • 240mbps Virgin Cable
    Microsoft knocked the legs out from under CL with the new UM audio driver model and took the direct out of direct sound, CL is using OpenAL as a work around for this but obviously the support is basic at best, it'll take some time until they're up to XP standards, Vista is rather pathetic for audio period anyway, if you want decent sound, you're going to have to step back operating system wise. Given CL's world renound reputation for driver development (or lack thereof, Linux users have been waiting for X-Fi drivers for a year and a half and it's currently looking like it'll be 2 and a half before beta drivers are out), I wouldn't hold your breath as far as strong Vista driver support goes.
    Quote Originally Posted by Agent View Post
    ...every time Creative bring out a new card range their advertising makes it sound like they have discovered a way to insert a thousand Chuck Norris super dwarfs in your ears...

  12. #12
    Senior Member this_is_gav's Avatar
    Join Date
    Dec 2005
    Location
    Alnwick, Northumberland
    Posts
    4,835
    Thanks
    175
    Thanked
    246 times in 213 posts
    • this_is_gav's system
      • Motherboard:
      • DFI DK X58-T3eH6
      • CPU:
      • Intel i7 920
      • Memory:
      • 12GB Corsair 1333MHz C9
      • Storage:
      • 2xRaptor 150GB (RAID0 300GB), 2.5TB permanent storage
      • Graphics card(s):
      • Nvidia GTX 560 Ti 1GB
      • PSU:
      • Seasonic X-series
      • Case:
      • Lian-Li A70B
      • Operating System:
      • Windows 7 x64
      • Monitor(s):
      • Dell 2408WFP
      • Internet:
      • 8M ADSL24
    Quote Originally Posted by shaithis View Post
    It seems to be very fashionable at the moment to completely knock a company if "someone has heard about someone with a vista driver problem"
    It's equally fashionable to look around and find thousands who are experiencing the exact same problems you are. I'm yet to find a single Audigy 2/4 (Pro, or with breakout box - not the cheapo cut down versions) user who can get 5.1 in Vista x64 final. It seems with Vista x86 you can sometimes get lucky by forcing it to use the XP drivers...

    It says it all really.

  13. #13
    Senior Member
    Join Date
    Aug 2003
    Posts
    6,457
    Thanks
    0
    Thanked
    226 times in 192 posts
    Quote Originally Posted by this_is_gav View Post
    The simple fact is Creative have been the laziest (major) company on the planet for developing drivers for years now.
    The sad part is, the X-Fi line is still one of the better gaming/entertainment card around.

    *Ponders how things might have been if Aureal was still around*

    People often given MS/Intel/Apple a hard time, but to me, Creative deserves more.

  14. #14
    Gentoo Ricer
    Join Date
    Jan 2005
    Location
    Galway
    Posts
    11,023
    Thanks
    1,008
    Thanked
    944 times in 704 posts
    • aidanjt's system
      • Motherboard:
      • Asus Strix Z370-G
      • CPU:
      • Intel i7-8700K
      • Memory:
      • 2x8GB Corsiar LPX 3000C15
      • Storage:
      • 500GB Samsung 960 EVO
      • Graphics card(s):
      • EVGA GTX 970 SC ACX 2.0
      • PSU:
      • EVGA G3 750W
      • Case:
      • Fractal Design Define C Mini
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • 240mbps Virgin Cable
    Well... MS and Apple deserve it, Creative just deserve it more than both combined for being worthless as far as support is concerned.
    Quote Originally Posted by Agent View Post
    ...every time Creative bring out a new card range their advertising makes it sound like they have discovered a way to insert a thousand Chuck Norris super dwarfs in your ears...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 22-03-2007, 10:00 PM
  2. MS releases public 'Beta' version of Vista
    By Mithrandir in forum Retail Therapy and Bargains
    Replies: 154
    Last Post: 29-06-2006, 12:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •