Results 1 to 15 of 15

Thread: P5B and USb keyboard

  1. #1
    www.dougmcdonald.co.uk
    Join Date
    May 2007
    Location
    Bath
    Posts
    523
    Thanks
    5
    Thanked
    20 times in 20 posts
    • DougMcDonald's system
      • Motherboard:
      • Asus P5B Deluxe
      • CPU:
      • Inter Core 2 Duo E6600
      • Memory:
      • 2 x 2GB - Geil Black Dragon PC6400
      • Storage:
      • 2 x 400GB Samsung Spinpoints (Running in Matrix array) 100GB @ RAID0 + 300GB @ RAID1
      • Graphics card(s):
      • BFG nVidia 8800GTS 320MB OC2
      • PSU:
      • Corsair HX520W modular
      • Case:
      • Lian-Li PC7 II Plus
      • Monitor(s):
      • LG 17" Flat Thingy
      • Internet:
      • Crappy BT 1MB Unreliable wank :s

    P5B and USb keyboard

    Hi guys, quick question,

    I've got an asus p5b and recently got a nice usb keyboard.

    Prior to the keyboard i was running 333x9 and quite happy after a new (hsf install) but now i want to start pushing 350 plus.

    Strangely i cannot seem to get into bios setup utility using the usb keyboard, only via my old ps2 one. Anyone else seen this issue, or know how to get around it?

  2. #2
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    Fit the old one.

    Get into the bios.

    Enable legacy USB.

    Save and exit.

    Power off.

    Refit new USB keyboard.
    Quote Originally Posted by Blitzen View Post
    stupid betond belief.
    You owe it to yourself to click here really.

  3. #3
    www.dougmcdonald.co.uk
    Join Date
    May 2007
    Location
    Bath
    Posts
    523
    Thanks
    5
    Thanked
    20 times in 20 posts
    • DougMcDonald's system
      • Motherboard:
      • Asus P5B Deluxe
      • CPU:
      • Inter Core 2 Duo E6600
      • Memory:
      • 2 x 2GB - Geil Black Dragon PC6400
      • Storage:
      • 2 x 400GB Samsung Spinpoints (Running in Matrix array) 100GB @ RAID0 + 300GB @ RAID1
      • Graphics card(s):
      • BFG nVidia 8800GTS 320MB OC2
      • PSU:
      • Corsair HX520W modular
      • Case:
      • Lian-Li PC7 II Plus
      • Monitor(s):
      • LG 17" Flat Thingy
      • Internet:
      • Crappy BT 1MB Unreliable wank :s
    Hi Clunk,

    thanks for the suggestion but this doesn't seem to work

    The bios will detect the USB device and even report that the keyboard contains a hub and also report the device attached to it, but i guess it's not active enough to use the keys until it gets further through the posting

    Bit of a pain really.

    Anyone got any other suggestions?

  4. #4
    Senior Member
    Join Date
    Sep 2006
    Location
    Leeds
    Posts
    2,598
    Thanks
    80
    Thanked
    106 times in 94 posts
    Ive had this problem before. Never found the answer.

    Ive had 4 different USB keyboards running from the same PC over the last 6 months and 1 of them wouldn't work outside windows. The other 3 worked in the BIOS etc
    Last edited by s_kinton; 19-06-2007 at 02:13 PM.

  5. #5
    No-one's Fanboi Thorsson's Avatar
    Join Date
    Nov 2004
    Location
    Neverneverland
    Posts
    2,749
    Thanks
    47
    Thanked
    93 times in 92 posts
    • Thorsson's system
      • Motherboard:
      • ASUS P8Z77-V PRO
      • CPU:
      • i5 3570k
      • Memory:
      • 2x8Gb Corsair Vengeance PC1866
      • Storage:
      • 256M4 SSD; 2Tb 7200RPM Barracuda; 2Tb Linkstation
      • Graphics card(s):
      • EVGA GTX970 SC
      • PSU:
      • Corsair HX650
      • Case:
      • Antec 300
      • Operating System:
      • Win10 64
      • Monitor(s):
      • Dell 2515H
      • Internet:
      • Fibre Optic 30Mb
    1. Try using a different USB port - the ones direct into the mobo seem to work better for me; or
    2. Use a USB to PS2 adapter.

  6. #6
    asphinctersayswhat dannyboy83's Avatar
    Join Date
    Sep 2005
    Location
    Hamilton, Scotland
    Posts
    677
    Thanks
    3
    Thanked
    0 times in 0 posts
    I have a USB keyboard (Apply Pro one) and the P5B and it worked straight away. Strange that your having problems! Must be certain keyboards...

    My System: Coolermaster Centurion 5 (black) case, Intel E6750 Core2Duo, Tagan Easy-Con 530W, Asus P5B Deluxe WIFI, OCZ 2GB Kit (2x1GB) DDR2 800MHz/PC2-6400 CL 4-4-4-15 PLATINUM XTC, Samsung SpinPoint 200Gb SATA2 / 2 x Maxtor DiamondMax 10 200Gb SATA, 256Mb Sapphire ATI PCI-E X1950PRO, Creative X-Fi Xtreme 7.1, 19" Daewoo W9ZQ Black Widescreen TFT, 4Mb Virgin Cable Broadband (formerly Blueyonder) with Linksys WRT54GL Wireless-G and DD-WRT firmware.

  7. #7
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    It does seem to be certain keyboards. I have a logitech that didnt like having the legacy USB turned off (on the P5B), but that worked by keeping it on.
    Quote Originally Posted by Blitzen View Post
    stupid betond belief.
    You owe it to yourself to click here really.

  8. #8
    www.dougmcdonald.co.uk
    Join Date
    May 2007
    Location
    Bath
    Posts
    523
    Thanks
    5
    Thanked
    20 times in 20 posts
    • DougMcDonald's system
      • Motherboard:
      • Asus P5B Deluxe
      • CPU:
      • Inter Core 2 Duo E6600
      • Memory:
      • 2 x 2GB - Geil Black Dragon PC6400
      • Storage:
      • 2 x 400GB Samsung Spinpoints (Running in Matrix array) 100GB @ RAID0 + 300GB @ RAID1
      • Graphics card(s):
      • BFG nVidia 8800GTS 320MB OC2
      • PSU:
      • Corsair HX520W modular
      • Case:
      • Lian-Li PC7 II Plus
      • Monitor(s):
      • LG 17" Flat Thingy
      • Internet:
      • Crappy BT 1MB Unreliable wank :s
    I'm reluctant to use a PS/2 adapter as i require the speed of USB to use certain functions on the keyboard. It's super brand new and to be honest certainly wasn't expecting any issues!

    In terms of ports used, I am definitely using two of the on board usb ports for the keyboard, no front panels etc so that shouldn't really be the issue.

    I will contact the keyboard manufacturer and see if they have any suggestions,

  9. #9
    www.dougmcdonald.co.uk
    Join Date
    May 2007
    Location
    Bath
    Posts
    523
    Thanks
    5
    Thanked
    20 times in 20 posts
    • DougMcDonald's system
      • Motherboard:
      • Asus P5B Deluxe
      • CPU:
      • Inter Core 2 Duo E6600
      • Memory:
      • 2 x 2GB - Geil Black Dragon PC6400
      • Storage:
      • 2 x 400GB Samsung Spinpoints (Running in Matrix array) 100GB @ RAID0 + 300GB @ RAID1
      • Graphics card(s):
      • BFG nVidia 8800GTS 320MB OC2
      • PSU:
      • Corsair HX520W modular
      • Case:
      • Lian-Li PC7 II Plus
      • Monitor(s):
      • LG 17" Flat Thingy
      • Internet:
      • Crappy BT 1MB Unreliable wank :s
    A bit of an update on this issue. I've managed to resolve it in a rather convaluted manner.

    1. I needed to update keyboard drivers to version 2.10
    2. I needed to update keyboard firmware to version 2.02
    3. Needed to ensure legacy usb keyboard support was enabled.

    Point 2 was dependent on point 1 being completed (needed latest driverset before firmware update was allowed)

    Hopefully this might help someone else in the same situation.

  10. #10
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    What keyboard was it?
    Quote Originally Posted by Blitzen View Post
    stupid betond belief.
    You owe it to yourself to click here really.

  11. #11
    www.dougmcdonald.co.uk
    Join Date
    May 2007
    Location
    Bath
    Posts
    523
    Thanks
    5
    Thanked
    20 times in 20 posts
    • DougMcDonald's system
      • Motherboard:
      • Asus P5B Deluxe
      • CPU:
      • Inter Core 2 Duo E6600
      • Memory:
      • 2 x 2GB - Geil Black Dragon PC6400
      • Storage:
      • 2 x 400GB Samsung Spinpoints (Running in Matrix array) 100GB @ RAID0 + 300GB @ RAID1
      • Graphics card(s):
      • BFG nVidia 8800GTS 320MB OC2
      • PSU:
      • Corsair HX520W modular
      • Case:
      • Lian-Li PC7 II Plus
      • Monitor(s):
      • LG 17" Flat Thingy
      • Internet:
      • Crappy BT 1MB Unreliable wank :s
    Its a razer tarrantula thingy:

    http://www.razerzone.com/index.php?m...products_id=40

    Lovely keyboard, just a pain in the ass to get working in the bios!

  12. #12
    Flat cap, Whippets, Cave. Clunk's Avatar
    Join Date
    Jan 2006
    Posts
    11,056
    Thanks
    360
    Thanked
    725 times in 459 posts
    Ah, well, it might be one to add to the troubleshooting guide, Ill see if anyone else has a problem
    Quote Originally Posted by Blitzen View Post
    stupid betond belief.
    You owe it to yourself to click here really.

  13. #13
    Squirrely tigerboyce's Avatar
    Join Date
    Jan 2007
    Location
    Oxfordshire or Hertfordshire(uni)
    Posts
    2,013
    Thanks
    88
    Thanked
    110 times in 77 posts
    • tigerboyce's system
      • Motherboard:
      • Asus P6T Deluxe/OC Palm
      • CPU:
      • Intel i7 920 D0 @3.8Ghz + Titan Fenrir
      • Memory:
      • 6gb (3x2) OCZ Reapers DDR3
      • Storage:
      • 690gb total WD caviars
      • Graphics card(s):
      • BFG 8800GTS 320mb
      • PSU:
      • Corsair HX 520w
      • Case:
      • Antec 900
      • Operating System:
      • Win7 x64
      • Monitor(s):
      • Dell E228WFP 22"
      • Internet:
      • aol :/
    if its not the same as the legacy USB option, is there a setting that is along the lines of "support USB keyboard: yes/no" probably under integrated prehipherals

  14. #14
    www.dougmcdonald.co.uk
    Join Date
    May 2007
    Location
    Bath
    Posts
    523
    Thanks
    5
    Thanked
    20 times in 20 posts
    • DougMcDonald's system
      • Motherboard:
      • Asus P5B Deluxe
      • CPU:
      • Inter Core 2 Duo E6600
      • Memory:
      • 2 x 2GB - Geil Black Dragon PC6400
      • Storage:
      • 2 x 400GB Samsung Spinpoints (Running in Matrix array) 100GB @ RAID0 + 300GB @ RAID1
      • Graphics card(s):
      • BFG nVidia 8800GTS 320MB OC2
      • PSU:
      • Corsair HX520W modular
      • Case:
      • Lian-Li PC7 II Plus
      • Monitor(s):
      • LG 17" Flat Thingy
      • Internet:
      • Crappy BT 1MB Unreliable wank :s
    I don't think i saw one whilst poking about, but I could well have missed it.

    I'm using asus P5B deluxe with 1101 bios verion (which i think is the latest)

  15. #15
    Registered User
    Join Date
    Jun 2007
    Posts
    1
    Thanks
    0
    Thanked
    0 times in 0 posts
    i am having the same problem .keyboard islogitech g11 ad mobo is asus p5w dh deluxe.all ps2 keyboards work but not any usb = [

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. p5b deluxe/wifi and antec 900 compatability problem???
    By prits_88 in forum PC Hardware and Components
    Replies: 3
    Last Post: 12-06-2007, 12:32 AM
  2. Asus P5W DH Deluxe USB problems :(
    By CrazyMonkey in forum PC Hardware and Components
    Replies: 8
    Last Post: 07-04-2007, 12:53 PM
  3. P5B USB issue
    By DratUK in forum PC Hardware and Components
    Replies: 17
    Last Post: 11-03-2007, 10:08 PM
  4. 15pin (DA-15) gameport to usb on modern pc?
    By retroborg in forum PC Hardware and Components
    Replies: 3
    Last Post: 21-01-2007, 05:10 PM
  5. p5b deluxe sound problems
    By Nudey in forum PC Hardware and Components
    Replies: 0
    Last Post: 25-09-2006, 06:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •