Results 1 to 9 of 9

Thread: Can't Connect Sapphire X1950pro to Board

  1. #1
    Member
    Join Date
    Jul 2007
    Posts
    104
    Thanks
    2
    Thanked
    1 time in 1 post

    Can't Connect Sapphire X1950pro to Board

    Just got a new system, below,

    Triton GZ-XX1CA-SNS
    Gigabyte GA-P35-DS3P
    Sapphire X1950 Pro

    Only problem is the graphics card does not fit into the board. I have removed the metal slot on the card to try and force it in but it doesn't slot in properly.

    Anyone got any ideas?

  2. #2
    Senior Member
    Join Date
    Apr 2006
    Posts
    679
    Thanks
    13
    Thanked
    43 times in 43 posts
    Make sure the plastic latch on the end of the slot is presses down so the graphics card slots in the pull it to lock the card in place you will then have to screw the backplate of the card into the case.

  3. #3
    Mostly Me Lucio's Avatar
    Join Date
    Mar 2007
    Location
    Tring
    Posts
    5,161
    Thanks
    443
    Thanked
    448 times in 351 posts
    • Lucio's system
      • Motherboard:
      • Gigabyte GA-970A-UD3P
      • CPU:
      • AMD FX-6350 with Cooler Master Seldon 240
      • Memory:
      • 2x4GB Corsair DDR3 Vengeance
      • Storage:
      • 128GB Toshiba, 2.5" SSD, 1TB WD Blue WD10EZEX, 500GB Seagate Baracuda 7200.11
      • Graphics card(s):
      • Sapphire R9 270X 4GB
      • PSU:
      • 600W Silverstone Strider SST-ST60F
      • Case:
      • Cooler Master HAF XB
      • Operating System:
      • Windows 8.1 64Bit
      • Monitor(s):
      • Samsung 2032BW, 1680 x 1050
      • Internet:
      • 16Mb Plusnet
    First question is have you definately for a PCI-e version of the Saapphire X1950? I see there's an AGP version on the market

    Secondly, which of the two slots are you trying to push it into? the Blue or the Orange?

  4. #4
    Member
    Join Date
    Jul 2007
    Posts
    104
    Thanks
    2
    Thanked
    1 time in 1 post
    I have had to remove the metal frontplate of the graphics card even for it to almost fit in. Otherwise it is anout 5mm too far in

  5. #5
    Resident abit mourner BUFF's Avatar
    Join Date
    Jul 2003
    Location
    Sunny Glasgow
    Posts
    8,067
    Thanks
    7
    Thanked
    181 times in 171 posts
    pics?

    MSI P55-GD80, i5 750
    abit A-S78H, Phenom 9750,

    My HEXUS.trust abit forums

  6. #6
    Member
    Join Date
    Jul 2007
    Posts
    104
    Thanks
    2
    Thanked
    1 time in 1 post
    Oh my life I am an idiot. I got the AGP one. Shame on me

  7. #7
    Member
    Join Date
    Jul 2007
    Posts
    104
    Thanks
    2
    Thanked
    1 time in 1 post
    Its says on the side of the box tho one PCI-E graphics slot is needed. And a PCI Express based PC is needed

  8. #8
    Mostly Me Lucio's Avatar
    Join Date
    Mar 2007
    Location
    Tring
    Posts
    5,161
    Thanks
    443
    Thanked
    448 times in 351 posts
    • Lucio's system
      • Motherboard:
      • Gigabyte GA-970A-UD3P
      • CPU:
      • AMD FX-6350 with Cooler Master Seldon 240
      • Memory:
      • 2x4GB Corsair DDR3 Vengeance
      • Storage:
      • 128GB Toshiba, 2.5" SSD, 1TB WD Blue WD10EZEX, 500GB Seagate Baracuda 7200.11
      • Graphics card(s):
      • Sapphire R9 270X 4GB
      • PSU:
      • 600W Silverstone Strider SST-ST60F
      • Case:
      • Cooler Master HAF XB
      • Operating System:
      • Windows 8.1 64Bit
      • Monitor(s):
      • Samsung 2032BW, 1680 x 1050
      • Internet:
      • 16Mb Plusnet
    Guessing from your thread on the Scan site, it is the AGP one you ended up with?

    Hope they don't hit you for handling (*should* be fine if within 7 days and packaging is immaculate)

  9. #9
    Member
    Join Date
    Jul 2007
    Posts
    104
    Thanks
    2
    Thanked
    1 time in 1 post
    Yeah it was. Whats the handling charge?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 256MB Sapphire Radeon X1950Pro or 256MB Leadtek 7900GS
    By vicar in forum SCAN.care@HEXUS
    Replies: 4
    Last Post: 13-11-2006, 03:30 PM
  2. Memory speed of Sapphire x1950xtx?
    By The_Iceman in forum Graphics Cards
    Replies: 10
    Last Post: 16-09-2006, 10:10 AM
  3. Replies: 21
    Last Post: 19-06-2006, 07:33 PM
  4. Finder..Connect to Server & Keychain
    By tommylittleboy@ in forum Apple Mac
    Replies: 1
    Last Post: 05-04-2005, 09:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •