Results 1 to 5 of 5

Thread: Mouse...Pis- Annoying me

  1. #1
    Senior Member
    Join Date
    Nov 2006
    Location
    Warminster, Wilts
    Posts
    405
    Thanks
    44
    Thanked
    23 times in 18 posts
    • Nemz0r's system
      • Motherboard:
      • ASRock Z75 Pro3
      • CPU:
      • i7 3570k @ 4.5 GHz (+0.2V) w/ ThermalRight Ultima-90i (modified to fit S1155 with a hammer...)
      • Memory:
      • 16 GiB (4x 4GiB) Samsung PC3-10700 (1333) @ PC3-16000 (2000) 9-14-14-36 1.55v
      • Storage:
      • 1x 500 GB Crucial MX200; 1x 1.5 TB Seagate Barracuda 7200.11; 1x 500 GB Samsung Spinpoint T166
      • Graphics card(s):
      • XFX Radeon R9 290 4GiB
      • PSU:
      • Corsair AX860 80Plus Platinum
      • Case:
      • Antec P180B
      • Operating System:
      • Microsoft Windows 10 Home
      • Monitor(s):
      • 27" Dell P2715Q
      • Internet:
      • ICUK ADSL2+ ~4 Mbps (sadface)

    Mouse pis--... Annoying me

    So I have an old yet reliable mouse. Works fine for the most part - one problem that is occuring lately. When I middle mouse click links (to make new tab with it), 50% of the time or so it creates two new tabs. Is there any solution I can do to fix this? (I already cleaned the innerds of my mouse) Or is my mouse wheel middle click fubared till I buy a new mouse? ^^

    Also: Anyone else have this problem/heard about it?
    Last edited by Nemz0r; 31-08-2007 at 03:59 PM.

  2. #2
    Senior Member Merlin4458's Avatar
    Join Date
    Dec 2004
    Location
    Kingston Uni
    Posts
    2,606
    Thanks
    26
    Thanked
    11 times in 11 posts

    Re: Mouse...Pis- Annoying me

    Try a driver re instal m8, if not not it does sound like a fubar
    Rig: Amd 64 3700+ San Diego | Abit AT8 | 4x512 Corsair XMS3200C2PRO | PowerColour X850XTPE / Arctic Cooled | Samsung Spinpoint 250Gig | Enermax NoiseTake 485w | Arctic Freezer 64 Pro | Coolermaster Wavemaster Silver | Dell 2405FPW | Logitech G5 / Everglide Destrukt Monstermat |

  3. #3
    Who the $%£# told you you could eat my cookies?! Oobie-'s Avatar
    Join Date
    Aug 2005
    Posts
    1,291
    Thanks
    96
    Thanked
    17 times in 16 posts

    Re: Mouse...Pis- Annoying me

    It could be that the button is actually dying, and thus its connection for registering the click seems to be happening twice. I get the same with my left click on my intelli 1.1. I click once and for some reason it will double click and open/load whatever I just clicked!
    Sucks when its in game and you are holding a nade or something.
    ¯\_(ツ)_/¯

  4. #4
    Senior Member charleski's Avatar
    Join Date
    Jul 2006
    Posts
    1,586
    Thanks
    7
    Thanked
    52 times in 45 posts

    Re: Mouse...Pis- Annoying me

    It's a faulty microswitch. The problem generally lies with the small metal bar inside that acts as a spring. If you're really adventurous you can try to open the microswitch and bend the spring, but that's very tricky. Sometimes you can partially correct the fault by clicking the button slowly and repeatedly 10-20 times.

  5. #5
    Member
    Join Date
    Aug 2007
    Location
    Ballymoney...sir
    Posts
    145
    Thanks
    0
    Thanked
    5 times in 5 posts
    • -N!CK-'s system
      • Motherboard:
      • Gigabyte DS4
      • CPU:
      • Intel Core 2 Duo E6600 @3.3GHz
      • Memory:
      • GeIL PC6400 UUL 2gb
      • Storage:
      • 780GB
      • Graphics card(s):
      • EVGA 8800gts 640mb
      • PSU:
      • Corsair HX 520W
      • Case:
      • Lian Li PC-7+ B
      • Monitor(s):
      • DELL 2007WFP

    Re: Mouse...Pis- Annoying me

    just buy a new mouse tbh

    Jesus did not have wheel Ralph...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Apple: New Multi button mouse shocker
    By Gordy in forum Apple Mac
    Replies: 17
    Last Post: 03-08-2005, 11:51 PM
  2. IceMat - Second Edition
    By autopilot in forum Reader Reviews
    Replies: 5
    Last Post: 12-02-2005, 09:44 AM
  3. Logitech MX700 Cordless Mouse
    By Lee H in forum Reader Reviews
    Replies: 0
    Last Post: 04-12-2004, 01:23 PM
  4. annoying optical mouse problem...mesh pc?
    By bellyboy in forum Help! Quick Relief From Tech Headaches
    Replies: 8
    Last Post: 14-10-2004, 10:50 AM
  5. Razor Boomslang 2100.
    By Stewart in forum Reader Reviews
    Replies: 0
    Last Post: 30-08-2004, 06:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •