Results 1 to 15 of 15

Thread: Creative X-fi issues

  1. #1
    Senior Member AD-15's Avatar
    Join Date
    Nov 2005
    Posts
    1,248
    Thanks
    142
    Thanked
    71 times in 34 posts
    • AD-15's system
      • Motherboard:
      • Asus Rampage II Extreme
      • CPU:
      • i7 920 @4.45GHz!!!! (No HT)
      • Memory:
      • 3x2GB G.Skill Trident
      • Storage:
      • 1x 160, 1x 250 (Both 16MB cache SATA2 WD)
      • Graphics card(s):
      • EVGA 460 1GB @ 815, 1013MHz
      • PSU:
      • 850W Corsair HX Series Modular
      • Case:
      • Corsair 700D
      • Operating System:
      • Windows 7 64
      • Monitor(s):
      • 22" Dell E228WFP

    Creative X-fi issues

    hello,

    The problems X-fi users have with Vista are well publicised, so does anybody know if Creative are working on a fix for the famous "crackling" problems in Vista?

    I also heard that there are some X-fi features that fail to work in Vista, could anybody tell me what these are?

    Thanks!
    Industrial espionage is simply the sincerest form of flattery......

  2. #2
    Member
    Join Date
    Aug 2006
    Posts
    105
    Thanks
    3
    Thanked
    1 time in 1 post

    Re: Creative X-fi issues

    Ive never had any crackling, however i seem to get lots of background noise with my from headphone jack which is connected to the onboard audio.

    The creative vista drivers are utter rubbish. however the controversial 3rd party hacked ones ones are great, just like xp's

  3. #3
    HEXUS.social member Agent's Avatar
    Join Date
    Jul 2003
    Location
    Internet
    Posts
    19,159
    Thanks
    733
    Thanked
    1,605 times in 1,044 posts

    Re: Creative X-fi issues

    Get the Daniel_K drivers - they solve a bunch of issues. Crackling is one of the items on the list of fixes, so it may help. It will depend on your system setup though.

    http://www.information-database.com/eve/

    Ignore everything about eve on there and follow the link to get the modded drivers
    Quote Originally Posted by Saracen View Post
    And by trying to force me to like small pants, they've alienated me.

  4. #4
    Senior Member AD-15's Avatar
    Join Date
    Nov 2005
    Posts
    1,248
    Thanks
    142
    Thanked
    71 times in 34 posts
    • AD-15's system
      • Motherboard:
      • Asus Rampage II Extreme
      • CPU:
      • i7 920 @4.45GHz!!!! (No HT)
      • Memory:
      • 3x2GB G.Skill Trident
      • Storage:
      • 1x 160, 1x 250 (Both 16MB cache SATA2 WD)
      • Graphics card(s):
      • EVGA 460 1GB @ 815, 1013MHz
      • PSU:
      • 850W Corsair HX Series Modular
      • Case:
      • Corsair 700D
      • Operating System:
      • Windows 7 64
      • Monitor(s):
      • 22" Dell E228WFP

    Re: Creative X-fi issues

    Hello,

    I might just wait to see what the new Creative drivers do first.

    So, which exact features are not available in Vista? I don't seem to notice anything missing?

    I'm going away soon and so won't be able to use this system for about 6 weeks, if the creative drivers are out and working when I come back, I'll just use those. If not, I'll use this genius' hacked drivers.
    Industrial espionage is simply the sincerest form of flattery......

  5. #5
    Senior Member
    Join Date
    Jul 2006
    Posts
    1,457
    Thanks
    33
    Thanked
    75 times in 71 posts

    Re: Creative X-fi issues

    I would dload the drivers now while they are there, they may not be when you come back.

  6. #6
    Gundam Infinite's Avatar
    Join Date
    Jun 2008
    Location
    Southport
    Posts
    1,647
    Thanks
    150
    Thanked
    122 times in 93 posts
    • Infinite's system
      • Motherboard:
      • MSI GD80
      • CPU:
      • Intel i5 750
      • Memory:
      • Kingston 16GB
      • Storage:
      • 120GB OCZ Agility 3
      • Graphics card(s):
      • GTX 460 SLI
      • PSU:
      • Corsair HX 650W
      • Case:
      • Silverstone TJ09B-W
      • Operating System:
      • Windows 7 Pro - 64-bit
      • Monitor(s):
      • Dell S2309W
      • Internet:
      • Infinity

    Re: Creative X-fi issues

    bleh, it always seem that i am the only person ever to not ever have any issues with the xfi drivers, lol....

  7. #7
    Gentoo Ricer
    Join Date
    Jan 2005
    Location
    Galway
    Posts
    11,046
    Thanks
    1,016
    Thanked
    944 times in 704 posts
    • aidanjt's system
      • Motherboard:
      • Asus Strix Z370-G
      • CPU:
      • Intel i7-8700K
      • Memory:
      • 2x8GB Corsiar LPX 3000C15
      • Storage:
      • 500GB Samsung 960 EVO
      • Graphics card(s):
      • EVGA GTX 970 SC ACX 2.0
      • PSU:
      • EVGA G3 750W
      • Case:
      • Fractal Design Define C Mini
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • 240mbps Virgin Cable

    Re: Creative X-fi issues

    I had problems just trying to get the motherboard to recognise it, much less for Windows to recognise it. This soundcard has sucked since day one, I offloaded it onto a friend due to abizmal lack of Linux support, they've finally released card specs to the ALSA team but I had enough of CL crap, I'll stick with onboard or get a descrete card from someone else if I really need to.
    Quote Originally Posted by Agent View Post
    ...every time Creative bring out a new card range their advertising makes it sound like they have discovered a way to insert a thousand Chuck Norris super dwarfs in your ears...

  8. #8
    Senior Member AD-15's Avatar
    Join Date
    Nov 2005
    Posts
    1,248
    Thanks
    142
    Thanked
    71 times in 34 posts
    • AD-15's system
      • Motherboard:
      • Asus Rampage II Extreme
      • CPU:
      • i7 920 @4.45GHz!!!! (No HT)
      • Memory:
      • 3x2GB G.Skill Trident
      • Storage:
      • 1x 160, 1x 250 (Both 16MB cache SATA2 WD)
      • Graphics card(s):
      • EVGA 460 1GB @ 815, 1013MHz
      • PSU:
      • 850W Corsair HX Series Modular
      • Case:
      • Corsair 700D
      • Operating System:
      • Windows 7 64
      • Monitor(s):
      • 22" Dell E228WFP

    Re: Creative X-fi issues

    hello,

    I'll download the drivers now and keep them just in case.

    Could anyone tell me which features are disabled under Vista?
    Industrial espionage is simply the sincerest form of flattery......

  9. #9
    Anthropomorphic Personification shaithis's Avatar
    Join Date
    Apr 2004
    Location
    The Last Aerie
    Posts
    10,857
    Thanks
    645
    Thanked
    872 times in 736 posts
    • shaithis's system
      • Motherboard:
      • Asus P8Z77 WS
      • CPU:
      • i7 3770k @ 4.5GHz
      • Memory:
      • 32GB HyperX 1866
      • Storage:
      • Lots!
      • Graphics card(s):
      • Sapphire Fury X
      • PSU:
      • Corsair HX850
      • Case:
      • Corsair 600T (White)
      • Operating System:
      • Windows 10 x64
      • Monitor(s):
      • 2 x Dell 3007
      • Internet:
      • Zen 80Mb Fibre

    Re: Creative X-fi issues

    Never had the cracking (which is odd as I always had 4-8GB RAM in the machine with the X-Fi in)

    The problems I had was if I touched anything in the "Playback" or "Recording" properties, I would run the risk of sound never working again until I rebooted.

    The recording options were the most temperamental for me.

    I also tried the daniel_k drivers as I wanted Dolby Digital Live but just kept getting BSODs with them and finally removed them not long before buying an Asus Xonar.

    Wish I had bought the Xonar earlier, its been a breath of fresh air
    Main PC: Asus Rampage IV Extreme / 3960X@4.5GHz / Antec H1200 Pro / 32GB DDR3-1866 Quad Channel / Sapphire Fury X / Areca 1680 / 850W EVGA SuperNOVA Gold 2 / Corsair 600T / 2x Dell 3007 / 4 x 250GB SSD + 2 x 80GB SSD / 4 x 1TB HDD (RAID 10) / Windows 10 Pro, Yosemite & Ubuntu
    HTPC: AsRock Z77 Pro 4 / 3770K@4.2GHz / 24GB / GTX 1080 / SST-LC20 / Antec TP-550 / Hisense 65k5510 4K TV / HTC Vive / 2 x 240GB SSD + 12TB HDD Space / Race Seat / Logitech G29 / Win 10 Pro
    HTPC2: Asus AM1I-A / 5150 / 4GB / Corsair Force 3 240GB / Silverstone SST-ML05B + ST30SF / Samsung UE60H6200 TV / Windows 10 Pro
    Spare/Loaner: Gigabyte EX58-UD5 / i950 / 12GB / HD7870 / Corsair 300R / Silverpower 700W modular
    NAS 1: HP N40L / 12GB ECC RAM / 2 x 3TB Arrays || NAS 2: Dell PowerEdge T110 II / 24GB ECC RAM / 2 x 3TB Hybrid arrays || Network:Buffalo WZR-1166DHP w/DD-WRT + HP ProCurve 1800-24G
    Laptop: Dell Precision 5510 Printer: HP CP1515n || Phone: Huawei P30 || Other: Samsung Galaxy Tab 4 Pro 10.1 CM14 / Playstation 4 + G29 + 2TB Hybrid drive

  10. #10
    Senior Member AD-15's Avatar
    Join Date
    Nov 2005
    Posts
    1,248
    Thanks
    142
    Thanked
    71 times in 34 posts
    • AD-15's system
      • Motherboard:
      • Asus Rampage II Extreme
      • CPU:
      • i7 920 @4.45GHz!!!! (No HT)
      • Memory:
      • 3x2GB G.Skill Trident
      • Storage:
      • 1x 160, 1x 250 (Both 16MB cache SATA2 WD)
      • Graphics card(s):
      • EVGA 460 1GB @ 815, 1013MHz
      • PSU:
      • 850W Corsair HX Series Modular
      • Case:
      • Corsair 700D
      • Operating System:
      • Windows 7 64
      • Monitor(s):
      • 22" Dell E228WFP

    Re: Creative X-fi issues

    hello,

    Thanks for your advice! So it's only Dolby that has been disabled under Vista?
    Industrial espionage is simply the sincerest form of flattery......

  11. #11
    It's good to be bad pauldarkside's Avatar
    Join Date
    Oct 2006
    Location
    Cornwall
    Posts
    2,930
    Thanks
    295
    Thanked
    378 times in 259 posts
    • pauldarkside's system
      • Motherboard:
      • ASUS Maximus VI Hero
      • CPU:
      • Intel Core i7-4770K & Corsair Hydro H80i
      • Memory:
      • Corsair Vengeance 32GB (4x8GB) 1600MHz DDR3
      • Storage:
      • Corsair Force GS 128GB, Crucial M500 480GB, WD Black 4TB
      • Graphics card(s):
      • EVGA GeForce GTX 780 Ti Superclocked
      • PSU:
      • Corsair Professional HX850W
      • Case:
      • Corsair Graphite 780T (White)
      • Operating System:
      • Windows 8.1 Pro 64bit
      • Monitor(s):
      • Asus ROG Swift PG278Q
      • Internet:
      • BT Infinity @ 78Mbps

    Re: Creative X-fi issues

    The newer beta drivers have Dolby re-enabled:

    http://downloads.guru3d.com/Creative...load-1944.html
    My only concern is should I hide my true identity? A costume maybe?

    0iD: Plus weeing in it every now & again does it good
    scaryjim: 10" is just a little large to hold comfortably in one hand, which makes it a lot harder to tap, swipe and generally interact with.

  12. #12
    Anthropomorphic Personification shaithis's Avatar
    Join Date
    Apr 2004
    Location
    The Last Aerie
    Posts
    10,857
    Thanks
    645
    Thanked
    872 times in 736 posts
    • shaithis's system
      • Motherboard:
      • Asus P8Z77 WS
      • CPU:
      • i7 3770k @ 4.5GHz
      • Memory:
      • 32GB HyperX 1866
      • Storage:
      • Lots!
      • Graphics card(s):
      • Sapphire Fury X
      • PSU:
      • Corsair HX850
      • Case:
      • Corsair 600T (White)
      • Operating System:
      • Windows 10 x64
      • Monitor(s):
      • 2 x Dell 3007
      • Internet:
      • Zen 80Mb Fibre

    Re: Creative X-fi issues

    DDL was never implemented on the older X-Fi cards as far as I know, even though there was no reason not to enable it. I think its only been enabled on the newer PCI-E cards (marketing ploy to get people to upgrade)

    What has been expressly disabled in Vista, I have no idea.

    EDIT: I guess they felt the pressure to add it then (thanks pauldarkside)
    Main PC: Asus Rampage IV Extreme / 3960X@4.5GHz / Antec H1200 Pro / 32GB DDR3-1866 Quad Channel / Sapphire Fury X / Areca 1680 / 850W EVGA SuperNOVA Gold 2 / Corsair 600T / 2x Dell 3007 / 4 x 250GB SSD + 2 x 80GB SSD / 4 x 1TB HDD (RAID 10) / Windows 10 Pro, Yosemite & Ubuntu
    HTPC: AsRock Z77 Pro 4 / 3770K@4.2GHz / 24GB / GTX 1080 / SST-LC20 / Antec TP-550 / Hisense 65k5510 4K TV / HTC Vive / 2 x 240GB SSD + 12TB HDD Space / Race Seat / Logitech G29 / Win 10 Pro
    HTPC2: Asus AM1I-A / 5150 / 4GB / Corsair Force 3 240GB / Silverstone SST-ML05B + ST30SF / Samsung UE60H6200 TV / Windows 10 Pro
    Spare/Loaner: Gigabyte EX58-UD5 / i950 / 12GB / HD7870 / Corsair 300R / Silverpower 700W modular
    NAS 1: HP N40L / 12GB ECC RAM / 2 x 3TB Arrays || NAS 2: Dell PowerEdge T110 II / 24GB ECC RAM / 2 x 3TB Hybrid arrays || Network:Buffalo WZR-1166DHP w/DD-WRT + HP ProCurve 1800-24G
    Laptop: Dell Precision 5510 Printer: HP CP1515n || Phone: Huawei P30 || Other: Samsung Galaxy Tab 4 Pro 10.1 CM14 / Playstation 4 + G29 + 2TB Hybrid drive

  13. #13
    HEXUS.social member Agent's Avatar
    Join Date
    Jul 2003
    Location
    Internet
    Posts
    19,159
    Thanks
    733
    Thanked
    1,605 times in 1,044 posts

    Re: Creative X-fi issues

    Quote Originally Posted by shaithis View Post
    DDL was never implemented on the older X-Fi cards as far as I know, even though there was no reason not to enable it. I think its only been enabled on the newer PCI-E cards (marketing ploy to get people to upgrade)

    What has been expressly disabled in Vista, I have no idea.

    EDIT: I guess they felt the pressure to add it then (thanks pauldarkside)
    Its not DDL / Doby Digital Live. The beta patch add's back the ability for the card to decode Dolby Digital streams, nothing more. Ya know, the ones Creative stole off their customers when they made their Vista drivers (and purposefully locked them down).

    A sad state of affairs

    Dolby® Digital and DTS® driver decode re-established for sound cards that included decoding in their Windows XP drivers (Not applicable for products that included a 3rd party software DVD player license in the package).
    Quote Originally Posted by Saracen View Post
    And by trying to force me to like small pants, they've alienated me.

  14. #14
    Senior Member Ciber's Avatar
    Join Date
    Feb 2007
    Location
    Southampton
    Posts
    1,526
    Thanks
    165
    Thanked
    71 times in 56 posts
    • Ciber's system
      • Motherboard:
      • Asus P6T
      • CPU:
      • Core i7 920 @3.2
      • Memory:
      • 12gb Corsair DDR3
      • Storage:
      • Crucial C300 256 + Crucial C300 128gb + Samsung F3 1tb
      • Graphics card(s):
      • GTX960
      • PSU:
      • Seasonic X900
      • Case:
      • Thermaltake Tsunami Dream
      • Operating System:
      • W7 64
      • Monitor(s):
      • Samsung 275T 27" LCD
      • Internet:
      • Plusnet Fibre

    Re: Creative X-fi issues

    Hmmm. I have an xfi I got for free and you're putting me off it lol. Should I ebay it now? Although I'm running XP 32 and it seems to be working fine, I know that creative driver support has always sucked. So theyre not supporting these PCI cards properly anymore even though they still sell them (I have one)?

  15. #15
    Senior Member 2Cold Scorpio's Avatar
    Join Date
    Aug 2007
    Location
    Greenvile, NC, U.S.A.
    Posts
    802
    Thanks
    15
    Thanked
    13 times in 12 posts
    • 2Cold Scorpio's system
      • Motherboard:
      • Abit IP-35 Pro, Sound Card: Creative X-Fi XtremeGamer
      • CPU:
      • Intel Core 2 Duo E6750 w/ G0 stepping - stock: 2.66 GHz OC'd to 3.6 GHz 1.48v
      • Memory:
      • 4x1GB Patriot PDC24G6400LLQK Extreme Performance PC2-6400 OC'd to 900MHz 5-5-5-18 timings 2.2v
      • Storage:
      • 2TB Samsung Spinpoint F4 5200rpm (main), 2x 250 GB Seagate Barracuda 7200.10 SATA in RAID 0 (backup)
      • Graphics card(s):
      • eVGA Geforce GTX 460 1GB Superclocked
      • PSU:
      • Antec NeoBlue 650w
      • Case:
      • Raidmax Smilodon Steel ATX
      • Operating System:
      • Microsoft Windows 7 Professional 64-bit
      • Monitor(s):
      • Samsung 226BW 22" LCD Widescreen (S-Panel) @ 1680x1050
      • Internet:
      • 15Mb/s Cable, Optical Drives: 1. Lite-On DVD+-R/+-RW/RAM w/ Lightscribe, 2. LiteOn CD-RW 52/32/52x

    Re: Creative X-fi issues

    I have a question: it says you can use the .iso installer to use this in XP as well, so I must ask, what are the benefits? I currently have no problems with my X-Fi in XP using Creative's software and drivers, but I'm always happy to make stuff even better.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Creative X-Fi Issues
    By camalbitboy in forum PC Hardware and Components
    Replies: 0
    Last Post: 03-04-2008, 10:02 AM
  2. Replies: 6
    Last Post: 30-03-2008, 09:37 AM
  3. Replies: 14
    Last Post: 05-07-2006, 02:53 PM
  4. Creative Audigy, mp3, speakers etc
    By Flibb in forum Retail Therapy and Bargains
    Replies: 13
    Last Post: 25-07-2005, 12:32 PM
  5. Creative Zen Micro Review
    By Nick F in forum Reader Reviews
    Replies: 19
    Last Post: 21-07-2005, 08:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •