Results 1 to 10 of 10

Thread: SupremeFX X-Fi sound driver problem

  1. #1
    Insomnia Robscure's Avatar
    Join Date
    Oct 2008
    Location
    London
    Posts
    703
    Thanks
    108
    Thanked
    32 times in 24 posts

    SupremeFX X-Fi sound driver problem

    EDIT: problem solved... had my sound card in PCI-e slot 2... it needed to be in 1 for some reason...

    I've got my SupremeFX X-Fi sound card hooked up, which came with my Maximus II Formula mobo... and the problem is that I have got no sound... no drivers are installed... and I can't find the drivers...

    my mobo came with a driver cd... but it didn't install any audio drivers...

    on the back is a code for 3d mark... and another for X-Fi....

    I've been on Asus website and I've searched google... still no luck...
    Last edited by Robscure; 15-02-2009 at 07:01 PM.

  2. #2
    Gentoo Ricer
    Join Date
    Jan 2005
    Location
    Galway
    Posts
    10,955
    Thanks
    986
    Thanked
    940 times in 700 posts
    • aidanjt's system
      • Motherboard:
      • Asus Strix Z370-G
      • CPU:
      • Intel i7-8700K
      • Memory:
      • 2x8GB Corsiar LPX 3000C15
      • Storage:
      • 500GB Samsung 960 EVO
      • Graphics card(s):
      • EVGA GTX 970 SC ACX 2.0
      • PSU:
      • EVGA G3 750W
      • Case:
      • Fractal Design Define C Mini
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • 240mbps Virgin Cable

    Re: SupremeFX X-Fi sound driver problem

    Drivers here: http://dlcdnet.asus.com/pub/ASUS/mis...6480_Vista.zip

    I'm assuming you have Vista x64 here.
    Quote Originally Posted by Agent View Post
    ...every time Creative bring out a new card range their advertising makes it sound like they have discovered a way to insert a thousand Chuck Norris super dwarfs in your ears...

  3. Received thanks from:

    Robscure (15-02-2009)

  4. #3
    Insomnia Robscure's Avatar
    Join Date
    Oct 2008
    Location
    London
    Posts
    703
    Thanks
    108
    Thanked
    32 times in 24 posts

    Re: SupremeFX X-Fi sound driver problem

    Quote Originally Posted by aidanjt View Post
    Drivers here: http://dlcdnet.asus.com/pub/ASUS/mis...6480_Vista.zip

    I'm assuming you have Vista x64 here.
    Thanks, hope this gives me sound!

    Another problem is that my Aego M speakers didn't come with instructions! lol

  5. #4
    Insomnia Robscure's Avatar
    Join Date
    Oct 2008
    Location
    London
    Posts
    703
    Thanks
    108
    Thanked
    32 times in 24 posts

    Re: SupremeFX X-Fi sound driver problem

    Quote Originally Posted by aidanjt View Post
    Drivers here: http://dlcdnet.asus.com/pub/ASUS/mis...6480_Vista.zip

    I'm assuming you have Vista x64 here.
    It said my hardware doesnt support those drivers... I think those are for a different card....

    I have the "SupremeFX X-Fi"
    Last edited by Robscure; 15-02-2009 at 06:32 PM.

  6. #5
    Gentoo Ricer
    Join Date
    Jan 2005
    Location
    Galway
    Posts
    10,955
    Thanks
    986
    Thanked
    940 times in 700 posts
    • aidanjt's system
      • Motherboard:
      • Asus Strix Z370-G
      • CPU:
      • Intel i7-8700K
      • Memory:
      • 2x8GB Corsiar LPX 3000C15
      • Storage:
      • 500GB Samsung 960 EVO
      • Graphics card(s):
      • EVGA GTX 970 SC ACX 2.0
      • PSU:
      • EVGA G3 750W
      • Case:
      • Fractal Design Define C Mini
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • 240mbps Virgin Cable

    Re: SupremeFX X-Fi sound driver problem

    Really?.. Because I went to Asus's website for the soundcard for that motherboard model. It should work assuming I got the right OS version.
    Quote Originally Posted by Agent View Post
    ...every time Creative bring out a new card range their advertising makes it sound like they have discovered a way to insert a thousand Chuck Norris super dwarfs in your ears...

  7. #6
    Insomnia Robscure's Avatar
    Join Date
    Oct 2008
    Location
    London
    Posts
    703
    Thanks
    108
    Thanked
    32 times in 24 posts

    Re: SupremeFX X-Fi sound driver problem

    Quote Originally Posted by aidanjt View Post
    Really?.. Because I went to Asus's website for the soundcard for that motherboard model. It should work assuming I got the right OS version.
    I don't know why it isn't working... on my taskbar i got this error saying "No Audio Output Device is installed."

    Why is it saying that?

    My sound card is glowing blue inside my case... It's definitely connected... I don't know why it isnt installed

  8. #7
    Insomnia Robscure's Avatar
    Join Date
    Oct 2008
    Location
    London
    Posts
    703
    Thanks
    108
    Thanked
    32 times in 24 posts

    Re: SupremeFX X-Fi sound driver problem

    okay I got it! I had it in PCI-e slot 2... it needed to be in PCI-e slot 1 apparently....

  9. #8
    Insomnia Robscure's Avatar
    Join Date
    Oct 2008
    Location
    London
    Posts
    703
    Thanks
    108
    Thanked
    32 times in 24 posts

    Re: SupremeFX X-Fi sound driver problem

    But wait... now I need to figure out why no sound is coming out of my speakers... lol

    And when I check the audio device, they're called "SoundMAX Integrated speakers" ... but its not... its a SupremeFX X-Fi..... why isn't the SupremeFX X-Fi card being properly recognized???

  10. #9
    Gentoo Ricer
    Join Date
    Jan 2005
    Location
    Galway
    Posts
    10,955
    Thanks
    986
    Thanked
    940 times in 700 posts
    • aidanjt's system
      • Motherboard:
      • Asus Strix Z370-G
      • CPU:
      • Intel i7-8700K
      • Memory:
      • 2x8GB Corsiar LPX 3000C15
      • Storage:
      • 500GB Samsung 960 EVO
      • Graphics card(s):
      • EVGA GTX 970 SC ACX 2.0
      • PSU:
      • EVGA G3 750W
      • Case:
      • Fractal Design Define C Mini
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • 240mbps Virgin Cable

    Re: SupremeFX X-Fi sound driver problem

    It's just generic ADI branding. It's still the SupremeFX audio card. Nothing to be concerned with. Just get your speakers working and you're done.
    Quote Originally Posted by Agent View Post
    ...every time Creative bring out a new card range their advertising makes it sound like they have discovered a way to insert a thousand Chuck Norris super dwarfs in your ears...

  11. #10
    Insomnia Robscure's Avatar
    Join Date
    Oct 2008
    Location
    London
    Posts
    703
    Thanks
    108
    Thanked
    32 times in 24 posts

    Re: SupremeFX X-Fi sound driver problem

    Quote Originally Posted by aidanjt View Post
    It's just generic ADI branding. It's still the SupremeFX audio card. Nothing to be concerned with. Just get your speakers working and you're done.
    Speakers still aren't working!

    I've tried all three cables that they came with... and plugged them into every slot on my sound card... and did so while playing music (which I cannot hear)... waiting and hoping to finally hear the music come through the speakers... the volume is turned up... if they were connected properly then I would certainly hear something...

    so what the hell????

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem w virtual sound card driver for AirPace Music
    By Fredrik in forum abit.care@HEXUS
    Replies: 8
    Last Post: 26-10-2009, 01:55 AM
  2. Mainboard driver problem
    By Deep34 in forum Help! Quick Relief From Tech Headaches
    Replies: 2
    Last Post: 29-11-2008, 01:05 PM
  3. media centre TV no sound problem
    By hegaroo in forum Help! Quick Relief From Tech Headaches
    Replies: 0
    Last Post: 26-08-2008, 10:06 PM
  4. Problem with Asus P5N32-E SLI build-in Sound in Games
    By Belgarath in forum PC Hardware and Components
    Replies: 4
    Last Post: 07-02-2007, 05:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •