Results 1 to 6 of 6

Thread: Help! Spilled Akasa TIM-Clean on mobo!

  1. #1
    Member
    Join Date
    Nov 2007
    Posts
    190
    Thanks
    18
    Thanked
    2 times in 2 posts
    • th0r0n's system
      • Motherboard:
      • Asus P5K-E
      • CPU:
      • Intel Core 2 Duo E6750
      • Memory:
      • GeIL PC6400 800Mhz DDR2
      • Storage:
      • Samsung Spinpoint 500GB
      • Graphics card(s):
      • nVidia 8800GT 512MB
      • PSU:
      • Corsair HX620W
      • Case:
      • Antec P182
      • Monitor(s):
      • Samsung 2032BW
      • Internet:
      • 24MB Cable

    Help! Spilled Akasa TIM-Clean on mobo!

    what i div I am, in true 3 stooges fashion I spilled a few drops of this product on my motherboard. Should I be worried? I take it it's non conductive?
    Computer geek, Honda VFR800 Rider

  2. #2
    Senior Member
    Join Date
    Aug 2003
    Posts
    6,582
    Thanks
    0
    Thanked
    246 times in 208 posts

    Re: Help! Spilled Akasa TIM-Clean on mobo!

    If it's anything like the Arcti-clean, a few drop should evaporate pretty quickly. Nothing to worry about.

  3. #3
    I R Toff Pandi! TAKTAK's Avatar
    Join Date
    Mar 2008
    Location
    Vergon6
    Posts
    7,410
    Thanks
    525
    Thanked
    995 times in 735 posts
    • TAKTAK's system
      • Motherboard:
      • MSI P55 GD65
      • CPU:
      • i7 860 @ 3.62GHz under an XSPC RASA
      • Memory:
      • 8GB 2133MHZ Corsair Vengeance
      • Storage:
      • 80GB Intel G2 SSD + 500GB + 640GB + 250GB WD AAKs + 2x1TB Samsung (1 Dead) + 500GB Maxtor
      • Graphics card(s):
      • EVGA SSC GTX260 216 55nm under an EK FC260 GTX
      • PSU:
      • Corsair HX620w
      • Case:
      • Corsair 800D, PA120.3 in the roof with 6 NF-P12s in Push-Pull
      • Operating System:
      • 7 x64
      • Monitor(s):
      • 24" Yuraku YV24WBH1 - SA-LTM240M2-L01 Panel & 32" LCD HDTV (1080i) Digihome tesco special :D
      • Internet:
      • 76Mb Fibre

    Re: Help! Spilled Akasa TIM-Clean on mobo!

    Just wipe it off and carry on
    Post Counts and Other Rewards, Rules, Folding@Home, Fans: Push vs Pull vs Push-Pull, Corsair PSU OEMs.

    Quote Originally Posted by razer121 View Post
    Would you like me to enter you? it would be my pleasure
    TAKTAK.co.uk

  4. #4
    Banhammer in peace PeterB kalniel's Avatar
    Join Date
    Aug 2005
    Posts
    29,377
    Thanks
    1,559
    Thanked
    2,969 times in 2,409 posts
    • kalniel's system
      • Motherboard:
      • Gigabyte X58A UD3R rev 2
      • CPU:
      • Intel Xeon X5680
      • Memory:
      • 12gb DDR3 2000
      • Graphics card(s):
      • nVidia GTX 1060 6GB
      • PSU:
      • Seasonic 600W
      • Case:
      • Cooler Master HAF 912
      • Operating System:
      • Win 10 Pro x64
      • Monitor(s):
      • Dell U2311H
      • Internet:
      • O2 8mbps

    Re: Help! Spilled Akasa TIM-Clean on mobo!


  5. #5
    VTECmeous Vimeous's Avatar
    Join Date
    Aug 2003
    Posts
    2,006
    Thanks
    62
    Thanked
    52 times in 51 posts

    Re: Help! Spilled Akasa TIM-Clean on mobo!

    Good idea!. Mine could do with a clean .......

    You'll be fine mate
    Vimeous : i7 7700K | 16Gb | ASUS Strix Z270G | GTX1080 | 960 EVO 500GB NVMe | 850 EVO 500GB | TX650W | NZXT S340 Elite | Dell U2713H + 17" | 10 Pro
    Willowin : i7 3570K | 16Gb | ASUS P8Z77-I Deluxe | GTX 660 TI | 2x 1TB 840EVO | Sugo SG05BB-450 | Dell U2713H + 17" | 8.1 Pro
    Svr : X2 4200+ | 2Gb | ASUS A8N-SLI Premium | HD6870 | SonicFury | 8x 250Gb (2x RAID10) | 3Ware 9650SE-8LPML | Seasonic 700W | CM Stacker 830 | XP Pro
    NAS : DS1511+ | DX513
    W : Dell Precision T3610 | E5-1650 V2 | 16GB | Quadro K2000 | 256GB SSD | 1TB HDD | 8.1 Pro | 2x Dell U2515H


  6. #6
    Member
    Join Date
    Nov 2007
    Posts
    190
    Thanks
    18
    Thanked
    2 times in 2 posts
    • th0r0n's system
      • Motherboard:
      • Asus P5K-E
      • CPU:
      • Intel Core 2 Duo E6750
      • Memory:
      • GeIL PC6400 800Mhz DDR2
      • Storage:
      • Samsung Spinpoint 500GB
      • Graphics card(s):
      • nVidia 8800GT 512MB
      • PSU:
      • Corsair HX620W
      • Case:
      • Antec P182
      • Monitor(s):
      • Samsung 2032BW
      • Internet:
      • 24MB Cable

    Re: Help! Spilled Akasa TIM-Clean on mobo!

    Yeah, works fine Thanks!

    Tim-Clean is amazing!
    Computer geek, Honda VFR800 Rider

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Fatality AN9 32x, No Bios, 9.0. Error Code
    By optical10 in forum abit.care@HEXUS
    Replies: 18
    Last Post: 22-04-2008, 02:04 PM
  2. New ABIT AB9 PRO MoBo looks dead.
    By abhide in forum abit.care@HEXUS
    Replies: 15
    Last Post: 26-01-2007, 05:20 PM
  3. Excel Formula Help
    By Lead_Head in forum Software
    Replies: 7
    Last Post: 02-10-2006, 10:09 AM
  4. CPU TIM Guide
    By Steve in forum Help! Quick Relief From Tech Headaches
    Replies: 0
    Last Post: 30-05-2004, 02:59 PM
  5. Replace TIM on integrated mobo?
    By Steve in forum PC Hardware and Components
    Replies: 1
    Last Post: 12-02-2004, 01:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •