Results 1 to 3 of 3

Thread: Creative update no longer detects soundcard?

  1. #1
    Member
    Join Date
    Feb 2009
    Location
    Cardiff
    Posts
    152
    Thanks
    35
    Thanked
    9 times in 6 posts
    • Jonessie's system
      • Motherboard:
      • Asus Rampage II Extreme, Intel X58
      • CPU:
      • Intel i7 920, D0 SLBEJ S1366, Bloomfield, 2.66 GHz
      • Memory:
      • 2x6GB (3x2GB) Corsair Dominator GT, DDR3 PC3-14900 (1866)
      • Storage:
      • 2TB SATA SEAGATE
      • Graphics card(s):
      • 2x1GB Sapphire HD 5870, PCI-E 2.0, 4800MHz GDDR5, GPU 850MHz, Crossfire
      • PSU:
      • ENERMAX REVOLUTION 850W
      • Case:
      • ThermalTake SPEDO Advanced Package
      • Operating System:
      • Windows 7 Ultimate 64-bit
      • Monitor(s):
      • Dell SP2309W (HDMI) 2048x1152
      • Internet:
      • VM 50MB Broadband :)

    Unhappy Creative update no longer detects soundcard?

    Okay this is a bit of an odd one, that has even me stuck and I have been using Creative soubdcards for over 10 years and have never come across this ever. I ordered a Creative Soubdblaster X-Fi Titainium Fatail1ty Pro from Scan and I must admit it looks as though I bagged the one which looks like it was soldered by a graduate. No offence, I was one once as well. I recently upgraded to Windows 7 full install, and because I now have a Biometric Scanner I decide to ditch the previous installation and run from fresh install. Yeah, I know there was no need to really but it does not matter. Well before I reinstalled again I tried the update and it was working but now if I run Creative update it sates it did not detect any Creative products on my system? So I though troubleshoot, run a diagnostical test and everything is working fine, sound, all the software works, Device Manager has it logged as Creative X-Fi everything is working as it should be... But Creative update says I do not have and Creative hardware on my system. Can somebody perhaps explain this for me because, I am lost! If there was something wrong with the PCIE then I would have total failure, but it is all working?
    Last edited by Jonessie; 31-10-2009 at 12:02 AM. Reason: Doh!
    JONESSIE
    Never use an iPod Touch to type because you need fingers like chopsticks.

  2. #2
    jim
    jim is offline
    HEXUS.clueless jim's Avatar
    Join Date
    Sep 2008
    Location
    Location: Location:
    Posts
    11,364
    Thanks
    606
    Thanked
    1,595 times in 1,269 posts
    • jim's system
      • Motherboard:
      • Asus Maximus IV Gene-Z
      • CPU:
      • i5 2500K @ 4.5GHz
      • Memory:
      • 8GB Corsair Vengeance LP
      • Storage:
      • 1TB Sandisk SSD
      • Graphics card(s):
      • ASUS GTX 970
      • PSU:
      • Corsair AX650
      • Case:
      • Silverstone Fortress FT03
      • Operating System:
      • 8.1 Pro
      • Monitor(s):
      • Dell S2716DG
      • Internet:
      • 10 Mbps ADSL

    Re: Creative update no longer detects soundcard?

    Yeah mine (X-Fi XtremeMusic) does that, I've just ignored it tbh as I'm perfectly happy doing manual updates.

    It worked perfectly on Vista, but nothing on 7. Might be an OS related issue.

  3. Received thanks from:

    Jonessie (31-10-2009)

  4. #3
    Member
    Join Date
    Feb 2009
    Location
    Cardiff
    Posts
    152
    Thanks
    35
    Thanked
    9 times in 6 posts
    • Jonessie's system
      • Motherboard:
      • Asus Rampage II Extreme, Intel X58
      • CPU:
      • Intel i7 920, D0 SLBEJ S1366, Bloomfield, 2.66 GHz
      • Memory:
      • 2x6GB (3x2GB) Corsair Dominator GT, DDR3 PC3-14900 (1866)
      • Storage:
      • 2TB SATA SEAGATE
      • Graphics card(s):
      • 2x1GB Sapphire HD 5870, PCI-E 2.0, 4800MHz GDDR5, GPU 850MHz, Crossfire
      • PSU:
      • ENERMAX REVOLUTION 850W
      • Case:
      • ThermalTake SPEDO Advanced Package
      • Operating System:
      • Windows 7 Ultimate 64-bit
      • Monitor(s):
      • Dell SP2309W (HDMI) 2048x1152
      • Internet:
      • VM 50MB Broadband :)

    Re: Creative update no longer detects soundcard?

    [Resolved]

    I think Creative must have been updating the update server because it's all working now. They must have updated because you know the update for Creative software via their website has never worked for 64-bit Vista or Windows 7 but now it does, you can scan for Creative software installed on your system, the same as doing this via your OS. This has never worked on Vista or Windows 7 so they must have been updating their servers because it works now. Try updating software via your OS now and see if this works because mine is now.
    Last edited by Jonessie; 02-11-2009 at 06:41 PM.
    JONESSIE
    Never use an iPod Touch to type because you need fingers like chopsticks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Creative Soundcard
    By DoubleDs in forum SCAN.care@HEXUS
    Replies: 1
    Last Post: 20-03-2006, 10:47 AM
  2. Creative Soundcard v AC97
    By Syd in forum PC Hardware and Components
    Replies: 5
    Last Post: 24-01-2006, 10:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •