Results 1 to 6 of 6

Thread: Screen problem

  1. #1
    Poor graduate. Ulti's Avatar
    Join Date
    Feb 2009
    Posts
    2,007
    Thanks
    702
    Thanked
    222 times in 191 posts
    • Ulti's system
      • Motherboard:
      • AsRock B450M Pro4
      • CPU:
      • AMD Ryzen 7 1800X
      • Memory:
      • Team Group Delta 32GB
      • Storage:
      • Samsung 970 EVO+ 500GB
      • Graphics card(s):
      • Palit GTX 1070 8GB
      • PSU:
      • SilverStone SX500-LG V2.0
      • Case:
      • Jonsbo UMX3 TG Version
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • AOC Agon AG322QC4 31.5"
      • Internet:
      • Plusnet Fibre Extra 80/20

    Screen problem

    Recently grabbed an AGP 9700Pro for dirt cheap on eBay but I just installed it and the screen is like this:



    So i thought it was a problem with the drivers but after uninstalling all drivers and using drivesweeper 2.10, the problem still persists.

    Should I return the card or is there a way to fix this? Thanks!

    EDIT: Just to tell you everything works fine before and after with an Nvidia Ti4200.

    Also another piece of information is that even the bootup and windows loading screen is like that but it's the whole screen and not only half.
    Last edited by Ulti; 08-12-2009 at 06:11 PM.

  2. #2
    Senior Member
    Join Date
    Dec 2008
    Location
    Cardiff
    Posts
    350
    Thanks
    24
    Thanked
    15 times in 14 posts
    • WhiteGiant's system
      • Motherboard:
      • Asus P5Q-E (1901 BIOS)
      • CPU:
      • Intel E8400 @ 3.6Ghz / TRUE Black
      • Memory:
      • 8gb Corsair 4-4-4-12 @2.1v
      • Storage:
      • 2 x 500gb Seagate (RAID0) + Storage drives(1.7tb)
      • Graphics card(s):
      • Powercolor 4870 1gb
      • PSU:
      • Enermax 500w (Modular)
      • Case:
      • Antec Nine Hundred v1
      • Operating System:
      • Win7 Home Premium
      • Monitor(s):
      • Belinea Artistline 22w
      • Internet:
      • Sky Max - oddly getting faster.

    Re: Screen problem

    Looks like a knackered card I'm afraid.
    "Don't wanna see your face, don't wanna hear your voice . . ."

  3. Received thanks from:

    Ulti (09-12-2009)

  4. #3
    Senior Member
    Join Date
    Jun 2009
    Posts
    282
    Thanks
    30
    Thanked
    31 times in 29 posts
    • Cheapy's system
      • Motherboard:
      • Gigabyte GA-MA770T-UD3P
      • CPU:
      • AMD Phenom II X3 710 (Unlocked)
      • Memory:
      • 4Gb Corsair DDR3
      • Storage:
      • 320Gb Samsung F1
      • Graphics card(s):
      • Sapphire 7950 Vapor-X
      • PSU:
      • 520W Corsair HX
      • Case:
      • Fractal Define R3
      • Operating System:
      • Windows 7
      • Monitor(s):
      • BenQ GW2450HM

    Re: Screen problem

    The card is dying like whitegiant said. About 5 months ago my Radeon 9700pro AGP started doing exactly the same thing until the screen was unreadable due to the multicoloured patterns running across it.

  5. Received thanks from:

    Ulti (09-12-2009)

  6. #4
    Senior Lurker
    Join Date
    Sep 2008
    Posts
    1,038
    Thanks
    202
    Thanked
    59 times in 58 posts
    • Englander's system
      • Motherboard:
      • ASUS Z170 Pro Gaming
      • CPU:
      • i5-6500
      • Memory:
      • 2x8GB Corsair Vengeance LPX 2666MHz
      • Storage:
      • SanDisk 128GB SSD
      • Graphics card(s):
      • Intel HD 530 Integrated Graphics
      • PSU:
      • Be Quiet! Straight Power 10 400W
      • Case:
      • Corsair Carbide 100R Silent Edition
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • Dell U2515H
      • Internet:
      • Plusnet 38Mb/2Mb

    Re: Screen problem

    I think we know why it was dirt cheap, now...

  7. Received thanks from:

    Ulti (09-12-2009)

  8. #5
    Registered+
    Join Date
    Dec 2009
    Posts
    28
    Thanks
    0
    Thanked
    2 times in 2 posts

    Re: Screen problem

    Send it back, looks like its had some problem due to overheating in the past or possably even now.

  9. Received thanks from:

    Ulti (09-12-2009)

  10. #6
    Poor graduate. Ulti's Avatar
    Join Date
    Feb 2009
    Posts
    2,007
    Thanks
    702
    Thanked
    222 times in 191 posts
    • Ulti's system
      • Motherboard:
      • AsRock B450M Pro4
      • CPU:
      • AMD Ryzen 7 1800X
      • Memory:
      • Team Group Delta 32GB
      • Storage:
      • Samsung 970 EVO+ 500GB
      • Graphics card(s):
      • Palit GTX 1070 8GB
      • PSU:
      • SilverStone SX500-LG V2.0
      • Case:
      • Jonsbo UMX3 TG Version
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • AOC Agon AG322QC4 31.5"
      • Internet:
      • Plusnet Fibre Extra 80/20

    Re: Screen problem

    Guess I'll be sending it back, no reply by end of week and I'll go to paypal and ask for a refund and leave negative feedback!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 4870 black screen high fan RPM problem - anyone else had this?
    By websemantic in forum Help! Quick Relief From Tech Headaches
    Replies: 51
    Last Post: 24-09-2009, 10:52 AM
  2. Please help me! Blue Screen Problem
    By guitarbloke in forum Help! Quick Relief From Tech Headaches
    Replies: 5
    Last Post: 01-07-2008, 04:28 PM
  3. LG L226WTQ Problem, Please Help !
    By spadders in forum Help! Quick Relief From Tech Headaches
    Replies: 3
    Last Post: 06-04-2008, 11:03 PM
  4. new quicktime problem: ? on screen
    By fuddam in forum Help! Quick Relief From Tech Headaches
    Replies: 0
    Last Post: 03-11-2006, 07:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •