Results 1 to 5 of 5

Thread: How to enable TRIM on a Kingston 40gb SSDNOW drive!

  1. #1
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU

    How to enable TRIM on a Kingston 40gb SSDNOW drive!



    Some clever bugger's found a way to do it This is excellent news!

    http://www.overclock.net/ssd/656984-...-40gb-ssd.html
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


  2. Received thanks from:

    Englander (08-02-2010)

  3. #2
    Senior Lurker
    Join Date
    Sep 2008
    Posts
    1,038
    Thanks
    202
    Thanked
    59 times in 58 posts
    • Englander's system
      • Motherboard:
      • ASUS Z170 Pro Gaming
      • CPU:
      • i5-6500
      • Memory:
      • 2x8GB Corsair Vengeance LPX 2666MHz
      • Storage:
      • SanDisk 128GB SSD
      • Graphics card(s):
      • Intel HD 530 Integrated Graphics
      • PSU:
      • Be Quiet! Straight Power 10 400W
      • Case:
      • Corsair Carbide 100R Silent Edition
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • Dell U2515H
      • Internet:
      • Plusnet 38Mb/2Mb

    Re: How to enable TRIM on a Kingston 40gb SSDNOW drive!

    Trying it out now, thanks for the tip

  4. #3
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU

    Re: How to enable TRIM on a Kingston 40gb SSDNOW drive!

    Well i'm typing on an upgraded system - this works! Whooo!
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


  5. #4
    Senior Lurker
    Join Date
    Sep 2008
    Posts
    1,038
    Thanks
    202
    Thanked
    59 times in 58 posts
    • Englander's system
      • Motherboard:
      • ASUS Z170 Pro Gaming
      • CPU:
      • i5-6500
      • Memory:
      • 2x8GB Corsair Vengeance LPX 2666MHz
      • Storage:
      • SanDisk 128GB SSD
      • Graphics card(s):
      • Intel HD 530 Integrated Graphics
      • PSU:
      • Be Quiet! Straight Power 10 400W
      • Case:
      • Corsair Carbide 100R Silent Edition
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • Dell U2515H
      • Internet:
      • Plusnet 38Mb/2Mb

    Re: How to enable TRIM on a Kingston 40gb SSDNOW drive!



    Don't know why it's in Chinese but the "TRIM" highlighted in black means it's activated

    Thank you very much, kind sir
    Last edited by Englander; 08-02-2010 at 08:32 PM. Reason: It's Chinese, not Japanese!

  6. #5
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU

    Re: How to enable TRIM on a Kingston 40gb SSDNOW drive!

    Quote Originally Posted by Englander View Post


    Don't know why it's in Japanese but the "TRIM" highlighted in black means it's activated

    Thank you very much, kind sir
    Check the crystaldisk folder - open diskinfo.ini and change the language to English (just type it in place of simplified chinese)

    Code:
    [Setting]
    DebugMode=0
    AutoRefresh=10
    StartupWaitTime=30
    Temperature=0
    ResidentMinimize=0
    Theme=default
    Language=English
    Height=610
    GraphHeight=480
    GraphWidth=640
    [USB]
    SAT=1
    IODATA=1
    Sunplus=1
    Logitec=1
    JMicron=1
    Cypress=1
    [GraphHideDisk]
    Disk0=0
    Disk1=0

    I'm trying the hack for the intel management tools but that doesn't seem to work (to recognize the drive) for some odd reason. Can't remember if this (002) has AHCI on i'll check..
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kingston SSDNow V-Series / Confused
    By Terbinator in forum PC Hardware and Components
    Replies: 13
    Last Post: 14-01-2010, 01:27 PM
  2. Replies: 20
    Last Post: 01-11-2009, 12:06 AM
  3. Replies: 11
    Last Post: 18-09-2009, 11:49 AM
  4. Free extra space? check this!!!
    By DR in forum PC Hardware and Components
    Replies: 145
    Last Post: 01-10-2005, 02:08 PM
  5. Looking for a Database Programmer
    By tillyoubreakit in forum Software
    Replies: 35
    Last Post: 25-04-2004, 05:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •