Results 1 to 13 of 13

Thread: Are these fps normal?

  1. #1
    Registered+
    Join Date
    Mar 2009
    Posts
    82
    Thanks
    2
    Thanked
    0 times in 0 posts

    Are these fps normal?

    Ok, well this is the first gaming PC that I've had and I just want to know if the performance that I have been getting is acceptable for these specs.As I think that it's quite low compared to benchmarks and I am not sure if I should send back my graphics card or not. In a game of css earlier today I was getting between 20 and 100 fps on high, no AA, bilinear filters and 1080p. Same settings on oblivion got me between 15 and 60 fps. Basically all games that I play lag, is this normal? Thanks

    Specs

    amd phenom 940 x 4 @ 3Ghz
    4GB DDR2 Ram
    ATI 4890
    HAF 932
    asus M3N78 pro
    500 GB HDD

  2. #2
    Senior Member kalniel's Avatar
    Join Date
    Aug 2005
    Posts
    29,196
    Thanks
    1,520
    Thanked
    2,933 times in 2,376 posts
    • kalniel's system
      • Motherboard:
      • Gigabyte X58A UD3R rev 2
      • CPU:
      • Intel Xeon X5680
      • Memory:
      • 12gb DDR3 2000
      • Graphics card(s):
      • nVidia GTX 1060 6GB
      • PSU:
      • Seasonic 600W
      • Case:
      • Cooler Master HAF 912
      • Operating System:
      • Win 10 Pro x64
      • Monitor(s):
      • Dell U2311H
      • Internet:
      • O2 8mbps

    Re: Are these fps normal?

    Hmm, not terribly clear what you're saying. Lag is usually where you do something but the server response is so slow that you're misaligned with whatever you thought you were doing, and it's nearly always internet latency related. It doesn't apply to games like Oblivion.

    Frame rate slow down is possibly what you're describing, and no, you shouldn't really be noticing slow down at 1920x1080. Make sure you've updated your drivers properly, get rid of any overclock, and check your airflow.

  3. #3
    Registered+
    Join Date
    Mar 2009
    Posts
    82
    Thanks
    2
    Thanked
    0 times in 0 posts

    Re: Are these fps normal?

    All temps are good and drivers are all up to date and its FPS lag. I don't know what to do anymore, look at this thread for more info. Should I send back my gpu?
    http://forums.hexus.net/scan-care-he...ard-issue.html

  4. #4
    Senior Member watercooled's Avatar
    Join Date
    Jan 2009
    Posts
    10,867
    Thanks
    1,502
    Thanked
    935 times in 805 posts

    Re: Are these fps normal?

    A faulty graphics card shouldn't cause a drop in frame rate, what usually does however is default drivers (as kalniel mentioned) - it's very important you download and install the latest drivers from the GPU MFR's website, in this case you can get them from here: http://support.amd.com/us/gpudownload/Pages/index.aspx

  5. #5
    Registered+
    Join Date
    Mar 2009
    Posts
    82
    Thanks
    2
    Thanked
    0 times in 0 posts

    Re: Are these fps normal?

    I have the latest drivers, any other possibilities? THe only other thing that I have noticed is my MCP temperature sensor stays constantly at 127 degrees C , so it's probably faulty but I thought that it may help finding out the cause of the fps drop. Could an overheating MCP cause low fps?

  6. #6
    Senior Member
    Join Date
    Jun 2009
    Posts
    282
    Thanks
    30
    Thanked
    31 times in 29 posts
    • Cheapy's system
      • Motherboard:
      • Gigabyte GA-MA770T-UD3P
      • CPU:
      • AMD Phenom II X3 710 (Unlocked)
      • Memory:
      • 4Gb Corsair DDR3
      • Storage:
      • 320Gb Samsung F1
      • Graphics card(s):
      • Sapphire 7950 Vapor-X
      • PSU:
      • 520W Corsair HX
      • Case:
      • Fractal Define R3
      • Operating System:
      • Windows 7
      • Monitor(s):
      • BenQ GW2450HM

    Re: Are these fps normal?

    Are you using any software to measure your FPS? If you are then that could be causing the stuttering mayby.

  7. #7
    Senior Member
    Join Date
    Sep 2008
    Location
    Durham, England
    Posts
    634
    Thanks
    18
    Thanked
    25 times in 24 posts
    • Rookie1986's system
      • Motherboard:
      • ASRock Fatal1ty z77 Pro
      • CPU:
      • Intel i5 3570K
      • Memory:
      • 16GB (2 x 8GB) Corsair Vengeance Pro DDR3 2400Mhz (Red)
      • Storage:
      • Crucial M4 SSD 128/256GB - Seagate 2TB 7200rpm
      • Graphics card(s):
      • ATI Radeon 3GB XFX 7970 Black with Ghost + Hydrocell
      • PSU:
      • Corsair AX850
      • Case:
      • Corsair Obsidian 650D
      • Operating System:
      • Windows 10
      • Monitor(s):
      • LG 34UM95 34" 21:9 UltraWide QHD

    Re: Are these fps normal?

    I agree there appears to be a problem, I'm running an nVidia GeForce GTX 260 which is a lesser card then yours and get a far more constant FPS in both of these games. Does the frame-rate problem persist if you lower the resolution?

  8. #8
    Member
    Join Date
    Apr 2010
    Location
    Midlands
    Posts
    173
    Thanks
    3
    Thanked
    8 times in 8 posts
    • dcwt2010's system
      • Motherboard:
      • Asus P8Z68-V Gen 3
      • CPU:
      • i5 2500k @ 4.0GHz
      • Memory:
      • 2 x 4GB DDR3 Corsair Vengeance
      • Storage:
      • 96GB SSD Kingston V100+, 1TB Samsung
      • Graphics card(s):
      • 2GB 660 ti Palit Jetstream
      • PSU:
      • Antec Truepower 650W
      • Case:
      • Antec 300
      • Operating System:
      • Win 7 64bit
      • Monitor(s):
      • LG 24in
      • Internet:
      • Virginmedia 30Mbs

    Re: Are these fps normal?

    Have you been messing with the catalyst 3d settings? Like have FSAA set to x8 constantly?

  9. #9
    Registered+
    Join Date
    Mar 2009
    Posts
    82
    Thanks
    2
    Thanked
    0 times in 0 posts

    Re: Are these fps normal?

    Quote Originally Posted by Rookie1986 View Post
    I agree there appears to be a problem, I'm running an nVidia GeForce GTX 260 which is a lesser card then yours and get a far more constant FPS in both of these games. Does the frame-rate problem persist if you lower the resolution?
    The FPS increases but not by a lot, it's still below average.

  10. #10
    Registered+
    Join Date
    Mar 2009
    Posts
    82
    Thanks
    2
    Thanked
    0 times in 0 posts

    Re: Are these fps normal?

    Quote Originally Posted by dcwt2010 View Post
    Have you been messing with the catalyst 3d settings? Like have FSAA set to x8 constantly?
    Nope, I reset them to factory default to check if it was that. Does this benchmark look ok? I used 3DMark05 and had to run everything at default settings as I used the trial.
    http://service.futuremark.com/home.a...A747847EA459E8

    Quote Originally Posted by Cheapy View Post
    Are you using any software to measure your FPS? If you are then that could be causing the stuttering mayby.
    I was using fraps in some but in source games I used built in console commands.

    Thanks for all of the help but I am still bewildered by this. :S
    Last edited by haveron; 09-08-2010 at 05:51 PM.

  11. #11
    Registered+
    Join Date
    Mar 2009
    Posts
    82
    Thanks
    2
    Thanked
    0 times in 0 posts

    Re: Are these fps normal?

    The only thing that I can think is causing this is my MCP overheating. The sensor acts really strange, with the first hour of my PC being on the temperature switching between 60 - 70 and 80, flickering between the same numbers and then when it's been on for over an hour it stays stuck at 127 degrees C. Could an overheating MCP cause these issues?

  12. #12
    Bows out! CAT-THE-FIFTH's Avatar
    Join Date
    Aug 2006
    Location
    Hopefully somewhere less backstabby
    Posts
    28,789
    Thanks
    3,203
    Thanked
    4,456 times in 3,442 posts
    • CAT-THE-FIFTH's system
      • Motherboard:
      • Less E-PEEN
      • CPU:
      • Massive E-PEEN
      • Memory:
      • RGB E-PEEN
      • Storage:
      • Not in any order
      • Graphics card(s):
      • EVEN BIGGER E-PEEN
      • PSU:
      • OVERSIZED
      • Case:
      • UNDERSIZED
      • Operating System:
      • DOS 6.22
      • Monitor(s):
      • NOT USUALLY ON....WHEN I POST
      • Internet:
      • FUNCTIONAL

    Re: Are these fps normal?

    What PSU does the OP have?


    Those despicable Elk,stealing the pond weed!

  13. #13
    Registered+
    Join Date
    Mar 2009
    Posts
    82
    Thanks
    2
    Thanked
    0 times in 0 posts

    Re: Are these fps normal?

    corsair 750 watt

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Are these fps normal?
    By haveron in forum SCAN.care@HEXUS
    Replies: 1
    Last Post: 08-08-2010, 10:09 PM
  2. Replies: 17
    Last Post: 23-06-2010, 07:09 PM
  3. Nothing on monitor on booting for 30 secs, then works as normal....!?
    By GSte in forum Help! Quick Relief From Tech Headaches
    Replies: 3
    Last Post: 17-06-2007, 12:17 PM
  4. What FPS with 6800GT playing Morrowind?
    By ed^chigliak in forum Gaming
    Replies: 8
    Last Post: 29-10-2004, 08:01 PM
  5. X800XT Benchmark Thread... Post Your Results Here!
    By Richdog in forum Graphics Cards
    Replies: 93
    Last Post: 03-09-2004, 07:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •