Results 1 to 9 of 9

Thread: AMD/ATI chipset drivers.

  1. #1
    Senior Member
    Join Date
    Oct 2004
    Posts
    1,731
    Thanks
    230
    Thanked
    151 times in 132 posts
    • Sputnik's system
      • Motherboard:
      • J&W 790GX Extreme
      • CPU:
      • AMD Phenom II 720be
      • Memory:
      • OCZ DDR2-6400
      • PSU:
      • Enermax

    AMD/ATI chipset drivers.

    I find these drivers to be confusing to say the least. I installed what I thought was the full package and then after tried to install the south bridge drivers. Which reported that the north bridge filter was not installed and it seemed it would install it, Then when I went to install the ahci drivers it said the north bridge drivers were not installed.

    Can someone please enlighten me.

  2. #2
    Senior Member kalniel's Avatar
    Join Date
    Aug 2005
    Posts
    29,196
    Thanks
    1,520
    Thanked
    2,933 times in 2,376 posts
    • kalniel's system
      • Motherboard:
      • Gigabyte X58A UD3R rev 2
      • CPU:
      • Intel Xeon X5680
      • Memory:
      • 12gb DDR3 2000
      • Graphics card(s):
      • nVidia GTX 1060 6GB
      • PSU:
      • Seasonic 600W
      • Case:
      • Cooler Master HAF 912
      • Operating System:
      • Win 10 Pro x64
      • Monitor(s):
      • Dell U2311H
      • Internet:
      • O2 8mbps

    Re: AMD/ATI chipset drivers.

    Driver CD?

  3. #3
    Senior Member
    Join Date
    Oct 2004
    Posts
    1,731
    Thanks
    230
    Thanked
    151 times in 132 posts
    • Sputnik's system
      • Motherboard:
      • J&W 790GX Extreme
      • CPU:
      • AMD Phenom II 720be
      • Memory:
      • OCZ DDR2-6400
      • PSU:
      • Enermax

    Re: AMD/ATI chipset drivers.

    The CD that came with the board has the old drivers on it. So I thought I'd download and install the latest drivers as I'm doing a fresh install of Win7 64 bit.

  4. #4
    Senior Member kalniel's Avatar
    Join Date
    Aug 2005
    Posts
    29,196
    Thanks
    1,520
    Thanked
    2,933 times in 2,376 posts
    • kalniel's system
      • Motherboard:
      • Gigabyte X58A UD3R rev 2
      • CPU:
      • Intel Xeon X5680
      • Memory:
      • 12gb DDR3 2000
      • Graphics card(s):
      • nVidia GTX 1060 6GB
      • PSU:
      • Seasonic 600W
      • Case:
      • Cooler Master HAF 912
      • Operating System:
      • Win 10 Pro x64
      • Monitor(s):
      • Dell U2311H
      • Internet:
      • O2 8mbps

    Re: AMD/ATI chipset drivers.

    It might be worth using the driver CD first, if it had 64 bit drivers at least, as then you'll have a minimum level for dependencies.

  5. Received thanks from:

    Sputnik (10-08-2010)

  6. #5
    Does he need a reason? Funkstar's Avatar
    Join Date
    Aug 2005
    Location
    Aberdeen
    Posts
    19,874
    Thanks
    630
    Thanked
    965 times in 816 posts
    • Funkstar's system
      • Motherboard:
      • Gigabyte EG45M-DS2H
      • CPU:
      • Intel Core2Quad Q9550 (2.83GHz)
      • Memory:
      • 8GB OCZ PC2-6400C5 800MHz Quad Channel
      • Storage:
      • 650GB Western Digital Caviar Blue
      • Graphics card(s):
      • 512MB ATI Radeon HD4550
      • PSU:
      • Antec 350W 80+ Efficient PSU
      • Case:
      • Antec NSK1480 Slim Mini Desktop Case
      • Operating System:
      • Vista Ultimate 64bit
      • Monitor(s):
      • Dell 2407 + 2408 monitors
      • Internet:
      • Zen 8mb

    Re: AMD/ATI chipset drivers.

    What's the chipset?

    I've always just used the full Catalyst pack and it's been fine, this is on 780 and 790 chipsets.

  7. Received thanks from:

    Sputnik (10-08-2010)

  8. #6
    Senior Member
    Join Date
    Oct 2004
    Posts
    1,731
    Thanks
    230
    Thanked
    151 times in 132 posts
    • Sputnik's system
      • Motherboard:
      • J&W 790GX Extreme
      • CPU:
      • AMD Phenom II 720be
      • Memory:
      • OCZ DDR2-6400
      • PSU:
      • Enermax

    Re: AMD/ATI chipset drivers.

    Quote Originally Posted by Funkstar View Post
    What's the chipset?

    I've always just used the full Catalyst pack and it's been fine, this is on 780 and 790 chipsets.
    It is a 790GX. So it should be fine using the full pack. Does that install the south bridge and AHCI drivers too ?

    VIA and Nvidia drivers seemed to be much simpler to understand.

    Searching on the AMD website only gives drivers for Linux or XP when using their search for drivers. So I downloaded them from game.amd.com

  9. #7
    Does he need a reason? Funkstar's Avatar
    Join Date
    Aug 2005
    Location
    Aberdeen
    Posts
    19,874
    Thanks
    630
    Thanked
    965 times in 816 posts
    • Funkstar's system
      • Motherboard:
      • Gigabyte EG45M-DS2H
      • CPU:
      • Intel Core2Quad Q9550 (2.83GHz)
      • Memory:
      • 8GB OCZ PC2-6400C5 800MHz Quad Channel
      • Storage:
      • 650GB Western Digital Caviar Blue
      • Graphics card(s):
      • 512MB ATI Radeon HD4550
      • PSU:
      • Antec 350W 80+ Efficient PSU
      • Case:
      • Antec NSK1480 Slim Mini Desktop Case
      • Operating System:
      • Vista Ultimate 64bit
      • Monitor(s):
      • Dell 2407 + 2408 monitors
      • Internet:
      • Zen 8mb

    Re: AMD/ATI chipset drivers.

    I can't check at the moment, but yes, I'm positive it installed the complete chipset drivers including all the graphics control panels too.

  10. Received thanks from:

    Sputnik (11-08-2010)

  11. #8
    Welcome to stampytown! Salazaar's Avatar
    Join Date
    Dec 2004
    Location
    Oxford
    Posts
    4,436
    Thanks
    505
    Thanked
    351 times in 252 posts

    Re: AMD/ATI chipset drivers.

    Just my 2p but I've always got on fine installing the full catalyst suite on my 780G.
    ____
    (='.'=)
    (")_(")

  12. Received thanks from:

    Sputnik (11-08-2010)

  13. #9
    Senior Member
    Join Date
    Oct 2004
    Posts
    1,731
    Thanks
    230
    Thanked
    151 times in 132 posts
    • Sputnik's system
      • Motherboard:
      • J&W 790GX Extreme
      • CPU:
      • AMD Phenom II 720be
      • Memory:
      • OCZ DDR2-6400
      • PSU:
      • Enermax

    Re: AMD/ATI chipset drivers.

    I've not had any problems with the system since putting it together about 18 months ago but, I was doing a fresh install of Win7 on an SSD for it and just did not remember seeing this error message about a north bridge filter driver.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Nvidia cards wont play games properly in newest drivers
    By Ltr0x in forum PC Hardware and Components
    Replies: 2
    Last Post: 18-12-2009, 01:21 PM
  2. Do I install drivers from Acer website or leave the ones Vista downloaded?
    By jallsey in forum Help! Quick Relief From Tech Headaches
    Replies: 3
    Last Post: 19-09-2009, 07:57 AM
  3. Windows 7 + Intel x38 Chipset = Issues :(
    By Grey M@a in forum Software
    Replies: 10
    Last Post: 24-07-2009, 10:52 AM
  4. Replies: 0
    Last Post: 23-08-2005, 10:20 AM
  5. NVIDIA graphics drivers to go multithreaded
    By Steve in forum HEXUS News
    Replies: 0
    Last Post: 22-06-2005, 08:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •