Results 1 to 4 of 4

Thread: Logitech Madness

  1. #1
    Senior Member
    Join Date
    Oct 2009
    Location
    Alfreton
    Posts
    323
    Thanks
    31
    Thanked
    18 times in 18 posts
    • cub1061's system
      • Motherboard:
      • Asrock B250M Pro
      • CPU:
      • Intel i7 6700k
      • Memory:
      • 16gb ddr4
      • Storage:
      • 240 ssd + 2x1gb Seagate
      • Graphics card(s):
      • EVGA 1060 6gb
      • PSU:
      • BeQuite 630w
      • Case:
      • Fractal Define Mini C
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • AOC 27"
      • Internet:
      • Snail speed

    Logitech Madness

    I have a Logitech S510 keyboard and mouse combi.
    1st everything was fine with all on screen display for sound etc.
    Now when I press buttons on the keyboard I don't get any displays, i.e. Press Cap Lock use to display on screen now nothing.
    Don't know why this has started to happen.
    Any ideas?
    Last edited by cub1061; 15-03-2011 at 09:21 PM.

  2. #2
    Senior Member this_is_gav's Avatar
    Join Date
    Dec 2005
    Location
    Alnwick, Northumberland
    Posts
    4,835
    Thanks
    175
    Thanked
    246 times in 213 posts
    • this_is_gav's system
      • Motherboard:
      • DFI DK X58-T3eH6
      • CPU:
      • Intel i7 920
      • Memory:
      • 12GB Corsair 1333MHz C9
      • Storage:
      • 2xRaptor 150GB (RAID0 300GB), 2.5TB permanent storage
      • Graphics card(s):
      • Nvidia GTX 560 Ti 1GB
      • PSU:
      • Seasonic X-series
      • Case:
      • Lian-Li A70B
      • Operating System:
      • Windows 7 x64
      • Monitor(s):
      • Dell 2408WFP
      • Internet:
      • 8M ADSL24

    Re: Logitech Madness

    Is SetPoint running?

    If so, is the option to show such status settings set?

    On my SetPoint (4.80) it's here:

    SetPoint > Tools > "Indicator settings" (tab second down on the left side of the screen) > tick "Show status setting changes (such as Caps Lock) on screen".

  3. #3
    Senior Member
    Join Date
    Oct 2009
    Location
    Alfreton
    Posts
    323
    Thanks
    31
    Thanked
    18 times in 18 posts
    • cub1061's system
      • Motherboard:
      • Asrock B250M Pro
      • CPU:
      • Intel i7 6700k
      • Memory:
      • 16gb ddr4
      • Storage:
      • 240 ssd + 2x1gb Seagate
      • Graphics card(s):
      • EVGA 1060 6gb
      • PSU:
      • BeQuite 630w
      • Case:
      • Fractal Define Mini C
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • AOC 27"
      • Internet:
      • Snail speed

    Re: Logitech Madness

    Quote Originally Posted by this_is_gav View Post
    Is SetPoint running?

    If so, is the option to show such status settings set?

    On my SetPoint (4.80) it's here:

    SetPoint > Tools > "Indicator settings" (tab second down on the left side of the screen) > tick "Show status setting changes (such as Caps Lock) on screen".
    Done all that still nothing, I was running 6.10 which worked fine then 6.20 still worked but a couple of hours later, nothing on screen. Re-installed 6.10 but no change.

  4. #4
    Senior Member
    Join Date
    Oct 2009
    Location
    Alfreton
    Posts
    323
    Thanks
    31
    Thanked
    18 times in 18 posts
    • cub1061's system
      • Motherboard:
      • Asrock B250M Pro
      • CPU:
      • Intel i7 6700k
      • Memory:
      • 16gb ddr4
      • Storage:
      • 240 ssd + 2x1gb Seagate
      • Graphics card(s):
      • EVGA 1060 6gb
      • PSU:
      • BeQuite 630w
      • Case:
      • Fractal Define Mini C
      • Operating System:
      • Windows 10 64bit
      • Monitor(s):
      • AOC 27"
      • Internet:
      • Snail speed

    Re: Logitech Madness

    Quote Originally Posted by desir0 View Post
    Try reinstalling drivers?
    Did that. I was using 6.10 before update and all was fine. Using 6.10 now but still nothing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Logitech G500 and RMA
    By Defiant in forum SCAN.care@HEXUS :: After sales support
    Replies: 4
    Last Post: 23-02-2010, 01:57 PM
  2. Logitech MX Revolution RMA
    By Sumanji in forum SCAN.care@HEXUS
    Replies: 1
    Last Post: 03-07-2009, 03:29 PM
  3. Logitech Duet hands on
    By Funkstar in forum Reader Reviews
    Replies: 30
    Last Post: 10-02-2009, 04:45 PM
  4. Logitech to acquire Slim Devices!
    By Funkstar in forum General Discussion
    Replies: 0
    Last Post: 18-10-2006, 11:09 PM
  5. Logitech MX700 Cordless Mouse
    By Lee H in forum Reader Reviews
    Replies: 0
    Last Post: 04-12-2004, 01:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •