Results 1 to 3 of 3

Thread: *help* can not power on

  1. #1
    Registered+
    Join Date
    Dec 2011
    Posts
    22
    Thanks
    0
    Thanked
    1 time in 1 post

    Unhappy *help* can not power on

    The light on board is on;
    The power supply and all the others are not working when pushing down the power button.

    It was ok before I was trying to replace the old CPU fan

  2. #2
    Anthropomorphic Personification shaithis's Avatar
    Join Date
    Apr 2004
    Location
    The Last Aerie
    Posts
    10,836
    Thanks
    645
    Thanked
    871 times in 735 posts
    • shaithis's system
      • Motherboard:
      • Asus P8Z77 WS
      • CPU:
      • i7 3770k @ 4.5GHz
      • Memory:
      • 32GB HyperX 1866
      • Storage:
      • Lots!
      • Graphics card(s):
      • Sapphire Fury X
      • PSU:
      • Corsair HX850
      • Case:
      • Corsair 600T (White)
      • Operating System:
      • Windows 10 x64
      • Monitor(s):
      • 2 x Dell 3007
      • Internet:
      • Zen 80Mb Fibre

    Re: *help* can not power on

    Are you sure you have connected both power cables to the motherboard?

    Did you have to remove the motherboard to fit the new heatsink/fan?
    Main PC: Asus Rampage IV Extreme / 3960X@4.5GHz / Antec H1200 Pro / 32GB DDR3-1866 Quad Channel / Sapphire Fury X / Areca 1680 / 850W EVGA SuperNOVA Gold 2 / Corsair 600T / 2x Dell 3007 / 4 x 250GB SSD + 2 x 80GB SSD / 4 x 1TB HDD (RAID 10) / Windows 10 Pro, Yosemite & Ubuntu
    HTPC: AsRock Z77 Pro 4 / 3770K@4.2GHz / 24GB / GTX 1080 / SST-LC20 / Antec TP-550 / Hisense 65k5510 4K TV / HTC Vive / 2 x 240GB SSD + 12TB HDD Space / Race Seat / Logitech G29 / Win 10 Pro
    HTPC2: Asus AM1I-A / 5150 / 4GB / Corsair Force 3 240GB / Silverstone SST-ML05B + ST30SF / Samsung UE60H6200 TV / Windows 10 Pro
    Spare/Loaner: Gigabyte EX58-UD5 / i950 / 12GB / HD7870 / Corsair 300R / Silverpower 700W modular
    NAS 1: HP N40L / 12GB ECC RAM / 2 x 3TB Arrays || NAS 2: Dell PowerEdge T110 II / 24GB ECC RAM / 2 x 3TB Hybrid arrays || Network:Buffalo WZR-1166DHP w/DD-WRT + HP ProCurve 1800-24G
    Laptop: Lenovo Flex 2 / 12GB RAM / 240GB Corsair Force 3 Printer: HP CP1515n || Phone: HTC One U11 || Other: Samsung Galaxy Tab 4 Pro 10.1 CM12.1 / Playstation 4 + G29 + 2TB Hybrid drive

  3. #3
    Registered+
    Join Date
    Nov 2010
    Location
    Sheffield
    Posts
    71
    Thanks
    6
    Thanked
    3 times in 3 posts
    • Ginger-Menace's system
      • Motherboard:
      • Asus P8P67 Pro
      • CPU:
      • i5 2500k 4.5, 1.32v
      • Memory:
      • 8gb Corsair Vengence 1600 c8
      • Storage:
      • Ocz Vertex 2E 120gb, 2 hdd's
      • Graphics card(s):
      • SLI GTX 570
      • PSU:
      • Corsair tx750w
      • Case:
      • CoolerMaster Haf X
      • Operating System:
      • Windows 7 Home Premium

    Re: *help* can not power on

    make sure that both the 4/8 pin and the 20+4 pin is plugged in correctly, and also make sure you havnt dislodged the front panel connectors ( usually at the bottom right)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •