Results 1 to 2 of 2

Thread: My new Sabretooth Z77 build thread

  1. #1
    Seriously casual gamer KeyboardDemon's Avatar
    Join Date
    Feb 2012
    Location
    London
    Posts
    3,013
    Thanks
    774
    Thanked
    280 times in 242 posts
    • KeyboardDemon's system
      • Motherboard:
      • Asus Sabretooth Z77
      • CPU:
      • i7 3770k + Corsair H80 (Refurbed)
      • Memory:
      • 16gb (4x4gb) Corsair Vengence Red (1866mhz) - (Because it looks good in a black mobo)
      • Storage:
      • Crucial M550 SSD 1TB + 2x 500GB Seagate HDDs
      • Graphics card(s):
      • EVGA GTX 980 SC ACX 2.0 (Warranty replacement for 780Ti SC ACX)
      • PSU:
      • EVGA 750 watt SuperNova G2
      • Case:
      • Silverstone RV03
      • Operating System:
      • Windows 10 Pro 64 Bit
      • Monitor(s):
      • Asus Swift PG278Q
      • Internet:
      • BT Infinity (40mbs dl/10mbs ul)

    My new Sabretooth Z77 build thread

    I have recently built a new PC:

    Sabretooth Z77 mobo
    i7 3770k CPU + NZXT Havik 140 HSF
    8gb Corsair Vengence 1866mhz RAM
    XFX HD6990 GPU
    Seagate 1TB HDD + 128gb OCZ Synapse Cache drive
    OCZ 750w PSU
    Silverstone Raven RV03 case

    The reason for starting this thread is that I'm completely new to using Intel CPUs so I feel a little out of my depth.

    There seem to be many more options in the BIOS than I am used to and some I'm used to are no longer there, even installing Windows became an ordeal because of the MBR/GPT issue that I had never heard of before or that wasn't in my Sabretooth user guide.

    Instead of starting a new thread for every question I thought it might be better to consolidate them all to one place and add questions here as I go along. I hope you guys don't mind.

    So my first question is about RAM speeds, the mobo defaults to 1333mhz my RAM can run at 1866mhz so I went into the BIOS and set this to 1866 manually but now my startup times have gone from a 22second boot from cold start to 85 seconds, I'm assuming that this is related to RAM as it is the only thing that I changed. I would have selected the SPD profile but I couldn't see the option for that in my BIOS, does anyone know how I should have changed this for it to continue booting at its previous 22 second boot times? Or why it doesn't boot as it did before?

    I'll try going back to Auto on the ram speed and see if my boot times go back to 22seconds again.
    Last edited by KeyboardDemon; 27-08-2012 at 04:19 PM.

  2. #2
    Seriously casual gamer KeyboardDemon's Avatar
    Join Date
    Feb 2012
    Location
    London
    Posts
    3,013
    Thanks
    774
    Thanked
    280 times in 242 posts
    • KeyboardDemon's system
      • Motherboard:
      • Asus Sabretooth Z77
      • CPU:
      • i7 3770k + Corsair H80 (Refurbed)
      • Memory:
      • 16gb (4x4gb) Corsair Vengence Red (1866mhz) - (Because it looks good in a black mobo)
      • Storage:
      • Crucial M550 SSD 1TB + 2x 500GB Seagate HDDs
      • Graphics card(s):
      • EVGA GTX 980 SC ACX 2.0 (Warranty replacement for 780Ti SC ACX)
      • PSU:
      • EVGA 750 watt SuperNova G2
      • Case:
      • Silverstone RV03
      • Operating System:
      • Windows 10 Pro 64 Bit
      • Monitor(s):
      • Asus Swift PG278Q
      • Internet:
      • BT Infinity (40mbs dl/10mbs ul)

    Re: My new Sabretooth Z77 build thread

    OK. I figured that one out, it was set the Ai Overclock Tuner to XMP mode, I did this now everything seems to run fine. It's given me a small boost to just under 4.1ghz.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •