Results 1 to 12 of 12

Thread: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

  1. #1
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU

    Exclamation Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    Ok, ok you could well ask "yeah, but what year?"

    ...but if you're waiting for drivers from the guys at creative (or 1 guy possibly) then bookmark this page:

    http://support.creative.com/KB/showa...sid=61105&h=13
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


  2. #2
    mutantbass head Lee H's Avatar
    Join Date
    Dec 2003
    Location
    M28, Manchester
    Posts
    14,204
    Thanks
    337
    Thanked
    671 times in 580 posts
    • Lee H's system
      • Motherboard:
      • MSI Z370 Carbon Gaming
      • CPU:
      • Intel i7 8700K Unlocked CPU
      • Memory:
      • 16 GB Corsair Vengeance 3200 LPX
      • Storage:
      • 250GB 960 EVO + a few more drives
      • Graphics card(s):
      • 6GB Palit GTX 1060 Dual
      • PSU:
      • Antec Truepower 750W Modular Blue
      • Case:
      • Corsair 600T White Edition
      • Operating System:
      • Windows 10 PRO
      • Monitor(s):
      • 27" Asus MX279H & 24" Acer 3D GD245HQ + the 3D glasses
      • Internet:
      • Virgin Media

    Re: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    I wonder what features they'll disable with their windows 8 drivers

  3. Received thanks from:

    directhex (08-11-2012)

  4. #3
    Anthropomorphic Personification shaithis's Avatar
    Join Date
    Apr 2004
    Location
    The Last Aerie
    Posts
    10,836
    Thanks
    645
    Thanked
    871 times in 735 posts
    • shaithis's system
      • Motherboard:
      • Asus P8Z77 WS
      • CPU:
      • i7 3770k @ 4.5GHz
      • Memory:
      • 32GB HyperX 1866
      • Storage:
      • Lots!
      • Graphics card(s):
      • Sapphire Fury X
      • PSU:
      • Corsair HX850
      • Case:
      • Corsair 600T (White)
      • Operating System:
      • Windows 10 x64
      • Monitor(s):
      • 2 x Dell 3007
      • Internet:
      • Zen 80Mb Fibre

    Re: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    I pulled my XFi Titanium a few months ago to give a little more airflow for my gfx cards.....haven't missed it in the slightest and the on-board (Realtek) is working fine with Windows 8 OOTB drivers.
    Main PC: Asus Rampage IV Extreme / 3960X@4.5GHz / Antec H1200 Pro / 32GB DDR3-1866 Quad Channel / Sapphire Fury X / Areca 1680 / 850W EVGA SuperNOVA Gold 2 / Corsair 600T / 2x Dell 3007 / 4 x 250GB SSD + 2 x 80GB SSD / 4 x 1TB HDD (RAID 10) / Windows 10 Pro, Yosemite & Ubuntu
    HTPC: AsRock Z77 Pro 4 / 3770K@4.2GHz / 24GB / GTX 1080 / SST-LC20 / Antec TP-550 / Hisense 65k5510 4K TV / HTC Vive / 2 x 240GB SSD + 12TB HDD Space / Race Seat / Logitech G29 / Win 10 Pro
    HTPC2: Asus AM1I-A / 5150 / 4GB / Corsair Force 3 240GB / Silverstone SST-ML05B + ST30SF / Samsung UE60H6200 TV / Windows 10 Pro
    Spare/Loaner: Gigabyte EX58-UD5 / i950 / 12GB / HD7870 / Corsair 300R / Silverpower 700W modular
    NAS 1: HP N40L / 12GB ECC RAM / 2 x 3TB Arrays || NAS 2: Dell PowerEdge T110 II / 24GB ECC RAM / 2 x 3TB Hybrid arrays || Network:Buffalo WZR-1166DHP w/DD-WRT + HP ProCurve 1800-24G
    Laptop: Lenovo Flex 2 / 12GB RAM / 240GB Corsair Force 3 Printer: HP CP1515n || Phone: HTC One U11 || Other: Samsung Galaxy Tab 4 Pro 10.1 CM12.1 / Playstation 4 + G29 + 2TB Hybrid drive

  5. #4
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU

    Re: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    Quote Originally Posted by Lee @ SCAN View Post
    I wonder what features they'll disable with their windows 8 drivers
    Well for me it was er.. "sound" - the sound disappearing on reboot bug came back.

    Quote Originally Posted by shaithis View Post
    I pulled my XFi Titanium a few months ago to give a little more airflow for my gfx cards.....haven't missed it in the slightest and the on-board (Realtek) is working fine with Windows 8 OOTB drivers.
    I tried (very hard - onboard and xonar) not to miss my XFI Titanium Pro but in the end the quality of sound is far better over my Z-5500's and I do (god help me) like the audio enhancements too. Eventually things got fixed for 7 and i've been happy with it since - 8 came along and broke all that (well not 8 as such but..). ATM i'm dual booting and 7 is still my primary OS.

    Airflow? Pshhaarr! Waterflow for me
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


  6. #5
    Syd
    Syd is offline
    Hanging on the Edge Syd's Avatar
    Join Date
    Jan 2006
    Location
    Kent
    Posts
    1,636
    Thanks
    69
    Thanked
    32 times in 29 posts
    • Syd's system
      • Motherboard:
      • EVGA 760 Classified / MSI P35 / gigabyte gaming 7 1150
      • CPU:
      • I7 920@3.8 / E8400 / 4790k
      • Memory:
      • 18GB Dominator DDR3 1600 / 4GB / 16GB GSill
      • Storage:
      • 2 x Samsung 830 256/ 120GB Vertex 2 / Sam840's/ Sam SM951
      • Graphics card(s):
      • 690GTX on Water/IGP/ 980ti
      • PSU:
      • AX860/1250w Seasonic
      • Case:
      • TJ07 / PCV700
      • Operating System:
      • 7 64/ 10 64
      • Monitor(s):
      • NEC 3090 + Dell 2405PW
      • Internet:
      • Sky Fibre

    Re: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    Quote Originally Posted by dangel View Post
    Well for me it was er.. "sound" - the sound disappearing on reboot bug came back.



    I tried (very hard - onboard and xonar) not to miss my XFI Titanium Pro but in the end the quality of sound is far better over my Z-5500's and I do (god help me) like the audio enhancements too. Eventually things got fixed for 7 and i've been happy with it since - 8 came along and broke all that (well not 8 as such but..). ATM i'm dual booting and 7 is still my primary OS.

    Airflow? Pshhaarr! Waterflow for me
    Hi dangle - did you find the Asus card that much different to the titanium through the 5500's?





    My very first watercooled PC project log

  7. #6
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU

    Re: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    Quote Originally Posted by Syd View Post
    Hi dangle - did you find the Asus card that much different to the titanium through the 5500's?
    Personally yes - but it's highly subjective and I'd struggle to recommend creative cards because the software support is (and has always) been really poor. The hardware IMHO works well it's just they're obviously not investing in their software side nearly enough. As you see a lot of people are fine with onboard sound (it's much better than it once was) - but that sounds miles worse than the xfi through the z5500's as (for PC speakers) they are remarkably good. The same applies to the xonar though, discreet audio still has the benefits of better SNR and circuitry that's better isolated from electrical noise.
    I suspect i'm so used to the XFI's sound that I'm probably unhappy with other solutions because they're different
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


  8. #7
    Member
    Join Date
    Jan 2012
    Posts
    131
    Thanks
    17
    Thanked
    11 times in 10 posts

    Re: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    I have gone right off Creative due to there Driver issues, I had an expensive Creative card in my Windows XP machine and when Windows 7 came out the drivers were not forth coming and the sound card and amp never worked the same again, the said Card and amp are back in there box under the stairs, always used the sound off the motherboard since thinking that I would never fall into that trap again, a shame really as I thought Creative were a good company.

  9. #8
    Oh Crumbs.... Biscuit's Avatar
    Join Date
    Feb 2007
    Location
    N. Yorkshire
    Posts
    11,192
    Thanks
    1,392
    Thanked
    1,091 times in 833 posts
    • Biscuit's system
      • Motherboard:
      • MSI B450M Mortar
      • CPU:
      • AMD 2700X (Be Quiet! Dark Rock 3)
      • Memory:
      • 16GB Patriot Viper 2 @ 3466MHz
      • Storage:
      • 500GB WD Black
      • Graphics card(s):
      • Sapphire R9 290X Vapor-X
      • PSU:
      • Seasonic Focus Gold 750W
      • Case:
      • Lian Li PC-V359
      • Operating System:
      • Windows 10 x64
      • Internet:
      • BT Infinity 80/20

    Re: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    Which Xonar did you have? the quality on my D2X is fantastic but i don't have an XFI to compare it too!

    I would also like to point out Asus have already got drivers out for Win 8
    Last edited by Biscuit; 08-11-2012 at 11:39 AM.

  10. #9
    Member
    Join Date
    Jan 2012
    Posts
    131
    Thanks
    17
    Thanked
    11 times in 10 posts

    Re: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    I have the X-FI Elite Pro.

  11. #10
    Oh Crumbs.... Biscuit's Avatar
    Join Date
    Feb 2007
    Location
    N. Yorkshire
    Posts
    11,192
    Thanks
    1,392
    Thanked
    1,091 times in 833 posts
    • Biscuit's system
      • Motherboard:
      • MSI B450M Mortar
      • CPU:
      • AMD 2700X (Be Quiet! Dark Rock 3)
      • Memory:
      • 16GB Patriot Viper 2 @ 3466MHz
      • Storage:
      • 500GB WD Black
      • Graphics card(s):
      • Sapphire R9 290X Vapor-X
      • PSU:
      • Seasonic Focus Gold 750W
      • Case:
      • Lian Li PC-V359
      • Operating System:
      • Windows 10 x64
      • Internet:
      • BT Infinity 80/20

    Re: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    Quote Originally Posted by Geoff I View Post
    I have the X-FI Elite Pro.
    I was asking Dangel

  12. #11
    Member
    Join Date
    Jan 2012
    Posts
    131
    Thanks
    17
    Thanked
    11 times in 10 posts

    Re: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    Sorry Biscuit

  13. #12
    Lovely chap dangel's Avatar
    Join Date
    Aug 2005
    Location
    Cambridge, UK
    Posts
    8,385
    Thanks
    407
    Thanked
    449 times in 331 posts
    • dangel's system
      • Motherboard:
      • See My Sig
      • CPU:
      • See My Sig
      • Memory:
      • See My Sig
      • Storage:
      • See My Sig
      • Graphics card(s):
      • See My Sig
      • PSU:
      • See My Sig
      • Case:
      • See My Sig
      • Operating System:
      • Windows 10
      • Monitor(s):
      • See My Sig
      • Internet:
      • 60mbit Sky LLU

    Re: Creative working on Windows 8 drivers - pro titanium promised for 30th + others.

    Quote Originally Posted by Biscuit View Post
    Which Xonar did you have? the quality on my D2X is fantastic but i don't have an XFI to compare it too!

    I would also like to point out Asus have already got drivers out for Win 8
    I had the same one - I'm not saying it wasn't good, just that I preferred the XFI (and I missed crystalizer etc). I also had some bad experiences with the card being identified incorrectly as the PCI version (and worse experiences with scan's RMA which put an end to me using them as a supplier but that's another story) and the drivers not installing correctly. I could get it up and running by re-flashing the hardware id's on the card (eeek) but wasn't happy that something else wasn't awry.
    System 001: Maximus VII Formula, 4790k i7, RTX 2080ti FE (incoming), 16GIG Corsair Vengence DDR3 RAM CL9, Corsair HX1000, ROG SWIFT PG278Q , SSDs, Antec 1200 case, All watercooled. [main]
    System 002: A8 3850 APU, ASUS uATX FM1A75 MB, 4GB Corsair Vengeance DDR3, Corsair psu, OCZ Agility 3, 1TB F3, Dell 2001FP 20" LCD, £7's worth of 5.1 speakers (they rock) Windows 7 x64[wife/server]
    System 003: AsRock MB, APU, 8 GIG Corsair, Silverstone HTPC case, stock cooler, GT220 1gbDDR3, WD Green 3TB, Kingston 40gb SSD, MCE Remote, Panasonic 50" LCD (87BDX) via HDMI Windows 8.1.1 (32) [media centre]
    System 004: Asus UL50AT Intel Core 2 Duo,4GB, Intel Gen 2 80GB SSD, Win 8.1.1 x64 [no justification]
    System 005: HP Proliant N40L Microserver, 4x2TB drives, fan mod, Pico PSU mod, Win7 x86 [file server]
    System 006: Dell Optiplex 9010, i7, 8gb, 128gb Samsung 830 x 2 (boot and VM drive), 1TB WD HDD, ATI something, Windows 8.1.1 x64 RTM [work]


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •