Results 1 to 2 of 2

Thread: 'AT' commands not returning anything from Bluetooth module + Hello :D

  1. #1
    I R Toff Pandi! TAKTAK's Avatar
    Join Date
    Mar 2008
    Location
    Vergon6
    Posts
    7,410
    Thanks
    525
    Thanked
    995 times in 735 posts
    • TAKTAK's system
      • Motherboard:
      • MSI P55 GD65
      • CPU:
      • i7 860 @ 3.62GHz under an XSPC RASA
      • Memory:
      • 8GB 2133MHZ Corsair Vengeance
      • Storage:
      • 80GB Intel G2 SSD + 500GB + 640GB + 250GB WD AAKs + 2x1TB Samsung (1 Dead) + 500GB Maxtor
      • Graphics card(s):
      • EVGA SSC GTX260 216 55nm under an EK FC260 GTX
      • PSU:
      • Corsair HX620w
      • Case:
      • Corsair 800D, PA120.3 in the roof with 6 NF-P12s in Push-Pull
      • Operating System:
      • 7 x64
      • Monitor(s):
      • 24" Yuraku YV24WBH1 - SA-LTM240M2-L01 Panel & 32" LCD HDTV (1080i) Digihome tesco special :D
      • Internet:
      • 76Mb Fibre

    'AT' commands not returning anything from Bluetooth module + Hello :D

    Helloooooooooooooooo guys

    Firstly, long time no see, how are you all?

    Secondly, having a slight problem with a bluetooth module (HC-05) I had delivered yesterday which is going to be used on my final year project, basically:

    I've hooked it up to my USB - TTL ->

    Gnd - Gnd
    Vcc - 5v (Also tried 3.3v)
    Rx - Tx
    Tx - Rx (Also tried Tx - Tx, Rx - Rx incase the silkscreen was wrong...)

    Also tried Setting pin 34 to low, powering on, then setting high. And setting high and powering on (LED changes to long pulse), still nothing at any baud rate

    I've checked that the USB - TTL is pushing data out over Tx by making a loopback, which confirms that it is working and sending the commands, however, the Bluetooth module never responds to any input at any baud rate, the default is supposed to be 9600, but nada, not a thing, tried in PuTTY, HyperTerminal even HT Comm.

    I know there is a time-out on the command, which is why I tested with HT Comm as well as Copy/Pasting the command in from notepad. But still nothing, AT (with or without CRLF) never replies with anything.

    Some things I know are that the board works, a connection can be established through the default HC-05 name or the BD with 1234 as the password. But obviously, I want to change the details and up the baud rate for the project...

    Any ideas?

    TheAnimus, bsodmike? I can't think who else is likely to know...

    Edit: Sorted it, forced it into AT mode by holding pin 34 high (as before), then applying power to the board. Then pushing commands at a baud rate of 38400, 8, n, 1. With commands appended with CR+LF (\r\n).
    The part I was missing was in this mode for the AT commands, Rx - Rx and Tx - Tx
    Last edited by TAKTAK; 07-04-2013 at 10:40 AM.
    Post Counts and Other Rewards, Rules, Folding@Home, Fans: Push vs Pull vs Push-Pull, Corsair PSU OEMs.

    Quote Originally Posted by razer121 View Post
    Would you like me to enter you? it would be my pleasure
    TAKTAK.co.uk

  2. #2
    Registered User
    Join Date
    May 2014
    Posts
    1
    Thanks
    0
    Thanked
    0 times in 0 posts

    Re: 'AT' commands not returning anything from Bluetooth module + Hello :D

    Hi!
    I'm having the same problem with hc-05 - no responds to the AT commands; I tried your solution but still no response; I tried connecting tx-tx, rx-rx, even tx-rx but I get nothing. If you have any ideas that might help I would be grateful.
    (I tried with both USB-TTL and USB-RS232).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •