Results 1 to 10 of 10

Thread: Canon scanner issue

  1. #1
    Ghost of Hexus Present sammyc's Avatar
    Join Date
    Nov 2007
    Posts
    3,143
    Thanks
    671
    Thanked
    429 times in 350 posts

    Canon scanner issue

    Hooked up a canon canoscan to my laptop the other day, 2nd-hand & didn't come with software so downloaded the drivers from canon - all fine.

    Worked perfectly well til today, have made no changes, & suddenly getting 'waiting for TWAIN to complete' on screen and driver error issue if i continue with test scan. Any help gratefully received, the only person I could see at first look that had posted a similar issue elsewhere had no replies. :/
    Last edited by sammyc; 13-06-2015 at 07:25 PM.

  2. #2
    Pork & Beans Powerup Phage's Avatar
    Join Date
    May 2009
    Location
    Kent
    Posts
    6,130
    Thanks
    1,550
    Thanked
    590 times in 503 posts
    • Phage's system
      • Motherboard:
      • Asus Crosshair VI
      • CPU:
      • 1700x @ 3.9
      • Memory:
      • 16Gb Corsair LPX
      • Storage:
      • Samsung 960 512Gb + 2Tb Seagate SSHD
      • Graphics card(s):
      • EVGA 1080ti
      • PSU:
      • BeQuiet 850w
      • Case:
      • Fractal R4
      • Operating System:
      • W10 64
      • Monitor(s):
      • Agon Gsync

    Re: Canon scanner issue

    Well, sounds like a corrupt TWAIN driver
    http://kb.dynamsoft.com/questions/88...n+twain+source.
    Society's to blame,
    Or possibly Atari.

  3. #3
    Hardcore Tory, Lost Cause Ttaskmaster's Avatar
    Join Date
    Nov 2013
    Location
    Reading, UK
    Posts
    5,875
    Thanks
    282
    Thanked
    637 times in 533 posts
    • Ttaskmaster's system
      • Motherboard:
      • Asus X99-PRO
      • CPU:
      • i7 5960X o/c to 4.summat
      • Memory:
      • 32GB 3200MHz Crucial Ballistix Tactical Tracer RGB DDR4
      • Storage:
      • Samsung Evo 120GB and Seagate Baracuda 2TB
      • Graphics card(s):
      • Gigabyte G1 GTX980Ti
      • PSU:
      • EVGA Supernova G2 1000W
      • Case:
      • Phanteks Enthoo Luxe wiv perspex window
      • Operating System:
      • Win10 64 Home
      • Monitor(s):
      • Acer Predator XB270HU 1440 IPS GSync
      • Internet:
      • BT 0.7Mbps 'In The Sticks' version

    Re: Canon scanner issue

    ^ What Phage says.
    I did a quick search around, but this very thread was basically the top result.

    Uninst and reinst the drivers?

  4. #4
    Ghost of Hexus Present sammyc's Avatar
    Join Date
    Nov 2007
    Posts
    3,143
    Thanks
    671
    Thanked
    429 times in 350 posts

    Re: Canon scanner issue

    ^ thanks, I did try one round of reinstalling with no success but re-tried this morning in case I'd mucked a step up somewhere.

    I have: uninstalled device & drivers through device manager, also checked for & removed anything leftover from previously with pnputil, deleted & re-downloaded the drivers, reinstalled, & windows reports having installed them fine/device manager is happy. However still getting the waiting for twain to complete. It having worked ok to begin with, don't know why I can't even get it working at all now.

  5. #5
    Ghost of Hexus Present sammyc's Avatar
    Join Date
    Nov 2007
    Posts
    3,143
    Thanks
    671
    Thanked
    429 times in 350 posts

    Re: Canon scanner issue

    the plot thickens.. tried a driver from an alternative source without effect, however on further messing I've noticed that
    a) as ScanGear opens over the part of the screen where the twain message is, I have no proof it ever disappeared, I just assumed it had because of ScanGear opening successfully, and..
    b) on trying a 300dpi document it will scan successfully, on a 1200dpi it hangs. So maybe there is more going on than meets the eye. Though I've already successfully scanned a 1200 colour jpg.

    yep, and have done so again ok, so for some reason it's hanging at a 1200dpi doc and I've interpreted that as twain driver error fault. think again i guess.
    Last edited by sammyc; 13-06-2015 at 04:26 PM.

  6. #6
    No-one's Fanboi Thorsson's Avatar
    Join Date
    Nov 2004
    Location
    Neverneverland
    Posts
    2,749
    Thanks
    47
    Thanked
    93 times in 92 posts
    • Thorsson's system
      • Motherboard:
      • ASUS P8Z77-V PRO
      • CPU:
      • i5 3570k
      • Memory:
      • 2x8Gb Corsair Vengeance PC1866
      • Storage:
      • 256M4 SSD; 2Tb 7200RPM Barracuda; 2Tb Linkstation
      • Graphics card(s):
      • EVGA GTX970 SC
      • PSU:
      • Corsair HX650
      • Case:
      • Antec 300
      • Operating System:
      • Win10 64
      • Monitor(s):
      • Dell 2515H
      • Internet:
      • Fibre Optic 30Mb

    Re: Canon scanner issue

    Have you tried putting the USB cable in a different PC port?

    What did you change between it working and it not working?

    Can you try it with another computer?

  7. #7
    Ghost of Hexus Present sammyc's Avatar
    Join Date
    Nov 2007
    Posts
    3,143
    Thanks
    671
    Thanked
    429 times in 350 posts

    Re: Canon scanner issue

    No changes were made.

    Re-reading my first post I realise that I'm not actually getting the onscreen driver error message now, just the waiting for twain to complete, so reinstalling the drivers may have helped something. I'm thinking that the twain message was always there & is just superseded by Scan Gear opening, it's just that I hadn't tried a 1200dpi document so I jumped to conclusions there..

    I could try another laptop later today. Just a thought, I am using a basic A B data transfer cable as it didn't come with its own, not recommended but as all seemed fine I thought I'd chance it, might that be unwise?

  8. #8
    No-one's Fanboi Thorsson's Avatar
    Join Date
    Nov 2004
    Location
    Neverneverland
    Posts
    2,749
    Thanks
    47
    Thanked
    93 times in 92 posts
    • Thorsson's system
      • Motherboard:
      • ASUS P8Z77-V PRO
      • CPU:
      • i5 3570k
      • Memory:
      • 2x8Gb Corsair Vengeance PC1866
      • Storage:
      • 256M4 SSD; 2Tb 7200RPM Barracuda; 2Tb Linkstation
      • Graphics card(s):
      • EVGA GTX970 SC
      • PSU:
      • Corsair HX650
      • Case:
      • Antec 300
      • Operating System:
      • Win10 64
      • Monitor(s):
      • Dell 2515H
      • Internet:
      • Fibre Optic 30Mb

    Re: Canon scanner issue

    TBH with USB I always suspect the cable first and the USB port second. It's not the most robust interface. As any fule no.

  9. Received thanks from:

    sammyc (13-06-2015)

  10. #9
    Ghost of Hexus Present sammyc's Avatar
    Join Date
    Nov 2007
    Posts
    3,143
    Thanks
    671
    Thanked
    429 times in 350 posts

    Re: Canon scanner issue



    'Cannot get away with cuting corners in tech, chiz.'

    I will try a process of elimination as per your advice, and as I am currently able to scan basic pdf docs which is what I need atm, will mark as resolved pending developments. Thank you one & all.

  11. #10
    Hardcore Tory, Lost Cause Ttaskmaster's Avatar
    Join Date
    Nov 2013
    Location
    Reading, UK
    Posts
    5,875
    Thanks
    282
    Thanked
    637 times in 533 posts
    • Ttaskmaster's system
      • Motherboard:
      • Asus X99-PRO
      • CPU:
      • i7 5960X o/c to 4.summat
      • Memory:
      • 32GB 3200MHz Crucial Ballistix Tactical Tracer RGB DDR4
      • Storage:
      • Samsung Evo 120GB and Seagate Baracuda 2TB
      • Graphics card(s):
      • Gigabyte G1 GTX980Ti
      • PSU:
      • EVGA Supernova G2 1000W
      • Case:
      • Phanteks Enthoo Luxe wiv perspex window
      • Operating System:
      • Win10 64 Home
      • Monitor(s):
      • Acer Predator XB270HU 1440 IPS GSync
      • Internet:
      • BT 0.7Mbps 'In The Sticks' version

    Re: Canon scanner issue

    Quote Originally Posted by sammyc View Post
    so reinstalling the drivers may have helped something.
    Har har!!!
    Smug Mode engaged!

    Have you checked to see if the driver/software(s) can find any updates?
    It's weird, but some software is just the basic and it then needs an in-app update to the latest... kinda like Star Citizen, actually!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •