Page 1 of 2 12 LastLast
Results 1 to 16 of 24

Thread: Memory read error in HL2 Deathmatch..

  1. #1
    Senior Member
    Join Date
    Jan 2005
    Posts
    712
    Thanks
    0
    Thanked
    1 time in 1 post

    Memory read error in HL2 Deathmatch..

    Hi guys,


    My system has been running stable to a couple days, still @ stock speeds.

    I was in the middle of a HL2 deathmatch online, when it quit/crashed out to dekstop and gave a popup:
    Application popup: Half-Life 2 DM: hl2.exe - Application Error : The instruction at "0x2406dc59" referenced memory at "0x010811d4". The memory could not be "read".

    Click on OK to terminate the program
    Some reports on the net say it's a hardware/memory/cpu issue, others say it's an issue with XP, some say with HalfLife2 itself.

    Having benched and played with this new system solidly for about 9 hours over 2 evenings so far, and only had this one error in this one game, I'm not sure whether or not to worry.. What do ya think?


    Advice appreciated,

    S.

  2. #2
    Senior Member skuzgib's Avatar
    Join Date
    Oct 2004
    Location
    Bromsgrove, Worcestershire / Durham
    Posts
    1,917
    Thanks
    6
    Thanked
    1 time in 1 post
    Sound like it just a prob with HL2.

    Try reinstalling/ updating the game.

  3. #3
    Member
    Join Date
    Oct 2004
    Posts
    59
    Thanks
    0
    Thanked
    0 times in 0 posts
    i had that problem to, try to update the game if u still have problem then run memtest 86. when i had that problem it turned out my ram was faulty

  4. #4
    Member
    Join Date
    Jan 2005
    Posts
    104
    Thanks
    5
    Thanked
    0 times in 0 posts
    I have also noticed this problem, it has crashed out of HL2 with exactly the error you describe 5 - 6 occasions. Though I thought it was down to overclocking my system, whenever I got this error I would up the voltage for my memory and CPU, recently it hasn't crashed.

  5. #5
    Laird Of The Glen jimborae's Avatar
    Join Date
    Oct 2003
    Location
    I come from a land of plenty......not
    Posts
    3,286
    Thanks
    222
    Thanked
    320 times in 262 posts
    • jimborae's system
      • Motherboard:
      • Gigabyte Z77X-UD5H
      • CPU:
      • Core i7 2600K@4.5Ghz
      • Memory:
      • Mushkin RipJaws DDR3 16Gig
      • Storage:
      • 1x Samsung 850Evo 500Gb SSD, 1 x WG 640Gb
      • Graphics card(s):
      • VTX R9 290 watercooled
      • PSU:
      • XFX 850W Black Edition
      • Case:
      • Phantek Enthoo Prime
      • Operating System:
      • Windows 7 Pro
      • Monitor(s):
      • 2 xDell 24"
      • Internet:
      • Vodafone 70Mb
    A pc I built for a friend suffers this problem too, Halflife always crashes at the exact same place when trying to load a new level with that error.

    The specs are.

    Asus K8V Deluxe -
    Amd 64 3000 - S754
    XFX 6800gt
    Corsair Value Ram - 512mb

    At first I thought i was the ram as it failed memtest after about 5hrs, so that was rma'd but it still does it. Gonna try upgrading the board bios, reinstalling the game & upgrading the PSU tonight & see if that cures it.

  6. #6
    Senior Member
    Join Date
    Jan 2005
    Posts
    712
    Thanks
    0
    Thanked
    1 time in 1 post
    Okay, so I battered the system with a few more hours of gaming - Sims2, Doom3, HalfLife2 (Single Player this time, not deathmatch), and it ran fine for the rest of the evening.

    I'm not sure what my voltages should be, but they're stable (they're handled by AUTO on the DFI board). I am not running overclocked - since the error appeared, I have forced my RAM timings to 2-2-2-5 200-1T just in case the DFI was trying it tighter?!

    I've downloaded Prime95 and OCZmemtest86, but have not had a chance to leave either running for a long period of time yet - needed sleep and the PC's noisy
    I did run Prime95 on 1024 with 1024K fft's for half hour without issue, and CPU temp stayed below 50deg. I also ran 2 cycles of full MemTests over about half an hour or so, which completed without errors.

    This is looking to me (and I'm hoping) like an issue with HalfLife2 itself? No other application, benchmark or game over the last 4 days has even so much as hiccupped - but then, HL2 has only done it once - and that was in a deathmatch.

    I have VERY little running on the task bar as this is a fresh XPpro install.
    I wonder if I forgot to disable MSN Messenger or something silly, and something like that interrupted it? It was wierd. It wasn't a BSOD, or an OS crash and burn - it was HalfLife2.exe failing ungracefully, and Windows was perfectly happy underneath - didn't even have to reboot - surely that can't be a hardware issue?


    I'm concerned.
    S.

  7. #7
    Laird Of The Glen jimborae's Avatar
    Join Date
    Oct 2003
    Location
    I come from a land of plenty......not
    Posts
    3,286
    Thanks
    222
    Thanked
    320 times in 262 posts
    • jimborae's system
      • Motherboard:
      • Gigabyte Z77X-UD5H
      • CPU:
      • Core i7 2600K@4.5Ghz
      • Memory:
      • Mushkin RipJaws DDR3 16Gig
      • Storage:
      • 1x Samsung 850Evo 500Gb SSD, 1 x WG 640Gb
      • Graphics card(s):
      • VTX R9 290 watercooled
      • PSU:
      • XFX 850W Black Edition
      • Case:
      • Phantek Enthoo Prime
      • Operating System:
      • Windows 7 Pro
      • Monitor(s):
      • 2 xDell 24"
      • Internet:
      • Vodafone 70Mb
    Thats exactly the same symptons as my mates pc. Windows os runs fine underneath, its only the application that errors out, having just spoken to my friend he also added that photochop also crashed once with a similar memory error but that may have been something else.

    I would also add that his machine had been runing fine for the last 9 months prior to this.

  8. #8
    Senior Member
    Join Date
    Jan 2005
    Posts
    712
    Thanks
    0
    Thanked
    1 time in 1 post
    This is the Steam statement on the issue...
    It seems that many HL2 users on every gaming forum, all different hardware configs (largely @ stock clocking), have this exact same memory 'read' issue. Valve puts it down to 'corrupt cache files'.

    Wierd and annoying, but at least it suggests that it's NOT a general system stability issue..

    Hmm...


    S.

  9. #9
    Laird Of The Glen jimborae's Avatar
    Join Date
    Oct 2003
    Location
    I come from a land of plenty......not
    Posts
    3,286
    Thanks
    222
    Thanked
    320 times in 262 posts
    • jimborae's system
      • Motherboard:
      • Gigabyte Z77X-UD5H
      • CPU:
      • Core i7 2600K@4.5Ghz
      • Memory:
      • Mushkin RipJaws DDR3 16Gig
      • Storage:
      • 1x Samsung 850Evo 500Gb SSD, 1 x WG 640Gb
      • Graphics card(s):
      • VTX R9 290 watercooled
      • PSU:
      • XFX 850W Black Edition
      • Case:
      • Phantek Enthoo Prime
      • Operating System:
      • Windows 7 Pro
      • Monitor(s):
      • 2 xDell 24"
      • Internet:
      • Vodafone 70Mb
    Nice find I'll try that tonight & report back. Thanx

  10. #10
    Member
    Join Date
    Jan 2005
    Posts
    104
    Thanks
    5
    Thanked
    0 times in 0 posts
    Corrupt cache files eh? How do you solve this then?

  11. #11
    Senior Member
    Join Date
    Jan 2005
    Posts
    712
    Thanks
    0
    Thanked
    1 time in 1 post
    Quote Originally Posted by skb3
    Corrupt cache files eh? How do you solve this then?
    The Steam link (above) points you to a few url's to check you have the latest updates and to validate the source files etc, so they obviously recognise that there is an issue.

    I'm not counting out the possibilty that there may be a hardware issue here, but for soooo many people with different configs? I think not..

    Another site suggested that it is the Steam interface/application demanding attention and 'interfering' with the HL2.exe process, forcing a drop back to desktop in the middle of a game..


    Hmmm..
    S.

  12. #12
    Senior Member
    Join Date
    Jan 2005
    Posts
    712
    Thanks
    0
    Thanked
    1 time in 1 post
    Just got exactly the same error - same instruction id's as last time.. that's not a random memory error, that's gotta be an issue with the exe misbehaving, surely?

    It's pi***ng me off, I know that much, especially as I was third in a deathmatch of 12 at the time.. lol

    S.

  13. #13
    Banned myth's Avatar
    Join Date
    May 2004
    Location
    alone in life
    Posts
    2,553
    Thanks
    0
    Thanked
    0 times in 0 posts
    I get these 10 times a day! I just learned to live with them...

  14. #14
    Senior Member
    Join Date
    May 2004
    Location
    Stafford, West Midlands
    Posts
    642
    Thanks
    3
    Thanked
    0 times in 0 posts
    I get this error at specific points in the game and its really annoying!!

    This error occurs at two specific points both when the 'loading' box is there.

    This happens in the same places on my laptop and desktop (both with ATI cards) and its so dam annoying.

    As for BlueMagition commenting that it is a steam problem its not. I have a legit copy of the game but i used a steamless crack to see if steam was the culprit and its not! I still get the error message in the same place with or without steam.

    Also all my source files have been validated and are fine. Apparently HL2 is really really unhappy with the slightest instability in the RAM, but upping the voltage has no effect.

    I really wish Valve fixed this as its getting really annoying. I couldent play a start of a level because of this problem. My friend had to make a save game for me after the first 'loading' screen came up.

    Its SOOOO frustrating!

  15. #15
    Laird Of The Glen jimborae's Avatar
    Join Date
    Oct 2003
    Location
    I come from a land of plenty......not
    Posts
    3,286
    Thanks
    222
    Thanked
    320 times in 262 posts
    • jimborae's system
      • Motherboard:
      • Gigabyte Z77X-UD5H
      • CPU:
      • Core i7 2600K@4.5Ghz
      • Memory:
      • Mushkin RipJaws DDR3 16Gig
      • Storage:
      • 1x Samsung 850Evo 500Gb SSD, 1 x WG 640Gb
      • Graphics card(s):
      • VTX R9 290 watercooled
      • PSU:
      • XFX 850W Black Edition
      • Case:
      • Phantek Enthoo Prime
      • Operating System:
      • Windows 7 Pro
      • Monitor(s):
      • 2 xDell 24"
      • Internet:
      • Vodafone 70Mb
    Quote Originally Posted by Timmy!!!
    I get this error at specific points in the game and its really annoying!!

    This error occurs at two specific points both when the 'loading' box is there.

    This happens in the same places on my laptop and desktop (both with ATI cards) and its so dam annoying.

    As for BlueMagition commenting that it is a steam problem its not. I have a legit copy of the game but i used a steamless crack to see if steam was the culprit and its not! I still get the error message in the same place with or without steam.

    Also all my source files have been validated and are fine. Apparently HL2 is really really unhappy with the slightest instability in the RAM, but upping the voltage has no effect.

    I really wish Valve fixed this as its getting really annoying. I couldent play a start of a level because of this problem. My friend had to make a save game for me after the first 'loading' screen came up.

    Its SOOOO frustrating!
    Yep thats the position my mate is in. Can't go any further in the game cos of erroring on loading the level.

  16. #16
    Senior Member
    Join Date
    Jan 2005
    Posts
    712
    Thanks
    0
    Thanked
    1 time in 1 post
    Quote Originally Posted by Timmy!!!
    ...As for BlueMagition commenting that it is a steam problem its not...
    I didn't say it was a Steam problem, I merely pointed out that people on other forums had suggested it - but it seems your experience proves that wrong anyhow. It's a shame to hear other people are having the same issue - but comforting at the same time.

    It's looking more and more likely, in this case, to be an issue with the game or the source itself - rather than anything specific to hardware. Every other game and benchie I've run so far has <thankfully> been rocksolid - so I think it's Valve's fault...

    </rant off>


    S.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cheaters in HL2 Deathmatch
    By Ruggerbugger in forum Gaming
    Replies: 9
    Last Post: 25-02-2005, 03:17 PM
  2. SN41G2 V2 Memory problems
    By Borg in forum PC Hardware and Components
    Replies: 0
    Last Post: 13-02-2005, 10:14 PM
  3. HL2 deathmatch map packs
    By Ruggerbugger in forum Gaming
    Replies: 7
    Last Post: 22-01-2005, 05:11 PM
  4. Comedy HL2 deathmatch screenshots
    By Ruggerbugger in forum Gaming
    Replies: 2
    Last Post: 16-01-2005, 02:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •