Results 1 to 16 of 16

Thread: PSU smells like scaelectrix handle

  1. #1
    Get to da choppa Million's Avatar
    Join Date
    Oct 2005
    Location
    Cardiff
    Posts
    1,040
    Thanks
    72
    Thanked
    17 times in 16 posts
    • Million's system
      • Motherboard:
      • Asus P5G41T-M LX2/GB/SI LGA775 mATX
      • CPU:
      • Core2 Quad Q6600
      • Memory:
      • 6Gb Corsair DDR3
      • Storage:
      • 256Gb OCZ Octane SSD, 3Tb Seagate HDD, 250Gb Samsung HDD
      • Graphics card(s):
      • HD4850 1Gb
      • PSU:
      • xClio 700w
      • Case:
      • Fractal Design Arc Mini (watercooled)
      • Operating System:
      • Windows 7
      • Monitor(s):
      • LG 36" LED TV
      • Internet:
      • Virgin 60mb cable

    Unhappy PSU smells like scaelectrix handle

    Remember when you used to play with scaelectrix cars, the handle would start to smell kinda like an electrical burning smell, a bit like liquorice? Well when I turn on my comp the PSU smells like that. I can't imagine this is a good thing. Is it about to blow? It's an Enermax EG375AX-VE Noisetaker 370w btw.
    So, if this means it's shot - is it dangerous to run, or will the PSU protect the rest in case of fatal problem?
    - what new PSU of the same power comes recommended by the trusty Hexite community? I want something as quiet as they come, and sub-400w should do me fine, preferably braided and modular, and of course reliable

    thanks all

  2. #2
    Will work for beer... nichomach's Avatar
    Join Date
    Jul 2003
    Location
    Preston, Lancs
    Posts
    6,133
    Thanks
    527
    Thanked
    137 times in 98 posts
    • nichomach's system
      • Motherboard:
      • Gigabyte GA-870A-UD3
      • CPU:
      • AMD Phenom II X6 1055T 95W
      • Memory:
      • 16GB DR3
      • Storage:
      • 1x250GB Maxtor SATAII, 1x 400GB Hitachi SATAII
      • Graphics card(s):
      • Zotac GTX 1060 3GB
      • PSU:
      • Coolermaster 500W
      • Case:
      • Coolermaster Elite 430
      • Operating System:
      • Windows 10
      • Monitor(s):
      • Dell 20" TFT
      • Internet:
      • Virgin Media Cable
    Errrr...if it smells as though it's burning, I'd pull it, stat. As far as a replacement, I recently got a non-modular Tagan 480w which is quiet and well made. They do a 430W modular which looks pretty nice, but it's £55. http://www.scan.co.uk/Products/Produ...oductID=241237

  3. #3
    Get to da choppa Million's Avatar
    Join Date
    Oct 2005
    Location
    Cardiff
    Posts
    1,040
    Thanks
    72
    Thanked
    17 times in 16 posts
    • Million's system
      • Motherboard:
      • Asus P5G41T-M LX2/GB/SI LGA775 mATX
      • CPU:
      • Core2 Quad Q6600
      • Memory:
      • 6Gb Corsair DDR3
      • Storage:
      • 256Gb OCZ Octane SSD, 3Tb Seagate HDD, 250Gb Samsung HDD
      • Graphics card(s):
      • HD4850 1Gb
      • PSU:
      • xClio 700w
      • Case:
      • Fractal Design Arc Mini (watercooled)
      • Operating System:
      • Windows 7
      • Monitor(s):
      • LG 36" LED TV
      • Internet:
      • Virgin 60mb cable
    forgot to mention, PSU should have long mobo cable as I'm thinking about getting an Antec P180

  4. #4
    radix lecti dave87's Avatar
    Join Date
    Sep 2005
    Location
    England
    Posts
    12,806
    Thanks
    657
    Thanked
    931 times in 634 posts
    • dave87's system
      • Motherboard:
      • Asus
      • CPU:
      • i5 3470k under Corsair H80 WC
      • Memory:
      • 8gb DDR3
      • Storage:
      • 240gb SSD + 120gb SSD
      • Graphics card(s):
      • Asus HD7950
      • PSU:
      • XFX 600w Modular
      • Case:
      • Lian Li PC-A05FNB + Acoustipack
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • 2x Dell S2309W (1920x1080)
      • Internet:
      • BT Infinity Option 2
    The Seasonic I've got has been brilliant - S12500w, but they are bringing out a new revision of it and a modular one I do believe going by the model number - M12. Otherwise any of the offerings from tagan and the likes would probably be suitable

  5. #5
    Senior Member pr0p4g4nd4's Avatar
    Join Date
    Mar 2006
    Location
    Worcester, UK
    Posts
    1,439
    Thanks
    7
    Thanked
    1 time in 1 post

  6. #6
    Senior Member
    Join Date
    Jul 2005
    Posts
    1,545
    Thanks
    0
    Thanked
    0 times in 0 posts
    Seasonic, Enermax and Tagan are the brands you would want to look at.

    If I was you I would stay away from Hiper, as since their move to coolermasters factory the quality has dropped.

  7. #7
    Senior Member MantisCSS's Avatar
    Join Date
    Apr 2006
    Location
    Basingstoke
    Posts
    898
    Thanks
    0
    Thanked
    0 times in 0 posts
    personaly i would go hyper! that coz i have one and its awesome. havent noticed any bad quality.
    PowerColor HD 4850 512MB
    Gigabyte GA-EP35-DS3L iP35 Socket 775 8 channel audio ATX Motherboard
    Intel Core 2 Duo E7200 2.53GHz
    Coolermaster Centurion 5 All Black
    Corsair 450W VX 450W PSU
    Samsung SpinPoint F1 500GB

  8. #8
    Senior Member
    Join Date
    Jul 2005
    Posts
    1,545
    Thanks
    0
    Thanked
    0 times in 0 posts
    Just get the FSP BLUESTORM 500W, if anyone argues with me on this PSU I will cut your head off!






    Nah just kidding, it is a great psu!

  9. #9
    Senior Member Max Tractor's Avatar
    Join Date
    Jan 2006
    Posts
    1,248
    Thanks
    44
    Thanked
    41 times in 38 posts
    • Max Tractor's system
      • Motherboard:
      • Biostar TA890GXE
      • CPU:
      • 95w 1055T@x4-3.5Ghz-1.15v
      • Memory:
      • Samsung Green 30nm low voltage 2x4GB@1.26v
      • Storage:
      • Corsair 3 60GB-Sandisk Extreme 240GB
      • Graphics card(s):
      • 7850 2GB
      • PSU:
      • Seasonic SS-1050XM
      • Case:
      • Coolermaster elite 120(Modd)
      • Monitor(s):
      • BenQ EW2430
    FSP, might want to check the cable length, my 2 blue storms aint the longest

  10. #10
    Senior Member
    Join Date
    Jul 2005
    Location
    Birmingham
    Posts
    3,050
    Thanks
    248
    Thanked
    33 times in 31 posts
    • amjedm's system
      • Motherboard:
      • Asus A8N-Sli Premium
      • CPU:
      • Athlon X2 4200 S939 + Scythe Ninja rev A
      • Memory:
      • 2GB Corsair DDR PC3200
      • Storage:
      • Samsung T 160GB Sata in Scythe Quiet Box
      • Graphics card(s):
      • Nvidia 6600 256MB + Cooling Mod
      • PSU:
      • Enermax Noisetaker 485 (fanless) - lower chamber P180 fan doing the PSU cooling
      • Case:
      • P180 (modded - easier cable routing, front and rear grills cut)
      • Operating System:
      • XP Pro
      • Monitor(s):
      • LG 22" WTQ?
      • Internet:
      • O2 8MB (Standard)
    Quote Originally Posted by Max Tractor
    FSP, might want to check the cable length, my 2 blue storms aint the longest
    I'll second that. The 350 Bluestorm I installed in a PC probably had the shortest cables I've seen in a psu. Only managed to reach the ATX connector because of the 24pin to 20in cable.

  11. #11
    Nox
    Nox is offline
    Vorsprung durch Technik
    Join Date
    Oct 2003
    Location
    Hampshire
    Posts
    2,023
    Thanks
    2
    Thanked
    2 times in 2 posts
    • Nox's system
      • Motherboard:
      • Yes
      • CPU:
      • Yes
      • Memory:
      • Yes
      • Storage:
      • Yes
      • Graphics card(s):
      • Yes
      • PSU:
      • Yes
      • Case:
      • Yes
      • Monitor(s):
      • Yes
      • Internet:
      • Yes
    Back to the original question...

    My PC P&C PSU started doing that, ignored it a bit as I didnt know what it was, next day switched on computer - went make cup of coffee, came back to find smoke pouriung out the back!!! Rails were still at 1% tolerance tho - you would not believe the company i bought it off asked me to switch my computer back on....

    almost told em where to shove it, but figured it would be down to them...

    Nox

  12. #12
    asphinctersayswhat dannyboy83's Avatar
    Join Date
    Sep 2005
    Location
    Hamilton, Scotland
    Posts
    677
    Thanks
    3
    Thanked
    0 times in 0 posts
    Quote Originally Posted by Million
    Remember when you used to play with scaelectrix cars, the handle would start to smell kinda like an electrical burning smell, a bit like liquorice?
    Haha, that analogy made me laugh! I remember that burning smell from back in the day!

    Hope yer PC is ok too!

    My System: Coolermaster Centurion 5 (black) case, Intel E6750 Core2Duo, Tagan Easy-Con 530W, Asus P5B Deluxe WIFI, OCZ 2GB Kit (2x1GB) DDR2 800MHz/PC2-6400 CL 4-4-4-15 PLATINUM XTC, Samsung SpinPoint 200Gb SATA2 / 2 x Maxtor DiamondMax 10 200Gb SATA, 256Mb Sapphire ATI PCI-E X1950PRO, Creative X-Fi Xtreme 7.1, 19" Daewoo W9ZQ Black Widescreen TFT, 4Mb Virgin Cable Broadband (formerly Blueyonder) with Linksys WRT54GL Wireless-G and DD-WRT firmware.

  13. #13
    Gentoo Ricer
    Join Date
    Jan 2005
    Location
    Galway
    Posts
    10,954
    Thanks
    986
    Thanked
    940 times in 700 posts
    • aidanjt's system
      • Motherboard:
      • Asus Strix Z370-G
      • CPU:
      • Intel i7-8700K
      • Memory:
      • 2x8GB Corsiar LPX 3000C15
      • Storage:
      • 500GB Samsung 960 EVO
      • Graphics card(s):
      • EVGA GTX 970 SC ACX 2.0
      • PSU:
      • EVGA G3 750W
      • Case:
      • Fractal Design Define C Mini
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • 240mbps Virgin Cable
    Quote Originally Posted by Nox
    Back to the original question...

    My PC P&C PSU started doing that, ignored it a bit as I didnt know what it was, next day switched on computer - went make cup of coffee, came back to find smoke pouriung out the back!!! Rails were still at 1% tolerance tho - you would not believe the company i bought it off asked me to switch my computer back on....

    almost told em where to shove it, but figured it would be down to them...

    Nox
    Did you ask them if they were willing to pay the £10,000 odd for the data recovery experts to get the data back from your HD if the PSU shorts and zaps your HD?
    Quote Originally Posted by Agent View Post
    ...every time Creative bring out a new card range their advertising makes it sound like they have discovered a way to insert a thousand Chuck Norris super dwarfs in your ears...

  14. #14
    Nox
    Nox is offline
    Vorsprung durch Technik
    Join Date
    Oct 2003
    Location
    Hampshire
    Posts
    2,023
    Thanks
    2
    Thanked
    2 times in 2 posts
    • Nox's system
      • Motherboard:
      • Yes
      • CPU:
      • Yes
      • Memory:
      • Yes
      • Storage:
      • Yes
      • Graphics card(s):
      • Yes
      • PSU:
      • Yes
      • Case:
      • Yes
      • Monitor(s):
      • Yes
      • Internet:
      • Yes
    funnily enough, i had unplugged my hd's

    Nox

  15. #15
    Gentoo Ricer
    Join Date
    Jan 2005
    Location
    Galway
    Posts
    10,954
    Thanks
    986
    Thanked
    940 times in 700 posts
    • aidanjt's system
      • Motherboard:
      • Asus Strix Z370-G
      • CPU:
      • Intel i7-8700K
      • Memory:
      • 2x8GB Corsiar LPX 3000C15
      • Storage:
      • 500GB Samsung 960 EVO
      • Graphics card(s):
      • EVGA GTX 970 SC ACX 2.0
      • PSU:
      • EVGA G3 750W
      • Case:
      • Fractal Design Define C Mini
      • Operating System:
      • Windows 10 Pro
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • 240mbps Virgin Cable
    So would I lol.
    Quote Originally Posted by Agent View Post
    ...every time Creative bring out a new card range their advertising makes it sound like they have discovered a way to insert a thousand Chuck Norris super dwarfs in your ears...

  16. #16
    Almost in control. autopilot's Avatar
    Join Date
    Dec 2004
    Location
    Region 2
    Posts
    4,071
    Thanks
    51
    Thanked
    12 times in 11 posts
    Correct me if i am wrong, but that smell is caused by Oxidization.

    Some products can make that smell simply because they are new. But it can indicate a short circuit or overheating of certain componants. I would definatly get it RMA'd.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PSU Died!!!
    By Matt1eD in forum PC Hardware and Components
    Replies: 9
    Last Post: 06-09-2005, 01:35 AM
  2. Major Upgrade - Can the PSU handle it?
    By Wyoming in forum PC Hardware and Components
    Replies: 26
    Last Post: 29-07-2005, 08:11 PM
  3. Silverstone 0dB Fanless PSU
    By Carvahlo in forum Reader Reviews
    Replies: 6
    Last Post: 21-10-2004, 09:12 AM
  4. Case and Psu matching
    By mr_anderson187 in forum PC Hardware and Components
    Replies: 3
    Last Post: 09-08-2004, 11:42 PM
  5. Can the standard PSU handle a 9800pro?
    By menthel in forum PC Hardware and Components
    Replies: 7
    Last Post: 30-06-2004, 02:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •