hmmm got my new psu and hdd all working fine but untill i plug it all in and boot up and it tells me my 160gb current ide weston digi hdd isnt there:| after hours of messing around and even trying to the old psu i find that it is working... BUT in my OTHER MACHINE:| WTF is going on:S then it tried to tell me the other weston wasnt working when again both working flawlessly on this i ended up getting my spare 200gb maxtor and cloning the 2 partitions on the 160gb western and cloning it to the 200gb maxtor.... then it doesn't want to detect that even though it did when the other was playing up... AGAIN all working fine in this machine WTF is going on is my mobo fk'ed or?
i've been trying all night and day and haven't had much sleep and its starting to piss me off that i've just spend 180quid and now i cant use it...
oh and btw yeah ive tried default settings and resetting the CMOS ... MANY TIMES! and yeah jumpers are right.grrrr someone help me this mobo's 60quid at the cheapest "USED!:O" so i dont really want to fork out just over half what i paid for a 2nd hand one...
spec is:
asus a7n8x-e deluxe
512mb corsair xmx3200pro (with the 18led heatsink)
2x512mb GeIL value select
160gb WD hdd (being stupid)
200gb MAXTOR (now also being stupid)
320gb WD (that also now wont detect)
320gb WD Sata (detected)
320gb WD Sata (detected)
Tagan Dual Engine 500w blah blah blah.

so basically WHY is it doing this:S it litterally was running the drives that have gone wierd the second before installing new psu and sata drive:S
i really dont want to buy another one to be honest. but if someone will sell me one or the abit nf7s aquivalent for around 35quid with shipping to uk?otherwise i have no idea what to also had a bios update ages ago but i doubt they'd have made a new one and see no reason to upgrade when it was running that before:S