Results 1 to 3 of 3

Thread: System not turning on

  1. #1
    Member
    Join Date
    Sep 2013
    Posts
    150
    Thanks
    34
    Thanked
    9 times in 6 posts
    • theanalyzer's system
      • Motherboard:
      • ASUS M5A99X Evo R2.0
      • CPU:
      • AMD FX-8350
      • Memory:
      • Corsair Vengeance 16GB (2x8) 1600Mhz
      • Storage:
      • WD Green 1TB
      • Graphics card(s):
      • ASUS ROG Matrix 7970
      • PSU:
      • Coolermaster V550S
      • Case:
      • CM Storm Stryker
      • Operating System:
      • Windows 7
      • Monitor(s):
      • BenQ XL2411T

    System not turning on

    So, I finally get a PSU replacement after TWO weeks -.-

    I plug it in, turn on the PSU switch, all lights green on mobo and gfx card.

    Press button. Nothing happens. How can i tell if its a psu problem or some bad connection (between power switch and mobo)

    Is there any way to check if the PSU is working, like attaching a fan to it doing some kinda pin trick. I mean the lights turn on, on the motherboard, so its providing power, but system isnt turning on.
    Last edited by theanalyzer; 24-12-2013 at 12:59 AM.

  2. #2
    Banhammer in peace PeterB kalniel's Avatar
    Join Date
    Aug 2005
    Posts
    30,929
    Thanks
    1,843
    Thanked
    3,354 times in 2,696 posts
    • kalniel's system
      • Motherboard:
      • Gigabyte Z390 Aorus Ultra
      • CPU:
      • Intel i9 9900k
      • Memory:
      • 32GB DDR4 3200 CL16
      • Storage:
      • 1TB Samsung 970Evo+ NVMe
      • Graphics card(s):
      • nVidia GTX 1060 6GB
      • PSU:
      • Seasonic 600W
      • Case:
      • Cooler Master HAF 912
      • Operating System:
      • Win 10 Pro x64
      • Monitor(s):
      • Dell S2721DGF
      • Internet:
      • rubbish

    Re: System not turning on

    Sounds like the case switch isn't connected properly. You could short the power on jumpers manually to bypass the case switch. If that doesn't work, you can test the PSU by removing the motherboard cable and manually shorting pin 14 and 15/16/17: http://www.techpowerup.com/articles/other/22 - that'll just turn the PSU on proper so you can check the fan spins etc.

  3. Received thanks from:

    theanalyzer (23-12-2013)

  4. #3
    Member
    Join Date
    Sep 2013
    Posts
    150
    Thanks
    34
    Thanked
    9 times in 6 posts
    • theanalyzer's system
      • Motherboard:
      • ASUS M5A99X Evo R2.0
      • CPU:
      • AMD FX-8350
      • Memory:
      • Corsair Vengeance 16GB (2x8) 1600Mhz
      • Storage:
      • WD Green 1TB
      • Graphics card(s):
      • ASUS ROG Matrix 7970
      • PSU:
      • Coolermaster V550S
      • Case:
      • CM Storm Stryker
      • Operating System:
      • Windows 7
      • Monitor(s):
      • BenQ XL2411T

    Re: System not turning on

    Ok, took it out and its working now.

    The problem was the graphics card 2x6 pins. One of the 6 pin was reversed eek.

    It was causing the psu not to turn on.
    Last edited by theanalyzer; 24-12-2013 at 12:57 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •