Results 1 to 2 of 2

Thread: MSI motherboard 'dead' after BIOS update

  1. #1
    Senior Member Bonebreaker777's Avatar
    Join Date
    Dec 2012
    Location
    Herts, UK
    Posts
    2,004
    Thanks
    46
    Thanked
    190 times in 177 posts
    • Bonebreaker777's system
      • Motherboard:
      • MSI H97I AC
      • CPU:
      • Xeon 1225 v3 + Freezer 11 L
      • Memory:
      • 2 x 4GB 1600Mhz 1T-8-8-8-20 1.35V Crucial BallistiX Tactical VLP
      • Storage:
      • 128GB CRUCIAL MX100///XPEnology server + 3 x WD Purple 3TB
      • Graphics card(s):
      • Intel HD 4600
      • PSU:
      • be quiet! L8 300W PSU BN220
      • Case:
      • Cooler Master Elite 120
      • Operating System:
      • Windows 10 Pro 64bit
      • Monitor(s):
      • Samsung SyncMaster 226BW
      • Internet:
      • Virgin 100Mb

    MSI motherboard 'dead' after BIOS update

    As per title.

    Not sure how or what. Installed MSI Live. Located the latest BIOS for my motherboard (MSI Z87I AC). Seen the PC restart, seen the progress bar to go to 100%, then a restart and bum. No reaction. Turns on but nothing on the screen. No beep. No 'num lock' feedback on the keyboard. Unplugged everything but the PCU, CPU & 1 x RAM module. Resetted the BIOS. Nothing.

    So I initiated the RMA procedure via the Scan website (or rather the technical support ticket).

    The motherboard (plus all the bits which were with it) is packed.

    Should I do anything else?

  2. #2
    Senior Member Bonebreaker777's Avatar
    Join Date
    Dec 2012
    Location
    Herts, UK
    Posts
    2,004
    Thanks
    46
    Thanked
    190 times in 177 posts
    • Bonebreaker777's system
      • Motherboard:
      • MSI H97I AC
      • CPU:
      • Xeon 1225 v3 + Freezer 11 L
      • Memory:
      • 2 x 4GB 1600Mhz 1T-8-8-8-20 1.35V Crucial BallistiX Tactical VLP
      • Storage:
      • 128GB CRUCIAL MX100///XPEnology server + 3 x WD Purple 3TB
      • Graphics card(s):
      • Intel HD 4600
      • PSU:
      • be quiet! L8 300W PSU BN220
      • Case:
      • Cooler Master Elite 120
      • Operating System:
      • Windows 10 Pro 64bit
      • Monitor(s):
      • Samsung SyncMaster 226BW
      • Internet:
      • Virgin 100Mb

    Re: MSI motherboard 'dead' after BIOS update

    May I ask to be moved to 'Scan.care@Hexus', please? I believe my post is more relevant there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •