Results 1 to 4 of 4

Thread: Possible RMA, am unsure

  1. #1
    A shadowy flight. MSIC's Avatar
    Join Date
    Oct 2005
    Location
    London/Herts
    Posts
    3,413
    Thanks
    394
    Thanked
    229 times in 168 posts
    • MSIC's system
      • Motherboard:
      • ASRock H170M-ITX
      • CPU:
      • Core i5 6500
      • Memory:
      • 2 x 4GB Corsair Veng DDR4 2666
      • Storage:
      • 240GB SSD (boot) +1TB Samsung F3
      • Graphics card(s):
      • ASUS GeForce 750Ti
      • PSU:
      • Silverstone 450W ST455F
      • Case:
      • Silverstone SG06-450
      • Operating System:
      • Win10
      • Monitor(s):
      • Dell S2309W
      • Internet:
      • PlusNet FiberTTC

    Possible RMA, am unsure

    Hi Scan guys, mid last week i bought this product:
    Jou-Jye VENUS SU2S
    as a part of a larger order (including the hard drive).
    Having used external hard drives quite a few times before, i had imagined that you plug it in, windows spends a few seconds detecting it, mounts it accordingly, and voila.
    Unfortunately, although i can see it in device manager, i get no actual drive letter appearing in 'My Computer' (under XP).
    I have tried this on my main rig (see to the left here), plus 2 seperate laptops (one a P3, one a Centrino), and the same all round.
    Even after reboots, still does not come up.
    I have also tried the installation disc that comes with, still no joy.

    Am i missing something here? I just want a quick 'plug-in-and-work' job.

    PS It comes with the 'Y' USB lead - you plug the 'mini' USB end into the external hard drive, and the 2 normal ones into the computer / laptop to ensure it draws enough power, which i have checked are plugged in correctly. Another external hard drive that i have does work with all 3 of the above computers (that is a 40 Gig PATA one but that shouldnt make a difference i suppose, and it also uses a Y USB cable, but full sized to the hard drive).
    I'm commenting on an internet forum. Your facts hold no sway over me.
    - Another poster, from another forum.

    System as shown, plus: Microsoft Wireless mobile 4000 mouse and Logitech Illuminated keyboard.
    Sennheiser RS160 wireless headphones. Creative Gigaworks T40 SII. My wife.
    My Hexus Trust

  2. #2
    Scan Computers - Tech pands@scan's Avatar
    Join Date
    Jan 2006
    Location
    Manc land!
    Posts
    843
    Thanks
    3
    Thanked
    10 times in 10 posts

    Re: Possible RMA, am unsure

    If you havnt already, try this..

    Control Panel > Admin Tools > Computer Management > Disk Management

    Find your drive, format it and assign a letter (or just assign a letter if its formatted)
    pands.goggles


  3. Received thanks from:

    MSIC (23-09-2008)

  4. #3
    Senior[ish] Member Singh400's Avatar
    Join Date
    Jun 2008
    Posts
    2,931
    Thanks
    136
    Thanked
    310 times in 247 posts

    Re: Possible RMA, am unsure

    You might need to "activate" it in Disk Management.

  5. Received thanks from:

    MSIC (23-09-2008)

  6. #4
    A shadowy flight. MSIC's Avatar
    Join Date
    Oct 2005
    Location
    London/Herts
    Posts
    3,413
    Thanks
    394
    Thanked
    229 times in 168 posts
    • MSIC's system
      • Motherboard:
      • ASRock H170M-ITX
      • CPU:
      • Core i5 6500
      • Memory:
      • 2 x 4GB Corsair Veng DDR4 2666
      • Storage:
      • 240GB SSD (boot) +1TB Samsung F3
      • Graphics card(s):
      • ASUS GeForce 750Ti
      • PSU:
      • Silverstone 450W ST455F
      • Case:
      • Silverstone SG06-450
      • Operating System:
      • Win10
      • Monitor(s):
      • Dell S2309W
      • Internet:
      • PlusNet FiberTTC

    Re: Possible RMA, am unsure

    Thanks very much, you know when you're kicking yourself for something obvious.....
    I'm commenting on an internet forum. Your facts hold no sway over me.
    - Another poster, from another forum.

    System as shown, plus: Microsoft Wireless mobile 4000 mouse and Logitech Illuminated keyboard.
    Sennheiser RS160 wireless headphones. Creative Gigaworks T40 SII. My wife.
    My Hexus Trust

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RMA Status
    By Logitech in forum SCAN.care@HEXUS
    Replies: 2
    Last Post: 16-07-2008, 08:12 PM
  2. Scan not accepting my RMA! :@
    By SCOTTBALL in forum SCAN.care@HEXUS
    Replies: 37
    Last Post: 20-02-2008, 11:44 PM
  3. RMA refund money - where is it!
    By DarthSpark in forum SCAN.care@HEXUS
    Replies: 2
    Last Post: 23-08-2007, 12:37 PM
  4. RMA - Getting stupid now
    By GFiSH in forum SCAN.care@HEXUS
    Replies: 1
    Last Post: 02-11-2006, 12:47 PM
  5. Advanced RMA
    By GoNz0 in forum SCAN.care@HEXUS
    Replies: 18
    Last Post: 22-06-2006, 06:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •