Results 1 to 3 of 3

Thread: Fried mobo

  1. #1
    Senior Member
    Join Date
    Mar 2006
    Location
    Cambridge, UK
    Posts
    346
    Thanks
    17
    Thanked
    28 times in 23 posts
    • barker967's system
      • Motherboard:
      • Gigabyte Z77X-UD5H
      • CPU:
      • IvyBridge I7 3770k @ 4.5ghz
      • Memory:
      • 16gb Mushkin Blackline 1600mhz
      • Storage:
      • 1TB Samsung F3 / 128Gb Crucial M4 OS
      • Graphics card(s):
      • Asus Direct cu2 7950TOP
      • PSU:
      • XFX 650watt modular
      • Case:
      • Coolermaster HAF 922
      • Operating System:
      • windows 7 home premium
      • Monitor(s):
      • Dell U2311H
      • Internet:
      • Plusnet up to 8 meg.

    Fried mobo

    Can one of you fine gentlemen from scan be of assistance.

    Just over a year ago i purchased an msi k8neo platinum s754 mobo from scan, all was well for over a year then one evening during a horrendous game of battlefield 2 a huge plume of smoke came out from the back of my pc and stank the whole house out.

    On later investigation i found out that the mobo had decided to fry itself, melted the board between the front cd in connectors and the firewire-neither of which was being used.
    Anyway contacted scan for an rma which they promptly gave me and sent the board back, only to be told a couple of days later that they had refused the claim, the reason was they couldn`t determine the cause so they weren`t going to exhcange it, but they said they could send it back to the manufacturer and see if they would exchange it on my behalf. Sent back the authorisation and waited.

    Well this was over 2 weeks ago and i have heard absolutely nothing from scan about what is happening with my board, in the meantime i have had to purchase another board so i can use my computer.

    I have spent a lot of money with scan over the last couple of years and would appreciate if someone would look into this for me, i can supply the rma and invoice numbers via pm.

    Many thanks
    Ben. (sorry its so long and winded)

  2. #2
    Moderator Philipp's Avatar
    Join Date
    Sep 2005
    Location
    Manchester
    Posts
    1,150
    Thanks
    176
    Thanked
    87 times in 75 posts
    • Philipp's system
      • Motherboard:
      • ROG Impact
      • CPU:
      • Intel i7 4770K
      • Memory:
      • 16GB Corsair DDR3
      • Storage:
      • 500GB Samsung Evo
      • Graphics card(s):
      • EVGA 980Ti
      • PSU:
      • Corsair 550W RMX
      • Case:
      • Fractal Design Node
      • Operating System:
      • Windows 10 Home
      • Monitor(s):
      • 27" ROG Swift
      • Internet:
      • Virgin 20Mb
    Please PM me your invoice number and i will look into the issue for you,

    Best Regards

  3. #3
    Senior Member
    Join Date
    Mar 2006
    Location
    Cambridge, UK
    Posts
    346
    Thanks
    17
    Thanked
    28 times in 23 posts
    • barker967's system
      • Motherboard:
      • Gigabyte Z77X-UD5H
      • CPU:
      • IvyBridge I7 3770k @ 4.5ghz
      • Memory:
      • 16gb Mushkin Blackline 1600mhz
      • Storage:
      • 1TB Samsung F3 / 128Gb Crucial M4 OS
      • Graphics card(s):
      • Asus Direct cu2 7950TOP
      • PSU:
      • XFX 650watt modular
      • Case:
      • Coolermaster HAF 922
      • Operating System:
      • windows 7 home premium
      • Monitor(s):
      • Dell U2311H
      • Internet:
      • Plusnet up to 8 meg.
    many thanks, have sent and received a pm from wesleyaldred about this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PC problems, posssibly mobo or psu. Please help me.
    By Meep-duh-Clone in forum Help! Quick Relief From Tech Headaches
    Replies: 0
    Last Post: 08-02-2006, 03:35 AM
  2. ASUS A8NE Mobo problem
    By stephent3 in forum SCAN.care@HEXUS
    Replies: 9
    Last Post: 29-11-2005, 07:09 PM
  3. Removing the backplate on Asus Mobo
    By Muddy in forum PC Hardware and Components
    Replies: 2
    Last Post: 21-06-2005, 12:39 AM
  4. mobo for a SS51G case
    By blue..matt in forum PC Hardware and Components
    Replies: 0
    Last Post: 01-02-2005, 08:19 PM
  5. Think I just fried my mobo...
    By shredisn@tdead in forum PC Hardware and Components
    Replies: 2
    Last Post: 29-04-2004, 11:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •