Results 1 to 7 of 7

Thread: Scan - need help with mobo - rma possible?

  1. #1
    The Big V vrykyl's Avatar
    Join Date
    Mar 2005
    Location
    Staffordshire
    Posts
    1,033
    Thanks
    140
    Thanked
    51 times in 41 posts
    • vrykyl's system
      • Motherboard:
      • Asus Maximus IV Extreme-Z (Z68)
      • CPU:
      • Intel i7 2700k @ 5ghz 1.38v (Dark Rock Pro)
      • Memory:
      • 16gb Kingston HyperX Genesis
      • Storage:
      • 256gb Crucial M4 SSD, 2x 2tb Samsung F4
      • Graphics card(s):
      • SLI 2gb MSI gtx 670 PE-OC (x2)
      • PSU:
      • Corsair AX 860w
      • Case:
      • Corsair 600T White Limited Edition
      • Operating System:
      • Windows 8.1 x64
      • Monitor(s):
      • 24" Dell U2410
      • Internet:
      • Plusnet 80mb fibre (80/20)

    Scan - need help with mobo - rma possible?

    Ok kindly folks at Scan, I am currently having some major problems with my Asus p5wdg2-ws mobo - and Iv no idea what to do or if I can rma this board to you. I will be open and honest about everything and hope you can consider all the facts and give me a reply.

    Since shelling out £187.12 in February this year for an Asus P5wDG2-WS, I have had nothing but endless problems with it. My issues have been as follows:

    Straight out of the box I was unable to insert my graphics card because of the northbridge sink - this was remedied by removing 4 of the fins on the northbridge heatsink (thus i think you probably wont take it back), however I mounted a 40mm fan over the nb sink as it was woefully inadequate anyway.

    Whilst that wasnt a major headache, the onboard lan has NEVER worked properly - to date my 2nd lan port still doesnt function properly...I can only use one port at a time, not both at once.

    RAID simply doesnt work properly at all - Asus never got around to fixing it.

    Now to my new issues that brought me to create this thread:

    For some reason now any pci cards I put in the system simply dont work....only card I can get to work sometimes is my audidgy2 ZS... xfi is a no go, wireless card doesnt work, NIC card doesnt work either.... so basically I cant use pci slots on it....very usefull.

    every few days the mobo gives a ram memory error on boot...I now have to swap the sticks out to the other two slots to get it to work again (for about 2 days then they have to go back again) - both sticks are fine tho...will run 24/7 in other mobos.

    I cant restart the mobo any more. If i shut down my pc and turn it straight back on all is fine...if i restart the bios resets itself.


    So what can I do scan? Iv spent £187 on a mobo that has been an absolute nightmare, and iv finally had enough. Will you take it back for rma replacement? Im not inclined to want another one either...if you did take it back would I be able to get a board of equal value? hell id even happily take a cheaper board and say you can keep the extra cash...I just want a mobo I can trust

    Many thanks whatever the outcome

    V

  2. #2
    Retail Sales Manager Chris P's Avatar
    Join Date
    Apr 2006
    Posts
    5,699
    Thanks
    767
    Thanked
    515 times in 411 posts
    Please log a Returns query via the link below so we can look into this for you.

    http://web6.scan.co.uk/Support/Query.ASP?QueryType=R

    Regards

  3. #3
    The Big V vrykyl's Avatar
    Join Date
    Mar 2005
    Location
    Staffordshire
    Posts
    1,033
    Thanks
    140
    Thanked
    51 times in 41 posts
    • vrykyl's system
      • Motherboard:
      • Asus Maximus IV Extreme-Z (Z68)
      • CPU:
      • Intel i7 2700k @ 5ghz 1.38v (Dark Rock Pro)
      • Memory:
      • 16gb Kingston HyperX Genesis
      • Storage:
      • 256gb Crucial M4 SSD, 2x 2tb Samsung F4
      • Graphics card(s):
      • SLI 2gb MSI gtx 670 PE-OC (x2)
      • PSU:
      • Corsair AX 860w
      • Case:
      • Corsair 600T White Limited Edition
      • Operating System:
      • Windows 8.1 x64
      • Monitor(s):
      • 24" Dell U2410
      • Internet:
      • Plusnet 80mb fibre (80/20)
    Thanks! Query submitted...I really hope something can be done about this mobo...half its selling features were never fully implemented by asus...its been nothing but buggy and unreliable...which for a workstation is just what I dont need!

  4. #4
    The Big V vrykyl's Avatar
    Join Date
    Mar 2005
    Location
    Staffordshire
    Posts
    1,033
    Thanks
    140
    Thanked
    51 times in 41 posts
    • vrykyl's system
      • Motherboard:
      • Asus Maximus IV Extreme-Z (Z68)
      • CPU:
      • Intel i7 2700k @ 5ghz 1.38v (Dark Rock Pro)
      • Memory:
      • 16gb Kingston HyperX Genesis
      • Storage:
      • 256gb Crucial M4 SSD, 2x 2tb Samsung F4
      • Graphics card(s):
      • SLI 2gb MSI gtx 670 PE-OC (x2)
      • PSU:
      • Corsair AX 860w
      • Case:
      • Corsair 600T White Limited Edition
      • Operating System:
      • Windows 8.1 x64
      • Monitor(s):
      • 24" Dell U2410
      • Internet:
      • Plusnet 80mb fibre (80/20)
    Can anyone confirm today if my rma request was received? as I didnt get a confirmation email and it doesnt show in my account page....

    cheers!

  5. #5
    Registered User
    Join Date
    Sep 2003
    Location
    Bolton
    Posts
    1,478
    Thanks
    168
    Thanked
    90 times in 74 posts
    can you PM me your invoice number, although I must stress that due to your original post confirming you physically removed fins from the item, this would void the warranty.

  6. #6
    The Big V vrykyl's Avatar
    Join Date
    Mar 2005
    Location
    Staffordshire
    Posts
    1,033
    Thanks
    140
    Thanked
    51 times in 41 posts
    • vrykyl's system
      • Motherboard:
      • Asus Maximus IV Extreme-Z (Z68)
      • CPU:
      • Intel i7 2700k @ 5ghz 1.38v (Dark Rock Pro)
      • Memory:
      • 16gb Kingston HyperX Genesis
      • Storage:
      • 256gb Crucial M4 SSD, 2x 2tb Samsung F4
      • Graphics card(s):
      • SLI 2gb MSI gtx 670 PE-OC (x2)
      • PSU:
      • Corsair AX 860w
      • Case:
      • Corsair 600T White Limited Edition
      • Operating System:
      • Windows 8.1 x64
      • Monitor(s):
      • 24" Dell U2410
      • Internet:
      • Plusnet 80mb fibre (80/20)
    Hey Wesley, do you still want me to pm you my number? as its been confirmed by email that yup, cos I voided the warranty im out o' luck :/
    time to start saving for a new mobo, as asus tech support is the worst ever....

  7. #7
    Registered User
    Join Date
    Sep 2003
    Location
    Bolton
    Posts
    1,478
    Thanks
    168
    Thanked
    90 times in 74 posts
    vrykyl,

    Yes could you please PM me the number, I understand the item will be warranty void, but I would like to take a quick look at the OLQ.

    Wesley

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Scan strike again!
    By Speedo in forum SCAN.care@HEXUS
    Replies: 15
    Last Post: 25-08-2006, 05:31 PM
  2. Fried mobo
    By barker967 in forum SCAN.care@HEXUS
    Replies: 2
    Last Post: 19-04-2006, 04:49 PM
  3. Scan far too good!!!!
    By ExceededGoku in forum SCAN.care@HEXUS
    Replies: 6
    Last Post: 08-03-2006, 10:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •