Have you tried wiring your laptop yet? It sounds like it's a wireless issue in my opinion.

Also, if you're only using one of your NIC's on your motherboard you can disable the one your're not...