Sounds like that needs a Raspberry Pi 4 conversion to bring it up to date :D