Page 2 of 2 FirstFirst 12
Results 17 to 19 of 19

Thread: PHP/MySQL What have I done wrong?

  1. #17
    Senior Member crazyfool's Avatar
    Join Date
    Jan 2008
    Posts
    761
    Thanks
    77
    Thanked
    38 times in 38 posts
    • crazyfool's system
      • Motherboard:
      • Striker Extreme
      • CPU:
      • Q6600
      • Memory:
      • OCZ 6400 2 x 2GB
      • Storage:
      • Samsung Spinpoint 500GB
      • Graphics card(s):
      • BFG 8800 GT OC 512MB
      • PSU:
      • Coolermaster Real Power Pro 850w
      • Case:
      • Coolermaster CM-690
      • Operating System:
      • XP, Vista, Windows 7 & Ubuntu
      • Monitor(s):
      • Samsung 2232BW

    Re: PHP/MySQL What have I done wrong?

    Well I'm pretty sure the id was tb but I'll double check that. Also the javascript runs on a button click so the page is fully loaded once it runs.

  2. #18
    PHP Geek Flash477's Avatar
    Join Date
    Dec 2008
    Location
    Devon
    Posts
    822
    Thanks
    51
    Thanked
    72 times in 65 posts

    Re: PHP/MySQL What have I done wrong?

    One way of debugging your code is as follows:

    Code:
    try {
    <<Your code goes here>>
    } catch (err) {
    alert(err);
    }

  3. #19
    Not a good person scaryjim's Avatar
    Join Date
    Jan 2009
    Location
    Manchester
    Posts
    15,158
    Thanks
    1,224
    Thanked
    2,278 times in 1,865 posts
    • scaryjim's system
      • Motherboard:
      • Dell Inspiron
      • CPU:
      • Core i5 8250U
      • Memory:
      • 1x 8GB DDR4 2400
      • Storage:
      • 128GB M.2 SSD + 1TB HDD
      • Graphics card(s):
      • Radeon R5 230
      • PSU:
      • Battery/Dell brick
      • Case:
      • Dell Inspiron 5570
      • Operating System:
      • Windows 10
      • Monitor(s):
      • 15" 1080p laptop panel

    Re: PHP/MySQL What have I done wrong?

    What happens after
    Code:
    var tbox = document.getElementById("tb").value;
    ? That is, what is *meant* to happen after that? As Flash says, one way to test things is to litter your code with alert(val) during testing - so in this case you could add a line after that that just says
    Code:
    alert(tbox);
    which will let you know if anything is being stored in tbox. If you posted up the rest of the code we might be able to spot something in it - it's very hard to bug fix from one line!

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ordered the wrong item by mistake
    By Ironbuket in forum SCAN.care@HEXUS
    Replies: 6
    Last Post: 04-06-2009, 10:51 AM
  2. scan support number? wrong order
    By looney in forum SCAN.care@HEXUS
    Replies: 16
    Last Post: 09-05-2008, 01:09 AM
  3. Connecting a battery the wrong way round?
    By AD-15 in forum General Discussion
    Replies: 4
    Last Post: 21-01-2008, 11:31 PM
  4. wireless keyboard displaying wrong characters
    By colincliff in forum Help! Quick Relief From Tech Headaches
    Replies: 4
    Last Post: 16-10-2007, 04:23 PM
  5. Windows xp repair gone wrong
    By jkh13 in forum Help! Quick Relief From Tech Headaches
    Replies: 3
    Last Post: 18-08-2005, 09:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •