Page 1 of 2 12 LastLast
Results 1 to 16 of 25

Thread: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

  1. #1
    Senior Member
    Join Date
    Mar 2015
    Location
    Lurking over a keyboard!
    Posts
    438
    Thanks
    216
    Thanked
    35 times in 33 posts
    • gupsterg's system
      • Motherboard:
      • Asus Maximus VII Ranger
      • CPU:
      • i5 4690K @ 4.9GHz
      • Memory:
      • Kingston HyperX Savage 2400Mhz 16GB
      • Storage:
      • Samsung 840 EVO 250GB + HGST 2TB
      • Graphics card(s):
      • Sapphire R9 Fury X
      • PSU:
      • Cooler Master V850
      • Case:
      • Silverstone Temjin 06 plus mods ;)
      • Operating System:
      • Win 7 Pro x64 / Win 10 Pro x64
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • TalkTalk VDSL

    English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    I usually use an ISO of my original Win 7 Pro x64 with slipstreamed SP1, but wanted an ISO from MS due to a freaky issue trying to install Win 7 in UEFI mode (see linked thread).

    I tried Firefox and IE11 on the site, my key is accepted, states eligible for Windows 7 Professional SP1 but no English language there .

    I have retail Windows 7 Pro, COA have English version written on it, I have invoice from big name UK etailer, should I be contacting MS Support?

    Is this another measure to force people to Windows 10!?
    i5 4690K @ 4.9GHz CPU@1.255v 4.4GHz Cache@1.10v - Archon SB-E X2 - Asus Maximus VII Ranger
    Kingston HyperX Savage 16GB@2400MHz 1T - Sapphire R9 Fury X (1145/545 Custom ROM, ~17.7K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850

    R7 1700@3.8GHz - Archon IB-E X2 - Asus Crosshair VI Hero - G.Skill Trident Z 3200MHz C14 - Sapphire Fury X (1145/545 Custom ROM, ~17.2K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850


  2. #2
    Registered+
    Join Date
    Feb 2010
    Location
    Cheshire
    Posts
    22
    Thanks
    0
    Thanked
    7 times in 5 posts

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    I just tried on the Microsoft Product Recovery Site with a Windows 7 Pro OEM key in FF (not Dell HP etc) and it accepted fine and offered me 32 or 64 bit download. So maybe it is an issue with your particular key thay you need to contact MS about.

  3. Received thanks from:

    gupsterg (05-12-2015)

  4. #3
    Senior Member
    Join Date
    Mar 2015
    Location
    Lurking over a keyboard!
    Posts
    438
    Thanks
    216
    Thanked
    35 times in 33 posts
    • gupsterg's system
      • Motherboard:
      • Asus Maximus VII Ranger
      • CPU:
      • i5 4690K @ 4.9GHz
      • Memory:
      • Kingston HyperX Savage 2400Mhz 16GB
      • Storage:
      • Samsung 840 EVO 250GB + HGST 2TB
      • Graphics card(s):
      • Sapphire R9 Fury X
      • PSU:
      • Cooler Master V850
      • Case:
      • Silverstone Temjin 06 plus mods ;)
      • Operating System:
      • Win 7 Pro x64 / Win 10 Pro x64
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • TalkTalk VDSL

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    Thanks for checking and posting .

    I will be contacting support, as I've paid for genuine I deserve it .

    And here's the shot of COA.



    It was a pre-order copy via eBuyer, found the invoice ready for Mondays conversation.
    i5 4690K @ 4.9GHz CPU@1.255v 4.4GHz Cache@1.10v - Archon SB-E X2 - Asus Maximus VII Ranger
    Kingston HyperX Savage 16GB@2400MHz 1T - Sapphire R9 Fury X (1145/545 Custom ROM, ~17.7K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850

    R7 1700@3.8GHz - Archon IB-E X2 - Asus Crosshair VI Hero - G.Skill Trident Z 3200MHz C14 - Sapphire Fury X (1145/545 Custom ROM, ~17.2K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850


  5. #4
    Registered+
    Join Date
    Feb 2010
    Location
    Cheshire
    Posts
    22
    Thanks
    0
    Thanked
    7 times in 5 posts

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    Should be ok from Ebuyer, but the ROW on the COA is a little confusing, maybe as it was a pre-order - some peple say it means Rest Of World. MS are usually pretty good on the phone, once you get to the right person.

  6. Received thanks from:

    gupsterg (06-12-2015)

  7. #5
    Senior Member
    Join Date
    Mar 2015
    Location
    Lurking over a keyboard!
    Posts
    438
    Thanks
    216
    Thanked
    35 times in 33 posts
    • gupsterg's system
      • Motherboard:
      • Asus Maximus VII Ranger
      • CPU:
      • i5 4690K @ 4.9GHz
      • Memory:
      • Kingston HyperX Savage 2400Mhz 16GB
      • Storage:
      • Samsung 840 EVO 250GB + HGST 2TB
      • Graphics card(s):
      • Sapphire R9 Fury X
      • PSU:
      • Cooler Master V850
      • Case:
      • Silverstone Temjin 06 plus mods ;)
      • Operating System:
      • Win 7 Pro x64 / Win 10 Pro x64
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • TalkTalk VDSL

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    Cheers , I also suspect ROW means Rest Of World, but still think English option should have been available as that is on COA. The installation DVD defaults to English (US) location US, anyhow will be defo ringing MS as currently I prize my Win 7 license highly .
    i5 4690K @ 4.9GHz CPU@1.255v 4.4GHz Cache@1.10v - Archon SB-E X2 - Asus Maximus VII Ranger
    Kingston HyperX Savage 16GB@2400MHz 1T - Sapphire R9 Fury X (1145/545 Custom ROM, ~17.7K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850

    R7 1700@3.8GHz - Archon IB-E X2 - Asus Crosshair VI Hero - G.Skill Trident Z 3200MHz C14 - Sapphire Fury X (1145/545 Custom ROM, ~17.2K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850


  8. #6
    Senior Member
    Join Date
    Mar 2015
    Location
    Lurking over a keyboard!
    Posts
    438
    Thanks
    216
    Thanked
    35 times in 33 posts
    • gupsterg's system
      • Motherboard:
      • Asus Maximus VII Ranger
      • CPU:
      • i5 4690K @ 4.9GHz
      • Memory:
      • Kingston HyperX Savage 2400Mhz 16GB
      • Storage:
      • Samsung 840 EVO 250GB + HGST 2TB
      • Graphics card(s):
      • Sapphire R9 Fury X
      • PSU:
      • Cooler Master V850
      • Case:
      • Silverstone Temjin 06 plus mods ;)
      • Operating System:
      • Win 7 Pro x64 / Win 10 Pro x64
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • TalkTalk VDSL

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    Well have called MS, spent I think so far 1hr plus on the phone (as I type I'm now waiting again for someone to help).

    My key has been verified as genuine retail and English language should be there but isn't. I keep getting told to try the same site as I have, also got an email for a dept that may send an actual disc but IIRC I swear there was mention on the web ages ago that discs were not available anymore.

    And it looks like I'm not the only one with this issue, Link 1, 2.
    i5 4690K @ 4.9GHz CPU@1.255v 4.4GHz Cache@1.10v - Archon SB-E X2 - Asus Maximus VII Ranger
    Kingston HyperX Savage 16GB@2400MHz 1T - Sapphire R9 Fury X (1145/545 Custom ROM, ~17.7K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850

    R7 1700@3.8GHz - Archon IB-E X2 - Asus Crosshair VI Hero - G.Skill Trident Z 3200MHz C14 - Sapphire Fury X (1145/545 Custom ROM, ~17.2K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850


  9. #7
    Old and VERY grumpy. g8ina's Avatar
    Join Date
    Nov 2006
    Location
    In a world of pain. Fibromyalgia UK.
    Posts
    6,346
    Thanks
    2,173
    Thanked
    1,418 times in 961 posts
    • g8ina's system
      • Motherboard:
      • ASRock Z75 Pro3
      • CPU:
      • QuadCore Intel Core i5-3570K, 3600 MHz
      • Memory:
      • 16GB Corsair 1600MHz DDR3.
      • Storage:
      • 250GB SSD system + 1TB data, + 6.5TB NAS
      • Graphics card(s):
      • AMD Radeon HD 6800 Series (1 GB)
      • Case:
      • Coolermaster Elite 430
      • Operating System:
      • Win7
      • Monitor(s):
      • Iiyama 22"
      • Internet:
      • Virgin 100MB unlimited

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    I just double checked with my Win7 64 bit English and it accepted my s/n no problem.... Same website as listed above.

  10. Received thanks from:

    gupsterg (07-12-2015)

  11. #8
    Senior Member
    Join Date
    Mar 2015
    Location
    Lurking over a keyboard!
    Posts
    438
    Thanks
    216
    Thanked
    35 times in 33 posts
    • gupsterg's system
      • Motherboard:
      • Asus Maximus VII Ranger
      • CPU:
      • i5 4690K @ 4.9GHz
      • Memory:
      • Kingston HyperX Savage 2400Mhz 16GB
      • Storage:
      • Samsung 840 EVO 250GB + HGST 2TB
      • Graphics card(s):
      • Sapphire R9 Fury X
      • PSU:
      • Cooler Master V850
      • Case:
      • Silverstone Temjin 06 plus mods ;)
      • Operating System:
      • Win 7 Pro x64 / Win 10 Pro x64
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • TalkTalk VDSL

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    g8ina,

    Thank you for trying.





    i5 4690K @ 4.9GHz CPU@1.255v 4.4GHz Cache@1.10v - Archon SB-E X2 - Asus Maximus VII Ranger
    Kingston HyperX Savage 16GB@2400MHz 1T - Sapphire R9 Fury X (1145/545 Custom ROM, ~17.7K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850

    R7 1700@3.8GHz - Archon IB-E X2 - Asus Crosshair VI Hero - G.Skill Trident Z 3200MHz C14 - Sapphire Fury X (1145/545 Custom ROM, ~17.2K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850


  12. #9
    Old and VERY grumpy. g8ina's Avatar
    Join Date
    Nov 2006
    Location
    In a world of pain. Fibromyalgia UK.
    Posts
    6,346
    Thanks
    2,173
    Thanked
    1,418 times in 961 posts
    • g8ina's system
      • Motherboard:
      • ASRock Z75 Pro3
      • CPU:
      • QuadCore Intel Core i5-3570K, 3600 MHz
      • Memory:
      • 16GB Corsair 1600MHz DDR3.
      • Storage:
      • 250GB SSD system + 1TB data, + 6.5TB NAS
      • Graphics card(s):
      • AMD Radeon HD 6800 Series (1 GB)
      • Case:
      • Coolermaster Elite 430
      • Operating System:
      • Win7
      • Monitor(s):
      • Iiyama 22"
      • Internet:
      • Virgin 100MB unlimited

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    gupsterg, Ive sent you a PM.

  13. Received thanks from:

    gupsterg (07-12-2015)

  14. #10
    Senior Member
    Join Date
    Mar 2015
    Location
    Lurking over a keyboard!
    Posts
    438
    Thanks
    216
    Thanked
    35 times in 33 posts
    • gupsterg's system
      • Motherboard:
      • Asus Maximus VII Ranger
      • CPU:
      • i5 4690K @ 4.9GHz
      • Memory:
      • Kingston HyperX Savage 2400Mhz 16GB
      • Storage:
      • Samsung 840 EVO 250GB + HGST 2TB
      • Graphics card(s):
      • Sapphire R9 Fury X
      • PSU:
      • Cooler Master V850
      • Case:
      • Silverstone Temjin 06 plus mods ;)
      • Operating System:
      • Win 7 Pro x64 / Win 10 Pro x64
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • TalkTalk VDSL

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    Finished chatting with level 2 support, unfortunately no help they could give!

    One even told me to contact manufacturer of PC, I said it's custom and I'm the manufacturer! (LOL)

    Level 1 had remoted into my PC to see whatever they wanted, I also showed my ebuyer account with invoice for purchase of Win 7 Pro.

    Puts a real bitter taste when you've paid retail.

    Gonna email the replacement media team to see what they say, as advised by level 1 & 2 techs.

    I'm just glad I've got my own slipstream ISOs .
    i5 4690K @ 4.9GHz CPU@1.255v 4.4GHz Cache@1.10v - Archon SB-E X2 - Asus Maximus VII Ranger
    Kingston HyperX Savage 16GB@2400MHz 1T - Sapphire R9 Fury X (1145/545 Custom ROM, ~17.7K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850

    R7 1700@3.8GHz - Archon IB-E X2 - Asus Crosshair VI Hero - G.Skill Trident Z 3200MHz C14 - Sapphire Fury X (1145/545 Custom ROM, ~17.2K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850


  15. #11
    Old and VERY grumpy. g8ina's Avatar
    Join Date
    Nov 2006
    Location
    In a world of pain. Fibromyalgia UK.
    Posts
    6,346
    Thanks
    2,173
    Thanked
    1,418 times in 961 posts
    • g8ina's system
      • Motherboard:
      • ASRock Z75 Pro3
      • CPU:
      • QuadCore Intel Core i5-3570K, 3600 MHz
      • Memory:
      • 16GB Corsair 1600MHz DDR3.
      • Storage:
      • 250GB SSD system + 1TB data, + 6.5TB NAS
      • Graphics card(s):
      • AMD Radeon HD 6800 Series (1 GB)
      • Case:
      • Coolermaster Elite 430
      • Operating System:
      • Win7
      • Monitor(s):
      • Iiyama 22"
      • Internet:
      • Virgin 100MB unlimited

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    and to close - I also tried the key that gupsterg was using (now all deleted) and I confirm that the key did offer the correct version of Windows, but did NOT offer English as the language, very peculiar !

  16. Received thanks from:

    gupsterg (07-12-2015)

  17. #12
    DILLIGAF GoNz0's Avatar
    Join Date
    Jun 2006
    Location
    Derby
    Posts
    10,871
    Thanks
    632
    Thanked
    1,192 times in 945 posts
    • GoNz0's system
      • Motherboard:
      • Asus Rampage V Extreme
      • CPU:
      • i7 something X99 based
      • Memory:
      • 16gb GSkill
      • Storage:
      • 4 SSD's + WD Red
      • Graphics card(s):
      • GTX980 Strix WC
      • PSU:
      • Enermax Galaxy 1250 (9 years and counting)
      • Case:
      • Corsair 900D
      • Operating System:
      • win10 64bit
      • Monitor(s):
      • Dell 24"
      • Internet:
      • 220mb Cable

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    why not take the iso and burn it to usb with rufus in uefi mode, also is csm disabled in your BIOS to force a secure boot and allow uefi install?

    Capitalization is the difference between helping your Uncle Jack
    off a horse and helping your uncle jack off a horse.

  18. Received thanks from:

    gupsterg (08-12-2015)

  19. #13
    Senior Member watercooled's Avatar
    Join Date
    Jan 2009
    Posts
    11,177
    Thanks
    1,519
    Thanked
    978 times in 837 posts

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    Do you have access to any English Win7 isos for the architecture (32/64) you're after? Because the media are identical identical except for an embedded configuration file, the deletion of which creates a 'universal disc' you can use to install most versions of Windows (e.g. starter/home/pro/etc).

    Details here: http://code.kliu.org/misc/winisoutils/

    If you're stuck, I might be able to send you a spare? PM me if so.

  20. Received thanks from:

    gupsterg (08-12-2015)

  21. #14
    Senior Member
    Join Date
    Mar 2015
    Location
    Lurking over a keyboard!
    Posts
    438
    Thanks
    216
    Thanked
    35 times in 33 posts
    • gupsterg's system
      • Motherboard:
      • Asus Maximus VII Ranger
      • CPU:
      • i5 4690K @ 4.9GHz
      • Memory:
      • Kingston HyperX Savage 2400Mhz 16GB
      • Storage:
      • Samsung 840 EVO 250GB + HGST 2TB
      • Graphics card(s):
      • Sapphire R9 Fury X
      • PSU:
      • Cooler Master V850
      • Case:
      • Silverstone Temjin 06 plus mods ;)
      • Operating System:
      • Win 7 Pro x64 / Win 10 Pro x64
      • Monitor(s):
      • Asus MG279Q
      • Internet:
      • TalkTalk VDSL

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    Quote Originally Posted by GoNz0 View Post
    why not take the iso and burn it to usb with rufus in uefi mode, also is csm disabled in your BIOS to force a secure boot and allow uefi install?
    Hi GoNz0,

    Yep already done chap! I have an SP1 ISO, created from my original non SP1 x64 DVD, I also used Agent's windows 7 patcher (available here on hexus). Seen the ROG guide and yourself about on ROG forum but to get Win 7 UEFI mode I have to not disable CSM, check linked thread in post 1; that issue is solved.

    I was just shocked to find my key doesn't allow me a download from MS product recovery site, hence the thread to see if there are others having same experience.

    Thanks for taking the time to post.

    Quote Originally Posted by watercooled View Post
    Do you have access to any English Win7 isos for the architecture (32/64) you're after? Because the media are identical identical except for an embedded configuration file, the deletion of which creates a 'universal disc' you can use to install most versions of Windows (e.g. starter/home/pro/etc).

    Details here: http://code.kliu.org/misc/winisoutils/

    If you're stuck, I might be able to send you a spare? PM me if so.
    Many thanks watercooled ,

    I am sorted, I know how to make all edition ISO , I'm not a power user but not new to slipstreaming (used to dabble in this with XP), again just shocked my key doesn't allow download via MS site.
    Last edited by gupsterg; 08-12-2015 at 01:30 AM.
    i5 4690K @ 4.9GHz CPU@1.255v 4.4GHz Cache@1.10v - Archon SB-E X2 - Asus Maximus VII Ranger
    Kingston HyperX Savage 16GB@2400MHz 1T - Sapphire R9 Fury X (1145/545 Custom ROM, ~17.7K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850

    R7 1700@3.8GHz - Archon IB-E X2 - Asus Crosshair VI Hero - G.Skill Trident Z 3200MHz C14 - Sapphire Fury X (1145/545 Custom ROM, ~17.2K 3DM FS)
    Samsung 840 Evo 250GB - Cooler Master V850


  22. #15
    DILLIGAF GoNz0's Avatar
    Join Date
    Jun 2006
    Location
    Derby
    Posts
    10,871
    Thanks
    632
    Thanked
    1,192 times in 945 posts
    • GoNz0's system
      • Motherboard:
      • Asus Rampage V Extreme
      • CPU:
      • i7 something X99 based
      • Memory:
      • 16gb GSkill
      • Storage:
      • 4 SSD's + WD Red
      • Graphics card(s):
      • GTX980 Strix WC
      • PSU:
      • Enermax Galaxy 1250 (9 years and counting)
      • Case:
      • Corsair 900D
      • Operating System:
      • win10 64bit
      • Monitor(s):
      • Dell 24"
      • Internet:
      • 220mb Cable

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    I would go to My Digital Life and have a look at the win7 section as they have all the ISO's for legitimate download, sometimes a direct link to MS as well. I always check the file hash with technet to be 101% sure it is what I expect it to be.

    Capitalization is the difference between helping your Uncle Jack
    off a horse and helping your uncle jack off a horse.

  23. Received thanks from:

    gupsterg (08-12-2015)

  24. #16
    Senior Member watercooled's Avatar
    Join Date
    Jan 2009
    Posts
    11,177
    Thanks
    1,519
    Thanked
    978 times in 837 posts

    Re: English Windows 7 SP1 ISO not listed on Microsoft Product Recovery site

    Is that still possible? IIRC the ISO download links don't work any more, forcing you to use that recovery media downloaded instead.

  25. Received thanks from:

    gupsterg (08-12-2015)

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •