Results 1 to 2 of 2

Thread: Unable to join SBS AD N5200RouStor

  1. #1
    Registered User
    Join Date
    Nov 2007
    0 times in 0 posts

    Unable to join SBS AD N5200RouStor

    A few months ago, my N5200RouStor started develloping problems on syncronizing user accounts with my AD and had issues with SMB access after a test in which I connected the WAN interface to my perimiter network (to allow external FTP access) and the LAN interface to the inner network. This didn't work and I lost communication with the N5200 completely. I've returned to the original settings where only the WAN interface was connected to the inner network (since it's primarily used for SMB access).

    I decided to remove the N5200 from the domain, and then rejoin again under the Administrator account. This came with a whole load of issues and I ended up only being able to rejoin the domain under a different account with Domain Admin privileges, but syncronisation with the AD was restored.

    Now, this has worked for quite a couple of weeks, but stopped working a couple of weeks ago. Redid the procedure, but this didn't work either. What happens is the browser asks me for confirmation whether I'm sure I want to enable ADS, I click "yes", and it begins loading the page, but never finishes (like it's waiting for a response, but never receives one). During this operation (and many minutes after) the N5200 also stops being reachable under netbios name (it does still reply to a ping, but the webinterface won't load entering the hostname). However, when you try reaching on by entering the IP, the interface will come up strait away. After a while, using the NetBios name will work again as well.
    Altough the operation never finishes with a success, it will still successfully generate a computer account in the ADS, but the N5200 will remain with the ADS option disabled.

    Interesting enough, when you try joining the domain with a faulty password or an account that doesn't have permission, it'll throw an error saying either an incorrect password or an account with insufficient permissions is being used. Also in this scenario, when an account for the N5200 already exists in the domain it'll come back with a warning saying so, as opposed to the scenario where we use valid credentials.

    Below I'll try and give some information about my network infrastructure since it's not your everyday SOHO setup.

    My network is consisting out of a perimeter network in the 192.168.1.x subnet and a inner network in the 192.168.0.x subnet, seperated through a Linksys WRT-300. I'm connected to the internet using a Draytek Vigor 2800VGi.

    I've got a Windows 2003 Small Business Server with a dual NIC running as a domain controller, one NIC attached to the perimeter network (firewalled used to expose IIS and Exchange to the Internet), one (unfirewalled) to the inner network, used for everything else + IIS and Exchange.
    On the SBS server I've got two virtual servers running a LAMP and a Squid reverse Proxy server, both connected to the perimeter network with their own IPs in the 192.168.1.x subnet.

    Internet <-- 2800VGi --> 192.168.1.x (SBS/LAMP/Squid)<-- WRT300 --> 192.168.0.x (SBS/N5200/Workstations)

    The DHCP and DNS services are only running on the "LAN NIC", so on the 192.168.0.x subnet. <--DMZ NIC (no DNS, DHCP, etc)--> SBS <--LAN NIC--> (DNS, DHCP, etc)

    DMZ NIC:
    Default Gateway:

    LAN NIC:
    Default Gateway: -

    The N5200 is connected through the WAN interface to a 5-port GB switch with all the network drives on, which is on it's turn connected to the main switch, a 3Com Baseline Switch 2816-SFP Plus (divided into two VLANs, one for the perimeter, one for the inner) on the inner VLAN. The LAN interface of the N5200 is not used, the subnet of the LAN interface is set to 192.168.254.x, DHCP server is turned off and IP sharing disabled.

    DHCP in the perimeter network is handled by the Vigor, inner network is done by the SBS server using the following settings:

    Default Gateway: (WRT300, which on it's turn routes to, the Vigor)
    DNS: (SBS)

    The N5200 has a reservation on IP

    To me, everything seems honkeydory. I've tried joining and removing Windows XP workstations into the domain using the same credentials which didn't cause any trouble at all.

    Seeing the results when using the faulty credentials and the fact that it does create an account in the AD for the N5200, it seems it does communicate properly with the server initially, but somewhere along the line upon finishing, the communication appears to breaks down.
    A problem that came into my mind is that the SBS server responds on the other NIC and therefor not reaching the N5200, but that would mean I couldn't join ANY computer attached through the inner network. The DNS name of the DC (SBS) does nicely resolve to the address btw, so I'm sure the request is directed to this IP.

    Any ideas on what could be the issue? If you'd like any more information or a more detailed schematic view on the infrastructure, I'd be happy to provide them.

    Firmware used is 2.00.01.

    Thanks in advance.

  2. #2
    Thecus Staff Thecus - Yvon's Avatar
    Join Date
    Apr 2007
    8 times in 8 posts

    Re: Unable to join SBS AD N5200RouStor

    Dear Sir,

    I might need to confirm follwoing items:

    1. Is there any other trust AD with this AD?
    2. Does this AD have alias name?
    3. Does Netlogon service is enabled?
    4. Does Windows Time service is enabled?

    Additionally, I would recommend diagnostic DC through Domain Controller Diagnostics Tool (dcdiag.exe)

    in case the problem still exist, please enable System Log through below URL


    After the System Log service is enabled, please try join to AD again, those login log will save into “tmp” folder under Nsync folder.

    Please send the config.bin and all files & folders under Nsync folder to . The config.bin can be downloaded from [System / Mgmt] page and then press [Download] button.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bobster....join us....
    By Zak33 in forum Software
    Replies: 9
    Last Post: 09-10-2007, 09:17 AM
  2. Please help - Unable to connect to website
    By jonnylew in forum Help! Quick Relief From Tech Headaches
    Replies: 11
    Last Post: 03-10-2006, 05:09 PM
  3. Come on ppl JOIN UD and put your CPU to good use.
    By Nick F in forum General Discussion
    Replies: 43
    Last Post: 21-04-2005, 07:36 AM
  4. Want to join
    By ravenblood in forum PC
    Replies: 5
    Last Post: 12-03-2005, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts