Results 1 to 2 of 2

Thread: H100 pump clicking

  1. #1
    Registered+
    Join Date
    Apr 2012
    Posts
    39
    Thanks
    4
    Thanked
    1 time in 1 post
    • davig019's system
      • CPU:
      • Q8400
      • Storage:
      • 1Tb wd Black
      • Graphics card(s):
      • 9800GT
      • PSU:
      • HX750
      • Case:
      • Haf 932
      • Operating System:
      • Win 7 ultimate x64
      • Monitor(s):
      • 2x generic 720p

    H100 pump clicking

    I installed my H100 today and the pump is making a clicking noise like a hard drive.

    I can stop the noise by flicking the tube but the noise will return after a few seconds, i have also tried turning the case on its side which stops the noise but as i have a full tower case this is not an option for more than an hour or so.

    what can i do to get rid of this annoying noise?!

    Thanks

  2. #2
    DILLIGAF GoNz0's Avatar
    Join Date
    Jun 2006
    Location
    Derby
    Posts
    10,833
    Thanks
    622
    Thanked
    1,179 times in 938 posts
    • GoNz0's system
      • Motherboard:
      • Asus Rampage V Extreme
      • CPU:
      • i7 something X99 based
      • Memory:
      • 16gb GSkill
      • Storage:
      • 4 SSD's + WD Red
      • Graphics card(s):
      • GTX980 Strix WC
      • PSU:
      • Enermax Galaxy 1250 (9 years and counting)
      • Case:
      • Corsair 900D
      • Operating System:
      • win10 64bit
      • Monitor(s):
      • Dell 24"
      • Internet:
      • 220mb Cable

    Re: H100 pump clicking

    run it for 24 hours until the air bubbles hide in the top of the rad out of harms way.

    Capitalization is the difference between helping your Uncle Jack
    off a horse and helping your uncle jack off a horse.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •