Results 1 to 2 of 2

Thread: NF7-S v2.0 / Sil3112 / Sil3114 - Boot ERROR

  1. #1
    Registered User
    Join Date
    Apr 2007
    0 times in 0 posts

    NF7-S v2.0 / Sil3112 / Sil3114 - Boot ERROR

    NF7-S v2.0 / Sil3112 / Sil3114 - Boot priority ERROR


    I hope some one can help me to solve my problem.

    First my hardware:

    Athlon XP 1800+ @ 2000 MHz
    Abit NF7-S V2.0 Bios D27 + Onboard Sil3112 SATA150 - RAID Bios 4.2.83
    2x512 MB Corsair CL2. RAM Dual Channel Mode
    nVidia GF5900 AGP 128MB
    2xHitachi 160GB SATA2 HDD RAID0 connected to Sil3112 with OS: Windows XP
    1x Samsung 320GB SATA2 HDD for testing proposes.
    1x IBM DeskStar 60GB IDE for testing proposes.

    NEW: Sil3114 PCI Add-on 4-Port SATA150 controller SATA-Link (IDE) Bios

    I have the main-board mentioned above and use the on board SATA-RAID
    controller Sil3112 with two 160GB Hitachi SATA-HDD in RAID0 Mode.
    The Sil3112 worked and works without any problems since I ever set up my RAID0.

    Recently I have added a Sil3114 4-Port SATA150 PCI Controller to get rid of the IDE stuff.
    Connected to this controller are now my new optical SATA-DVD-ROM and SATA-DVD-RW.

    The whole system (Mainboard+Sill3112 / Sil3114 / SATA-DVD-ROM / SATA DVD-RW)
    has the newest available Bios/Firmware versions. These are also checked for RAID or IDE use.

    Now my problem:
    I am able to boot to Windows XP with NO devices connected to Sil3114, the controller is recognized correctly and drivers are installed without any problems.

    I am able to boot to Windows XP with the Samsung 320GB SATA2 HDD connected to Sil3114.
    The HDD is recognized correctly and functions properly.

    I am NOT able to boot to Windows XP when optical devices are connected to Sil3114.
    The system hangs at the point where the DMI POOL Data is checked and the ESCD is updated.
    I have tried any possible boot order available in the main-board Bios, none is working.

    For testing proposes I disconnected my RAID0 set of disks,
    leaving the onboard Sil3112 enabled with no disks connected.
    The optical devices are still connected to the Sil3114.
    I was able to boot from a bootable CD/DVD from both of my optical devices.
    After this test I installed the IBM DeskStar IDE HDD to my first IDE Port and
    tried to installed Windows XP with the boot CD/DVD from the optical devices.
    The installation procedure and the boot to the OS worked without any errors and problems.

    The testing points to a boot conflict with optical devices connected to Sil3114, which is not solvable by the current boot configuration provided in the main-board Bios.

    Additional tests with a combination of Sil3114 and the onboard IDE controller shows
    that the boot up to Windows XP works and all optical devices function properly.
    At the boot process the Sil3114 checks for any bootable media found in the optical devices.
    If no bootable media is present it hands the boot procedure over to the internal IDE controller, which boots from the freshly installed OS on the IBM DeskStar HDD.

    I additional checks from different main-boards over the
    internet and the Bios options provided in the manuals,
    some main-boards offer settings called “boot priority”
    and the additional option called “On-Board Controllers first”.

    My question is, is there a possibility to enable or add such an option to the Abit NF7-S v2.0 Bios.
    Did someone have or had the same problem or a solution?

    Many thanks in advance for any kind help and ideas.


  2. #2
    Registered User
    Join Date
    Jan 2008
    0 times in 0 posts

    Wink Re: NF7-S v2.0 / Sil3112 / Sil3114 - Boot ERROR

    Hi there,
    I have similar condition as yours.
    My mb is also NF7S-2.0.
    And I have two SATA HD connected to a PCI SATA card for a raid 0 set.
    One SATA HD connects to mb SATA port 1.
    One SATA DVD-ROM connects to mb SATA port 0.

    I've tried different states to boot from different device, and I want to share my experience with you and others.

    State 1:
    I usually boot from the raid 0 set, ie. from the PCI SATA card.
    In the BIOS setting, the sata function is enable, but the SATA ROM is disable.
    In "Advanced BIOS Feature," the "Boot Other Device" is enable.
    Then my PC would boot from the raid 0 set. (WinXP)

    State 2:
    I also have another OS (Vista) on the single SATA HD.
    When I want to boot from this HD, I just set tht SATA function as enable and the SATA ROM is also enable in the BIOS settings.
    Furthermore, the first boot device is set to HDD-0.
    Then my PC would boot from this HD.

    State 3:
    When I want to boot from my optical device, ie. from a bootable CD or DVD,
    the BIOS setting is just like State 2 but the first boot device is set to CD-ROM.
    Then my PC would boot from the optical device.

    ps. All of my SATA devices are connected in these three different states.
    (two to PCI card, two to mb SATA port)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Windows - boot process & simple troubleshooting
    By Paul Adams in forum Software
    Replies: 30
    Last Post: 17-11-2010, 04:38 AM
  2. Prob. with Norton GoBack & boot error
    By MSIC in forum Help! Quick Relief From Tech Headaches
    Replies: 2
    Last Post: 15-07-2007, 06:19 PM
  3. Windows - a brief guide inside
    By Paul Adams in forum Software
    Replies: 31
    Last Post: 23-06-2007, 03:14 PM
  4. Load Error! Acer laptop will not boot
    By sinar in forum Help! Quick Relief From Tech Headaches
    Replies: 2
    Last Post: 02-10-2006, 04:00 PM
  5. 8o!! taste hot WineX powaaah!
    By directhex in forum Software
    Replies: 33
    Last Post: 31-05-2004, 08:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts