Results 1 to 3 of 3

Thread: Need help with flashing bios abit kn9 sli

  1. #1
    Registered User
    Join Date
    May 2012
    Posts
    1
    Thanks
    0
    Thanked
    0 times in 0 posts

    Need help with flashing bios abit kn9 sli

    found a abit kn9 sli just sitting at a thrift store decided to buy it
    got all the parts for the build sitting here with just a standard vga connection
    and everytime i try to install my video card it freezes up at windows 7 startup.
    blue screens and something about atikmdag- atikmpag(not exactly how you spell it)
    pretty sure its because the bios hasnt been updated since 2007 and
    since the abit site is down and no more downloads of the bios update
    im hoping to come to my last stop here.

    video card is a radeon hd 4850

    please and thanks in advanced

  2. #2
    Senior Member
    Join Date
    Feb 2012
    Location
    Duisburg, Germany
    Posts
    273
    Thanks
    29
    Thanked
    45 times in 40 posts
    • Bambooz's system
      • Motherboard:
      • Asus ROG Strix X470-F
      • CPU:
      • Ryzen 7 3700X + Thermalright Macho Rev.2 (BW)
      • Memory:
      • 32GB Crucial Ballistix Sport LT (E-Die) DDR4-3200 @ 3600
      • Storage:
      • SKhynix BC501 256GB NVMe SSD (to be replaced) + 2x 8TB WD Red + 1TB Crucial MX200 (games)
      • Graphics card(s):
      • MSI Geforce GTX 1080 Gaming X 8GB
      • PSU:
      • Seasonic Platinum Fanless 520W (SS-520FL2)
      • Case:
      • Fractal Design Arc XL
      • Operating System:
      • Win 10 Pro (blergh)
      • Monitor(s):
      • Samsung S27D850T (27" 1440p) + 2x Samsung 2333T (23" 1080p)
      • Internet:
      • VDSL 100/40mbps

    Re: Need help with flashing bios abit kn9 sli

    Sounds like AMD/ATI driver problems, rather than BIOS issues. Maybe try a different card?

    The newest BIOS for the KN9 SLI is V23, dated November 19th 2007.

    ftp://91.121.194.115/pub/download/bios/kn9/m520a23.zip

  3. #3
    Registered User
    Join Date
    Mar 2015
    Posts
    1
    Thanks
    0
    Thanked
    1 time in 1 post

    Re: Need help with flashing bios abit kn9 sli

    Quote Originally Posted by Bambooz View Post
    Sounds like AMD/ATI driver problems, rather than BIOS issues. Maybe try a different card?

    The newest BIOS for the KN9 SLI is V23, dated November 19th 2007.
    Hi from the future, thanks Bambooz, this just helped me =)

  4. Received thanks from:

    Millennium (24-03-2015)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •