Page 1 of 2 12 LastLast
Results 1 to 16 of 19

Thread: Help with 'Black and White'

  1. #1
    Registered+
    Join Date
    Aug 2003
    Posts
    29
    Thanks
    0
    Thanked
    0 times in 0 posts

    Help with 'Black and White'

    Lo all,
    I've recently reinstalled 'Black and White' onto my PC, but its not working now (it was half a year ago) and so I was wondering if any of you guys can help. There are 2 things i think might have caused it; it might be something to do with Windows XP, or it might be to do with our graphics card that we recently installed (my brother is TomWilko, so a few of you know the cards spec's coz he posted them up here).

    What happens is when i try to load it up (either by using the CD's menu screen or the icon in the folder) is i get the following message;

    runblack.exe has encountered a problem and needs to close. We are sorry for the inconvenience.
    That is what happens if i run it under Windows 2000/Me compatability. If i run it with the compatability as default, it has a DOS window appear for a split second (no text appears in this as far as i can see) and then that disapears and nothing happens.

    Because its the only major thing thats changed, i imagine its the Graphics Card (it worked with XP on the PC before)... however there is a patch out for 'Black and White' (patch is 1.2) that i read somewhere cures a lot of XP problems. If anyone who plays 'Black and White' has a copy of the patch, could you send it please?

    Any advice and Information you can give is greatly appreciated, so thanks a lot in advance.

    Erotic Bootlace

    (P.S. I'm also having some Max Payne and Commandos 2 problems, but those are for another time...).

  2. #2
    cat /dev/null streetster's Avatar
    Join Date
    Jul 2003
    Location
    London
    Posts
    4,138
    Thanks
    119
    Thanked
    100 times in 82 posts
    • streetster's system
      • Motherboard:
      • Asus P7P55D-E
      • CPU:
      • Intel i5 750 2.67 @ 4.0Ghz
      • Memory:
      • 4GB Corsair XMS DDR3
      • Storage:
      • 2x1TB Drives [RAID0]
      • Graphics card(s):
      • 2xSapphire HD 4870 512MB CrossFireX
      • PSU:
      • Corsair HX520W
      • Case:
      • Coolermaster Black Widow
      • Operating System:
      • Windows 7 x64
      • Monitor(s):
      • DELL U2311
      • Internet:
      • Virgin 50Mb

  3. #3
    Registered+
    Join Date
    Aug 2003
    Posts
    29
    Thanks
    0
    Thanked
    0 times in 0 posts
    Sorry i forgot to mention... patch 1.3 is for using the 'Minority Report' syle Gaming Glove to play 'Black and White' with, and apparently messes up your PC if you install it and don't have the hardware. Personally, i don't see how it can, so I'll look into downloading that if it says it does anything else like makest he game more stable.

    I am more interested in 1.2 (can't find it anywhere), but thanks anyway for the links.

  4. #4
    Going Retro!!! Ferral's Avatar
    Join Date
    Jul 2003
    Location
    North East
    Posts
    7,854
    Thanks
    551
    Thanked
    1,426 times in 873 posts
    • Ferral's system
      • Motherboard:
      • ASUS Z97-P
      • CPU:
      • Intel i7 4790K Haswell
      • Memory:
      • 12Gb Corsair XMS3 DDR3 1600 Mhz
      • Storage:
      • 120Gb Kingston SSD & 2 Tb Toshiba
      • Graphics card(s):
      • Sapphire Radeon R9 380 Nitro 4Gb
      • PSU:
      • Antec Truepower 750 Watt Modular
      • Case:
      • Fractal Design Focus G Mid Tower
      • Operating System:
      • Windows 10 64 bit
      • Monitor(s):
      • 28" iiyama Prolite 4K
      • Internet:
      • 80Mb BT Fiber
    Max Payne requires the patch to make it run under XP or it jumps out into Windows.

    The problem that you are experiencing sounds like it could be memory timings in the bios. Also set all the graphics card options to default. When that happens it sounds like Windows is having difficulty starting something up. Might be worth setting the pagefile to default also on XP if you have custom settings

  5. #5
    Registered+
    Join Date
    Aug 2003
    Posts
    29
    Thanks
    0
    Thanked
    0 times in 0 posts
    Originally posted by Ferral
    Max Payne requires the patch to make it run under XP or it jumps out into Windows.

    The problem that you are experiencing sounds like it could be memory timings in the bios. Also set all the graphics card options to default. When that happens it sounds like Windows is having difficulty starting something up. Might be worth setting the pagefile to default also on XP if you have custom settings
    Thanks but... how would i go about doing those? I imagine Tom knows how, but he is a bit touchy about donig stuff for me in his time on the PC (coz he doesn't get much tiem on here).

    For Max Payne, it works fine except that the sounds are all static and popping, and none of the in-game dialogue like Gangsters talking to eachother works at all (it kinda starts then desintergrates into a nasty static that my ears dislike a lot...). In the official FAQ it tells you to turn an option on, but it isn't in my control panel [].

    But I'd rather get 'Black and WHite' Sorted first because thats what i want to play at the moment. I'll be asking about Max Payne in a seperate thread some other time.

  6. #6
    "Are you local?" Ravens Nest's Avatar
    Join Date
    Jul 2003
    Location
    Royston Vasey
    Posts
    1,653
    Thanks
    40
    Thanked
    77 times in 45 posts
    • Ravens Nest's system
      • Motherboard:
      • Gigabyte Z270 Gaming K3
      • CPU:
      • Intel i5 6600K
      • Memory:
      • 16gb DDR4 3200mhz
      • Storage:
      • 1tb Crucial 500 SSD, 256GB Micron M550 SSD, 2TB Hitachi HDD.
      • Graphics card(s):
      • Gigabyte NVIDIA GTX 970 G1 Gaming Edition
      • PSU:
      • 550W Corsair
      • Operating System:
      • Windows 10 Home 64bit
    Last edited by Ravens Nest; 23-10-2003 at 10:58 PM.
    "Mmm... I want you for my wife!"
    "Autom...Sprow...Canna...Tik banna...Sandwol...But no sera smee?"
    "Of course you can. We would love for you to join us."

  7. #7
    Registered+
    Join Date
    Aug 2003
    Posts
    29
    Thanks
    0
    Thanked
    0 times in 0 posts
    I'm afraid that page doesn't load up, any chance of a quote please?

  8. #8
    Sexiest Hexus user? quite possibly Russ's Avatar
    Join Date
    Jul 2003
    Location
    North Norfolk
    Posts
    5,200
    Thanks
    11
    Thanked
    69 times in 44 posts
    • Russ's system
      • Motherboard:
      • Apple Logic Board
      • CPU:
      • Core i5 2.8GHZ 8MB Cache
      • Memory:
      • 2x2GB
      • Storage:
      • 1TB
      • Graphics card(s):
      • ATI 5750
      • Case:
      • iMac
      • Operating System:
      • Mac OS X Snow Leopard
      • Monitor(s):
      • 27" iMac
      • Internet:
      • 2mb(on a good day)
    just get a crack fr no-cd off a site that supplies such evil things, maybe that will help?
    Last edited by directhex; 23-10-2003 at 11:14 PM.
    Gamertag - Russonf (xbox and ps3)

  9. #9
    "Are you local?" Ravens Nest's Avatar
    Join Date
    Jul 2003
    Location
    Royston Vasey
    Posts
    1,653
    Thanks
    40
    Thanked
    77 times in 45 posts
    • Ravens Nest's system
      • Motherboard:
      • Gigabyte Z270 Gaming K3
      • CPU:
      • Intel i5 6600K
      • Memory:
      • 16gb DDR4 3200mhz
      • Storage:
      • 1tb Crucial 500 SSD, 256GB Micron M550 SSD, 2TB Hitachi HDD.
      • Graphics card(s):
      • Gigabyte NVIDIA GTX 970 G1 Gaming Edition
      • PSU:
      • 550W Corsair
      • Operating System:
      • Windows 10 Home 64bit
    Erotic Bootlace, i've fixed the link and added others
    (Sorry had to go to work so could not check link properly)

    Good luck
    "Mmm... I want you for my wife!"
    "Autom...Sprow...Canna...Tik banna...Sandwol...But no sera smee?"
    "Of course you can. We would love for you to join us."

  10. #10
    Registered+
    Join Date
    Aug 2003
    Posts
    29
    Thanks
    0
    Thanked
    0 times in 0 posts
    Thanks Ravens Nest! All it needed was Patch 1.2! Rather odd that it used to work and then stopped, but i'm not complaining coz its as good as ever

  11. #11
    "Are you local?" Ravens Nest's Avatar
    Join Date
    Jul 2003
    Location
    Royston Vasey
    Posts
    1,653
    Thanks
    40
    Thanked
    77 times in 45 posts
    • Ravens Nest's system
      • Motherboard:
      • Gigabyte Z270 Gaming K3
      • CPU:
      • Intel i5 6600K
      • Memory:
      • 16gb DDR4 3200mhz
      • Storage:
      • 1tb Crucial 500 SSD, 256GB Micron M550 SSD, 2TB Hitachi HDD.
      • Graphics card(s):
      • Gigabyte NVIDIA GTX 970 G1 Gaming Edition
      • PSU:
      • 550W Corsair
      • Operating System:
      • Windows 10 Home 64bit
    Glad i could help Erotic bootlace

  12. #12
    Senior Member Scooby's Avatar
    Join Date
    Aug 2003
    Posts
    1,082
    Thanks
    6
    Thanked
    2 times in 2 posts
    Is this game sorted now as I used to play it but there was a glitch. Also when I got a patch I lost some saved games.

  13. #13
    Registered+
    Join Date
    Aug 2003
    Posts
    29
    Thanks
    0
    Thanked
    0 times in 0 posts
    Yes it is fully sorted now, the 1.2 patch cures 'Black and White' of a lot of XP glitches. If your looking at getting into 'Black and White' then i recommend that you get both patches, the football add-on and the 4 extra creatures, then starting a new game from scratch. If you lsoe save games you can make back-ups because of the files they are stored in, and you can also save creature minds.

  14. #14
    Registered User
    Join Date
    Sep 2006
    Posts
    2
    Thanks
    0
    Thanked
    0 times in 0 posts
    ok, i've got something else to add. i recently re-installed black and white on this computer, but the new one is the sold out software version. now when i play the game, the graphics go haywire. absolutely nuts. i've contacted sold out software, and they replied that i needed to install the version 1 patch for this game. only one problem with that... i already HAVE! they can't seem to answer any of my questions, so i figured, "what the heck" and decided to post on here, and see if any of you have heard of this problem.

    i am trying to run this game on an acer aspire
    hardware:
    amd sempron 3200+ 1.6 GHz processor
    nvidia GeForce 6100 256Mb
    448 Mb ram
    DirectX 9.0c
    Windows XP Home SP2

    anyone have any idea what's goin on?

  15. #15
    Are you Junglin' guy? jamin's Avatar
    Join Date
    Jul 2003
    Location
    Sunny Southend On Sea
    Posts
    921
    Thanks
    17
    Thanked
    11 times in 10 posts
    Sorry, cant resist mate.....

    Holy thread revival Batman!

    GFX drivers up to date?

    Latest patch installed?
    Beer is life, life is good!

  16. #16
    Registered User
    Join Date
    Sep 2006
    Posts
    2
    Thanks
    0
    Thanked
    0 times in 0 posts
    yeah, everything's up to date.... patches installed... version 1-3, but graphics are still messing up. game glitch maybe? something in the manufacturing?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •